aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/sloccount/Makefile12
-rw-r--r--misc/sloccount/files/patch-makefile12
-rw-r--r--misc/sloccount/pkg-plist1
3 files changed, 11 insertions, 14 deletions
diff --git a/misc/sloccount/Makefile b/misc/sloccount/Makefile
index a910118f6e2b..e6f7d0016496 100644
--- a/misc/sloccount/Makefile
+++ b/misc/sloccount/Makefile
@@ -16,19 +16,13 @@ INSTALL_TARGET= install_programs install_man
PORTDOCS= ChangeLog README TODO sloccount.html
-MAN1= sloccount.1
-MANCOMPRESSED= yes
-
-NO_STAGE= yes
post-install:
.for file in lexcount1 c_count java_count php_count
- @${STRIP_CMD} ${PREFIX}/bin/${file}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${file}
.endfor
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docs in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/misc/sloccount/files/patch-makefile b/misc/sloccount/files/patch-makefile
index a275791075e1..d9875329d44e 100644
--- a/misc/sloccount/files/patch-makefile
+++ b/misc/sloccount/files/patch-makefile
@@ -1,5 +1,5 @@
---- makefile.orig 2009-08-29 15:28:59.000000000 -0300
-+++ makefile 2009-08-29 15:30:34.000000000 -0300
+--- makefile.orig 2004-08-01 22:52:06.000000000 +0400
++++ makefile 2014-03-06 18:50:45.513966851 +0400
@@ -28,7 +28,6 @@
# Set this for where to store the man pages and executables.
# If you want to store this as part of an official distribution,
@@ -16,12 +16,14 @@
# Set this to the name of your "install" program. On some systems,
# "install -C" would be useful (so unchanged files won't be modified),
-@@ -70,7 +68,7 @@
+@@ -69,8 +67,8 @@
+ RPM_VERSION=1
ARCH=i386
VERSIONEDNAME=$(NAME)-$(VERSION)
- INSTALL_DIR=$(PREFIX)/bin
+-INSTALL_DIR=$(PREFIX)/bin
-MAN_DIR=$(PREFIX)/share/man
-+MAN_DIR=$(PREFIX)/man
++INSTALL_DIR=${DESTDIR}$(PREFIX)/bin
++MAN_DIR=${DESTDIR}$(PREFIX)/man
MAN_DIR_MAN1=$(MAN_DIR)/man1
DOC_DIR=$(PREFIX)/share/doc/$(VERSIONEDNAME)-$(RPM_VERSION)
POSTED_DIR=/home/dwheeler/dwheeler.com/sloccount
diff --git a/misc/sloccount/pkg-plist b/misc/sloccount/pkg-plist
index 919e3d2dceef..f9355d9a26eb 100644
--- a/misc/sloccount/pkg-plist
+++ b/misc/sloccount/pkg-plist
@@ -38,3 +38,4 @@ bin/show_filecount
bin/sloccount
bin/sql_count
bin/tcl_count
+man/man1/sloccount.1.gz