aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/boxer/Makefile5
-rw-r--r--graphics/cinepaint/Makefile3
-rw-r--r--graphics/commons-utilities/Makefile3
-rw-r--r--graphics/curator/Makefile5
-rw-r--r--graphics/diacanvas2/Makefile3
-rw-r--r--graphics/driconf/Makefile5
-rw-r--r--graphics/electrix/Makefile3
-rw-r--r--graphics/evolvotron/Makefile3
-rw-r--r--graphics/exact-image/Makefile3
-rw-r--r--graphics/gif2png/Makefile2
-rw-r--r--graphics/gimp-ez-perspective-plugin/Makefile3
-rw-r--r--graphics/gnofract4d/Makefile6
-rw-r--r--graphics/gsculpt/Makefile3
-rw-r--r--graphics/hugin/Makefile5
-rw-r--r--graphics/jbig2dec/Makefile2
-rw-r--r--graphics/kludge3d/Makefile3
-rw-r--r--graphics/lcms-python/Makefile2
-rw-r--r--graphics/mahotas/Makefile5
-rw-r--r--graphics/mapnik/Makefile3
-rw-r--r--graphics/ocrfeeder/Makefile3
-rw-r--r--graphics/opencolorio/Makefile2
-rw-r--r--graphics/pecomato/Makefile3
-rw-r--r--graphics/piddle/Makefile5
-rw-r--r--graphics/py-aafigure/Makefile5
-rw-r--r--graphics/py-blockdiagcontrib-cisco/Makefile5
-rw-r--r--graphics/py-cairo/Makefile3
-rw-r--r--graphics/py-django-easy-thumbnails/Makefile5
-rw-r--r--graphics/py-editobj/Makefile4
-rw-r--r--graphics/py-exif/Makefile2
-rw-r--r--graphics/py-exiv2/Makefile3
-rw-r--r--graphics/py-freeimagepy/Makefile6
-rw-r--r--graphics/py-gd/Makefile6
-rw-r--r--graphics/py-gimp/Makefile2
-rw-r--r--graphics/py-glewpy/Makefile4
-rw-r--r--graphics/py-goocanvas/Makefile3
-rw-r--r--graphics/py-graph-core/Makefile5
-rw-r--r--graphics/py-graph-dot/Makefile5
-rw-r--r--graphics/py-graph/Makefile3
-rw-r--r--graphics/py-graphviz/Makefile4
-rw-r--r--graphics/py-gvgen/Makefile5
-rw-r--r--graphics/py-openexr/Makefile9
-rw-r--r--graphics/py-paint/Makefile5
-rw-r--r--graphics/py-png/Makefile5
-rw-r--r--graphics/py-poppler-qt4/Makefile6
-rw-r--r--graphics/py-poppler/Makefile3
-rw-r--r--graphics/py-pycha/Makefile5
-rw-r--r--graphics/py-pydot/Makefile5
-rw-r--r--graphics/py-pygal/Makefile5
-rw-r--r--graphics/py-pygooglechart/Makefile5
-rw-r--r--graphics/py-pyproj/Makefile5
-rw-r--r--graphics/py-sane/Makefile4
-rw-r--r--graphics/py-webcolors/Makefile5
-rw-r--r--graphics/py3-cairo/Makefile3
-rw-r--r--graphics/pygts/Makefile5
-rw-r--r--graphics/pymorph/Makefile5
-rw-r--r--graphics/qgis/Makefile3
-rw-r--r--graphics/skencil/Makefile6
-rw-r--r--graphics/svgfig/Makefile5
-rw-r--r--graphics/tilecache/Makefile5
-rw-r--r--graphics/truevision/Makefile3
-rw-r--r--graphics/vigra/Makefile3
61 files changed, 97 insertions, 153 deletions
diff --git a/graphics/boxer/Makefile b/graphics/boxer/Makefile
index 25e218ebea52..864067edea25 100644
--- a/graphics/boxer/Makefile
+++ b/graphics/boxer/Makefile
@@ -20,9 +20,8 @@ LICENSE= GPLv3
RUN_DEPENDS= box:${PORTSDIR}/graphics/box
USE_GNOME= pygtk2
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
USE_LDCONFIG= yes
PLIST_FILES= share/pixmaps/${PORTNAME}.png
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 53de32fc252e..9fdd97f132c9 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -25,11 +25,10 @@ OPTIONS_DEFINE= OYRANOS PRINT
OYRANOS_DESC= ICC profile support via Oyranos
PRINT_DESC= Gutenprint (gimp-print) plugin
-USES= desktop-file-utils gettext gmake libtool pkgconfig
+USES= desktop-file-utils gettext gmake libtool pkgconfig python
USE_XORG= xmu
USE_GNOME= gtk20
USE_GHOSTSCRIPT_RUN=yes
-USE_PYTHON= yes
USE_AUTOTOOLS= libtoolize aclocal automake autoconf
ACLOCAL_ARGS= -I aclocal
AUTOMAKE_ARGS= --copy --force-missing --foreign --add-missing
diff --git a/graphics/commons-utilities/Makefile b/graphics/commons-utilities/Makefile
index 05c6d76deb94..0bdd02e007c6 100644
--- a/graphics/commons-utilities/Makefile
+++ b/graphics/commons-utilities/Makefile
@@ -20,9 +20,8 @@ RUN_DEPENDS= p5-Image-ExifTool>=0:${PORTSDIR}/graphics/p5-Image-ExifTool \
${PYTHON_PKGNAMEPREFIX}mechanize>=0.2:${PORTSDIR}/www/py-mechanize \
exiv2:${PORTSDIR}/graphics/exiv2
-USES= perl5
+USES= perl5 python
USE_PERL5= run
-USE_PYTHON= yes
NO_BUILD= yes
PLIST_FILES= bin/commons-csv-creator bin/commons-upload
diff --git a/graphics/curator/Makefile b/graphics/curator/Makefile
index 761b45a0c20f..2fb161234d30 100644
--- a/graphics/curator/Makefile
+++ b/graphics/curator/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Static Image Gallery Generator for web or CD-ROM galleries
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= PIL
PIL_DESC= Use Python Imaging Library instead of ImageMagick
diff --git a/graphics/diacanvas2/Makefile b/graphics/diacanvas2/Makefile
index 49675dd5cc08..2f9f9aa07570 100644
--- a/graphics/diacanvas2/Makefile
+++ b/graphics/diacanvas2/Makefile
@@ -13,9 +13,8 @@ COMMENT= General drawing canvas from dia dialog editor
LICENSE= GPLv2
-USES= gmake pathfix pkgconfig libtool
+USES= gmake libtool pathfix pkgconfig python
USE_GNOME= pygnome2
-USE_PYTHON= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/graphics/driconf/Makefile b/graphics/driconf/Makefile
index eca767795479..d1ec3dcef057 100644
--- a/graphics/driconf/Makefile
+++ b/graphics/driconf/Makefile
@@ -15,10 +15,9 @@ COMMENT= Configuration program for DRI drivers
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
USE_GL= glut
-USE_PYTHON= yes
+USE_PYTHON= distutils
NO_BUILD= yes
-USES= gettext
-USE_PYDISTUTILS= yes
+USES= gettext python
PYDISTUTILS_EGGINFODIR= ${STAGEDIR}${PREFIX}/lib/driconf
pre-patch:
diff --git a/graphics/electrix/Makefile b/graphics/electrix/Makefile
index 0c5593e8aca7..3cadee573e41 100644
--- a/graphics/electrix/Makefile
+++ b/graphics/electrix/Makefile
@@ -11,10 +11,9 @@ COMMENT= Application to view PDF files
LICENSE= GPLv2
-USES= pkgconfig desktop-file-utils
+USES= pkgconfig desktop-file-utils python:2
USE_BZIP2= yes
USE_GNOME= gtk20 glib20 intltool intlhack
-USE_PYTHON= 2
CONFIGURE_ARGS= --prefix=${STAGEDIR}${PREFIX}
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index 07036289fe85..66ff2219a061 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -19,9 +19,8 @@ LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= qmake
+USES= python qmake
USE_QT4= corelib gui xml moc_build
-USE_PYTHON= yes
QMAKE_ARGS+= VERSION_NUMBER="${PORTVERSION}"
QMAKE_SOURCE_PATH= ${WRKSRC}/main.pro
MAKE_JOBS_UNSAFE= yes
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 29985a270932..710e77e67cfa 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -28,8 +28,7 @@ CFLAGS+= -fPIC
#hack to get custom exactcode configure script to enable tiff support with
#broken headers on c++ in base system:
CPPFLAGS+= -fpermissive -I${LOCALBASE}/include/libpng15
-USES= gmake perl5 pkgconfig tar:bzip2
-USE_PYTHON= yes
+USES= gmake perl5 pkgconfig python tar:bzip2
USE_XORG= x11
USE_EFL= evas
USE_EFL_EVAS_ENGINES= x11 opengl
diff --git a/graphics/gif2png/Makefile b/graphics/gif2png/Makefile
index 7590097be0b7..b8c52328efea 100644
--- a/graphics/gif2png/Makefile
+++ b/graphics/gif2png/Makefile
@@ -12,7 +12,7 @@ COMMENT= Converts GIF images to a PNG format
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
-USE_PYTHON_RUN= yes
+USES= python:run
GNU_CONFIGURE= yes
PLIST_FILES= bin/${PORTNAME} bin/web2png \
diff --git a/graphics/gimp-ez-perspective-plugin/Makefile b/graphics/gimp-ez-perspective-plugin/Makefile
index eb20a210e910..c7f22e511815 100644
--- a/graphics/gimp-ez-perspective-plugin/Makefile
+++ b/graphics/gimp-ez-perspective-plugin/Makefile
@@ -22,8 +22,7 @@ LICENSE_DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app \
${LOCALBASE}/libexec/gimp/2.2/python/gimpfu.py:${PORTSDIR}/graphics/py-gimp
-USES= zip
-USE_PYTHON_RUN= yes
+USES= python:run zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index b0eb34ee4571..a75400b2fd21 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -15,11 +15,9 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng15.so:${PORTSDIR}/graphics/png
-USES= desktop-file-utils pathfix pkgconfig shared-mime-info
+USES= desktop-file-utils pathfix pkgconfig python shared-mime-info
USE_GNOME= gnomeprefix intlhack libgnomeui pygtk2
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USE_PYTHON= distutils autoplist
USE_GCC= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
index 13f9a857c630..355405a2bbf1 100644
--- a/graphics/gsculpt/Makefile
+++ b/graphics/gsculpt/Makefile
@@ -19,11 +19,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>0:${PORTSDIR}/graphics/py-opengl \
WRKSRC= ${WRKDIR}/${DISTNAME:S,-src,,}
-USES= pkgconfig scons
+USES= pkgconfig python:2 scons
USE_GNOME= pygtk2
USE_GL= glu
USE_XORG= x11
-USE_PYTHON= 2
USE_LDCONFIG= ${PREFIX}/lib/gSculpt
DATADIR= ${PREFIX}/share/gSculpt
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 5facbe2ddd84..15b0560ab448 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -26,14 +26,13 @@ RUN_DEPENDS= enblend>=3.1.r20080615:${PORTSDIR}/graphics/enblend \
exiftool:${PORTSDIR}/graphics/p5-Image-ExifTool \
gmake:${PORTSDIR}/devel/gmake
-USE_PYTHON= yes
-
OPTIONS_DEFINE= PANOMATIC AUTOPANOSIFTC
OPTIONS_DEFAULT= PANOMATIC AUTOPANOSIFTC
PANOMATIC_DESC= Install graphics/panomatic
AUTOPANOSIFTC_DESC= Install graphics/autopano-sift-c
-USES= cmake gettext pkgconfig tar:bzip2 desktop-file-utils shared-mime-info
+USES= cmake gettext pkgconfig tar:bzip2 desktop-file-utils python \
+ shared-mime-info
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}
diff --git a/graphics/jbig2dec/Makefile b/graphics/jbig2dec/Makefile
index e8ff0a2732c9..80d4531ae6ff 100644
--- a/graphics/jbig2dec/Makefile
+++ b/graphics/jbig2dec/Makefile
@@ -34,7 +34,7 @@ PNG_CFLAGS= -I${LOCALBASE}/include/libpng15
.if ${PORT_OPTIONS:MTESTS}
MASTER_SITES+= http://jbig2dec.sourceforge.net/ubc/:tests
DISTFILES+= jb2streams.zip:tests
-USE_PYTHON_BUILD=yes
+USES+= python:build
KNOWN_BAD_JB2S= 042_11 042_13 042_14 042_24 042_25 amb_1 amb_2
post-extract:
diff --git a/graphics/kludge3d/Makefile b/graphics/kludge3d/Makefile
index 99a0693e8953..d0b77efa6f4e 100644
--- a/graphics/kludge3d/Makefile
+++ b/graphics/kludge3d/Makefile
@@ -13,8 +13,7 @@ COMMENT= Simple 3D editor
LIB_DEPENDS= lib3ds-1.so:${PORTSDIR}/graphics/lib3ds \
libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
-USE_PYTHON= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig python
USE_GL= gl
USE_GNOME= gtk20
GNU_CONFIGURE= yes
diff --git a/graphics/lcms-python/Makefile b/graphics/lcms-python/Makefile
index 872e7dfe5d22..1d61bfb3577d 100644
--- a/graphics/lcms-python/Makefile
+++ b/graphics/lcms-python/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= liblcms.so:${PORTSDIR}/graphics/lcms
BUILD_WRKSRC= ${WRKSRC}/python
INSTALL_WRKSRC= ${WRKSRC}/python
-USE_PYTHON= 2
+USES= python:2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-python
CONFIGURE_ENV= PYTHON="${PYTHON_CMD}"
diff --git a/graphics/mahotas/Makefile b/graphics/mahotas/Makefile
index 3305f4540f52..f02caf2eb013 100644
--- a/graphics/mahotas/Makefile
+++ b/graphics/mahotas/Makefile
@@ -15,8 +15,7 @@ BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libfreeimage.so:${PORTSDIR}/graphics/freeimage
USE_GCC= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index 9134a5c6b612..5121986aec22 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -21,9 +21,8 @@ LIB_DEPENDS= libproj.so:${PORTSDIR}/graphics/proj \
BUILD_DEPENDS= ${LOCALBASE}/bin/freetype-config:${PORTSDIR}/print/freetype2 \
${PYTHON_PKGNAMEPREFIX}icu>=0.8.1:${PORTSDIR}/devel/py-icu
-USES= pkgconfig scons tar:bzip2
+USES= pkgconfig python scons tar:bzip2
USE_GNOME= libxml2
-USE_PYTHON= yes
USE_LDCONFIG= yes
WARNING_CXXFLAGS?= -w
diff --git a/graphics/ocrfeeder/Makefile b/graphics/ocrfeeder/Makefile
index d2bfa4459afb..3b373d153b39 100644
--- a/graphics/ocrfeeder/Makefile
+++ b/graphics/ocrfeeder/Makefile
@@ -23,10 +23,9 @@ RUN_DEPENDS:= ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
gtkspell3>0:${PORTSDIR}/textproc/gtkspell3 \
${BUILD_DEPENDS}
-USES= desktop-file-utils gettext gmake pkgconfig tar:xz
+USES= desktop-file-utils gettext gmake pkgconfig python tar:xz
USE_GNOME= gnomedocutils gnomehier gtk30 librsvg2 pygobject3
USE_GHOSTSCRIPT=yes
-USE_PYTHON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/opencolorio/Makefile b/graphics/opencolorio/Makefile
index 8c6aaae2b30f..a5ca4fa69b5a 100644
--- a/graphics/opencolorio/Makefile
+++ b/graphics/opencolorio/Makefile
@@ -40,7 +40,7 @@ CMAKE_ARGS+= -DOCIO_USE_SSE:BOOL=OFF
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
LIB_DEPENDS= libtinyxml.so:${PORTSDIR}/textproc/tinyxml \
libyaml-cpp03.so:${PORTSDIR}/devel/yaml-cpp03
-USE_PYTHON= yes
+USES+= python
USE_LDCONFIG= yes
CMAKE_ARGS+= -DOCIO_BUILD_APPS:BOOL=OFF \
-DOCIO_BUILD_SHARED:BOOL=ON \
diff --git a/graphics/pecomato/Makefile b/graphics/pecomato/Makefile
index 5064b91d53a1..50fc64ec6bbb 100644
--- a/graphics/pecomato/Makefile
+++ b/graphics/pecomato/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= http://www.mollux.org/projects/pecomato/download/sources/ \
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Command-line picture metadata processor
-USES= gmake
-USE_PYTHON_BUILD= yes
+USES= gmake python:build
MAKEFILE= Makefile.unix
diff --git a/graphics/piddle/Makefile b/graphics/piddle/Makefile
index af14dc917aef..d5c570519ee7 100644
--- a/graphics/piddle/Makefile
+++ b/graphics/piddle/Makefile
@@ -11,9 +11,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical Drawing library for Python
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
PORTDOCS= *
diff --git a/graphics/py-aafigure/Makefile b/graphics/py-aafigure/Makefile
index b9717d4c691f..ff7e741f1b8a 100644
--- a/graphics/py-aafigure/Makefile
+++ b/graphics/py-aafigure/Makefile
@@ -16,9 +16,8 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab2
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${UNIQUENAME}
diff --git a/graphics/py-blockdiagcontrib-cisco/Makefile b/graphics/py-blockdiagcontrib-cisco/Makefile
index 131993cb1508..7fc8ba07dbfc 100644
--- a/graphics/py-blockdiagcontrib-cisco/Makefile
+++ b/graphics/py-blockdiagcontrib-cisco/Makefile
@@ -11,8 +11,7 @@ COMMENT= Networking shapes for blockdiag designed by Cisco
RUN_DEPENDS= ${PKGNAMEPREFIX}blockdiag>=0.8.0:${PORTSDIR}/graphics/py-blockdiag
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/graphics/py-cairo/Makefile b/graphics/py-cairo/Makefile
index 15e26439edb0..fe10cd4d6a17 100644
--- a/graphics/py-cairo/Makefile
+++ b/graphics/py-cairo/Makefile
@@ -13,8 +13,7 @@ DISTNAME= py2${PORTNAME}-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Python 2 bindings for Cairo
-USE_PYTHON= 2
-USES= pkgconfig shebangfix tar:bzip2
+USES= pkgconfig python:2 shebangfix tar:bzip2
USE_GNOME= cairo
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/py-django-easy-thumbnails/Makefile b/graphics/py-django-easy-thumbnails/Makefile
index 71081e24dd4a..210bcc840628 100644
--- a/graphics/py-django-easy-thumbnails/Makefile
+++ b/graphics/py-django-easy-thumbnails/Makefile
@@ -15,8 +15,7 @@ LICENSE= BSD
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=0:${PORTSDIR}/www/py-django
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/graphics/py-editobj/Makefile b/graphics/py-editobj/Makefile
index 61aaf8c9fdb0..b10418ee5def 100644
--- a/graphics/py-editobj/Makefile
+++ b/graphics/py-editobj/Makefile
@@ -13,8 +13,8 @@ MAINTAINER= acm@FreeBSD.org
COMMENT= Create and display a Tkinter dialog box for editing any Python object
DIST_SUBDIR= python
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES+= python
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= EditObj
WRKSRC= ${WRKDIR}/EditObj-${PORTVERSION}
EXAMPLESDIR= ${PREFIX}/share/examples/py-editobj
diff --git a/graphics/py-exif/Makefile b/graphics/py-exif/Makefile
index c280ef2cdf23..7f04b3d8c41e 100644
--- a/graphics/py-exif/Makefile
+++ b/graphics/py-exif/Makefile
@@ -12,7 +12,7 @@ DISTNAME= pyexif-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Python library to extract EXIF metadata from JPEG and TIFF image files
-USE_PYTHON= yes
+USES= python
WRKSRC= ${WRKDIR}/pyexif
DATADIR= ${PREFIX}/share/py-exif
DOCSDIR= ${PREFIX}/share/doc/py-exif
diff --git a/graphics/py-exiv2/Makefile b/graphics/py-exiv2/Makefile
index 1b210b81b0d4..c2408eb134af 100644
--- a/graphics/py-exiv2/Makefile
+++ b/graphics/py-exiv2/Makefile
@@ -15,8 +15,7 @@ COMMENT= Python bindings for exiv2
LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2\
libboost_python.so:${PORTSDIR}/devel/boost-python-libs
-USES= scons tar:bzip2
-USE_PYTHON= 2
+USES= python:2 scons tar:bzip2
USE_LDCONFIG= yes
CXXFLAGS+= -I${LOCALBASE}/include
MAKE_ARGS+= prefix=${PREFIX} use_env=1
diff --git a/graphics/py-freeimagepy/Makefile b/graphics/py-freeimagepy/Makefile
index 012f5ae2bf94..9e0004564550 100644
--- a/graphics/py-freeimagepy/Makefile
+++ b/graphics/py-freeimagepy/Makefile
@@ -14,9 +14,7 @@ COMMENT= FreeImage library python wrapper
LIB_DEPENDS= libfreeimage.so:${PORTSDIR}/graphics/freeimage
WRKSRC= ${WRKDIR}/FreeImagePy-${PORTVERSION}
-USES= tar:bzip2
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python tar:bzip2
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/graphics/py-gd/Makefile b/graphics/py-gd/Makefile
index 2a39cc19a6f0..7f3695d317da 100644
--- a/graphics/py-gd/Makefile
+++ b/graphics/py-gd/Makefile
@@ -14,11 +14,9 @@ COMMENT= Python interface to the GD library
LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist pythonprefix
PYSETUP= Setup.py
-USE_PYTHON_PREFIX= yes
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/graphics/py-gimp/Makefile b/graphics/py-gimp/Makefile
index d1261feb09d0..4acf95592fbb 100644
--- a/graphics/py-gimp/Makefile
+++ b/graphics/py-gimp/Makefile
@@ -13,7 +13,7 @@ COMMENT= GIMP python plugin
GIMP_SLAVE= pygimp
-USE_PYTHON= yes
+USES= python
USE_GNOME= pygtk2
CONFIGURE_ARGS= --enable-python
diff --git a/graphics/py-glewpy/Makefile b/graphics/py-glewpy/Makefile
index 55885a38113d..02ca504d9e3d 100644
--- a/graphics/py-glewpy/Makefile
+++ b/graphics/py-glewpy/Makefile
@@ -18,9 +18,9 @@ COMMENT= Advanced OpenGL extensions to Python
BUILD_DEPENDS= pyrex>=0.9.6.2:${PORTSDIR}/devel/pyrex
+USES= python
USE_GL= glew
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USE_PYTHON= distutils
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/py-goocanvas/Makefile b/graphics/py-goocanvas/Makefile
index 9b17e6a5b54b..b68648f99a08 100644
--- a/graphics/py-goocanvas/Makefile
+++ b/graphics/py-goocanvas/Makefile
@@ -18,11 +18,10 @@ LIB_DEPENDS= libgoocanvas.so:${PORTSDIR}/graphics/goocanvas
PLIST_FILES= %%PYTHON_SITELIBDIR%%/goocanvasmodule.so \
libdata/pkgconfig/pygoocanvas.pc
-USE_PYTHON= yes
USE_GNOME= pygtk2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-docs
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake libtool pathfix pkgconfig python tar:bzip2
INSTALL_TARGET= install-strip
post-patch:
diff --git a/graphics/py-graph-core/Makefile b/graphics/py-graph-core/Makefile
index 23040b62fc18..4432c0f3919a 100644
--- a/graphics/py-graph-core/Makefile
+++ b/graphics/py-graph-core/Makefile
@@ -13,8 +13,7 @@ MAINTAINER= demon@FreeBSD.org
COMMENT= Library for working with graphs in Python, core module
PROJECTHOST= python-graph
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/graphics/py-graph-dot/Makefile b/graphics/py-graph-dot/Makefile
index 76a60f98b053..0aeb9234041d 100644
--- a/graphics/py-graph-dot/Makefile
+++ b/graphics/py-graph-dot/Makefile
@@ -16,9 +16,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pydot>=0:${PORTSDIR}/graphics/py-pydot \
${PYTHON_PKGNAMEPREFIX}graph-core>=${PORTVERSION}:${PORTSDIR}/graphics/py-graph-core
PROJECTHOST= python-graph
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
# post-stage and add-plist-post should not act as reference on how to fix
# egg-based conflicts.
diff --git a/graphics/py-graph/Makefile b/graphics/py-graph/Makefile
index 9621b841888b..1bb24cb02db7 100644
--- a/graphics/py-graph/Makefile
+++ b/graphics/py-graph/Makefile
@@ -15,8 +15,7 @@ COMMENT= Library for working with graphs in Python
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}graph-core>=${PORTVERSION}:${PORTSDIR}/graphics/py-graph-core \
${PYTHON_PKGNAMEPREFIX}graph-dot>=${PORTVERSION}:${PORTSDIR}/graphics/py-graph-dot
-USE_PYTHON= yes
-
+USES= python
NO_BUILD= yes
do-install:
diff --git a/graphics/py-graphviz/Makefile b/graphics/py-graphviz/Makefile
index 012946e7bd61..20f998f2dec9 100644
--- a/graphics/py-graphviz/Makefile
+++ b/graphics/py-graphviz/Makefile
@@ -16,8 +16,8 @@ COMMENT= Python interface to GraphViz agraph
BUILD_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= python
+USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= pygraphviz
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
diff --git a/graphics/py-gvgen/Makefile b/graphics/py-gvgen/Makefile
index ad3c8384fd2f..78be69a8817b 100644
--- a/graphics/py-gvgen/Makefile
+++ b/graphics/py-gvgen/Makefile
@@ -12,10 +12,9 @@ COMMENT= Easy python interface to generate dot files
LICENSE= GPLv2
+USES= python
+USE_PYTHON= distutils autoplist
USE_GITHUB= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
GH_ACCOUNT= stricaud
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 777ab06
diff --git a/graphics/py-openexr/Makefile b/graphics/py-openexr/Makefile
index d1c0bbae3f51..f34852f8d00e 100644
--- a/graphics/py-openexr/Makefile
+++ b/graphics/py-openexr/Makefile
@@ -15,12 +15,11 @@ COMMENT= Python module for ILM's OpenEXR image format and library
LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR
+USES= python
+USE_PYTHON= distutils autoplist
+MASTER_SITE_SUBDIR=source/O/OpenEXR
+
post-extract:
${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/setup.py
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
-MASTER_SITE_SUBDIR=source/O/OpenEXR
-
.include <bsd.port.mk>
diff --git a/graphics/py-paint/Makefile b/graphics/py-paint/Makefile
index 025c6705ba8f..b3a57ddceb04 100644
--- a/graphics/py-paint/Makefile
+++ b/graphics/py-paint/Makefile
@@ -15,9 +15,8 @@ COMMENT= Simple and flexible painting adaptor to libart for Python
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libttf.so:${PORTSDIR}/print/freetype
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
USE_GNOME= libartlgpl2
NO_WRKSUBDIR= yes
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libart-2.0 \
diff --git a/graphics/py-png/Makefile b/graphics/py-png/Makefile
index d50742259262..a4db0a4eaad9 100644
--- a/graphics/py-png/Makefile
+++ b/graphics/py-png/Makefile
@@ -14,8 +14,7 @@ COMMENT= Python PNG encoder/decoder
PROJECTHOST= pypng
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/graphics/py-poppler-qt4/Makefile b/graphics/py-poppler-qt4/Makefile
index fb17c9d19b9c..62a58e432631 100644
--- a/graphics/py-poppler-qt4/Makefile
+++ b/graphics/py-poppler-qt4/Makefile
@@ -21,9 +21,7 @@ LIB_DEPENDS= libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:${PORTSDIR}/x11-toolkits/py-qt4-gui \
${PYTHON_PKGNAMEPREFIX}qt4-xml>=0:${PORTSDIR}/textproc/py-qt4-xml
-USES= pkgconfig
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= pkgconfig python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/graphics/py-poppler/Makefile b/graphics/py-poppler/Makefile
index 226a0577e32c..ab913e911f90 100644
--- a/graphics/py-poppler/Makefile
+++ b/graphics/py-poppler/Makefile
@@ -16,9 +16,8 @@ COMMENT= Python bindings for the Poppler PDF rendering library
LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
-USE_PYTHON= yes
GNU_CONFIGURE= yes
-USES= gmake libtool pkgconfig
+USES= gmake libtool pkgconfig python
USE_GNOME= atk pygtk2
.include <bsd.port.mk>
diff --git a/graphics/py-pycha/Makefile b/graphics/py-pycha/Makefile
index 77a0689738e4..56096bfb5f60 100644
--- a/graphics/py-pycha/Makefile
+++ b/graphics/py-pycha/Makefile
@@ -12,9 +12,8 @@ COMMENT= Library for making charts with Python
LICENSE= LGPL3
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= CAIRO
OPTIONS_DEFAULT= CAIRO
diff --git a/graphics/py-pydot/Makefile b/graphics/py-pydot/Makefile
index 0178e73cbd03..0ef9a4e8498b 100644
--- a/graphics/py-pydot/Makefile
+++ b/graphics/py-pydot/Makefile
@@ -16,8 +16,7 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pyparsing.py:${PORTSDIR}/devel/py-parsing
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyparsing.py:${PORTSDIR}/devel/py-parsing \
dot:${PORTSDIR}/graphics/graphviz
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/graphics/py-pygal/Makefile b/graphics/py-pygal/Makefile
index b2af3a2c5f85..39bbd48b7d00 100644
--- a/graphics/py-pygal/Makefile
+++ b/graphics/py-pygal/Makefile
@@ -15,8 +15,7 @@ LICENSE= LGPL3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=3.3.4:${PORTSDIR}/devel/py-lxml
# Python3 ready
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/graphics/py-pygooglechart/Makefile b/graphics/py-pygooglechart/Makefile
index 840bc1b2be0b..2bd74730ef37 100644
--- a/graphics/py-pygooglechart/Makefile
+++ b/graphics/py-pygooglechart/Makefile
@@ -12,9 +12,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Complete Python wrapper for the Google Chart API
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
PORTEXAMPLES= *
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/graphics/py-pyproj/Makefile b/graphics/py-pyproj/Makefile
index d4c728750fde..540e008190e9 100644
--- a/graphics/py-pyproj/Makefile
+++ b/graphics/py-pyproj/Makefile
@@ -11,9 +11,8 @@ MAINTAINER= fmysh@iijmio-mail.jp
COMMENT= Pyrex wrapper to provide python interfaces to PROJ.4
WRKSRC= ${WRKDIR}/${DISTNAME:C/[a-z]$//}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
PORTDOCS= Changelog README LICENSE_proj4
PORTEXAMPLES= datum_shift.py geodtest.py sample.out \
diff --git a/graphics/py-sane/Makefile b/graphics/py-sane/Makefile
index b28c6d123cb3..3ec958e0bc82 100644
--- a/graphics/py-sane/Makefile
+++ b/graphics/py-sane/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= libsane.so:${PORTSDIR}/graphics/sane-backends
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow
DIST_SUBDIR= python
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils
WRKSRC= ${WRKDIR}/${DISTNAME}/Sane
diff --git a/graphics/py-webcolors/Makefile b/graphics/py-webcolors/Makefile
index f20d0e4e2f5b..8e1faeae81ce 100644
--- a/graphics/py-webcolors/Makefile
+++ b/graphics/py-webcolors/Makefile
@@ -12,9 +12,8 @@ COMMENT= Library working with the sRGB color space as used in the HTML and CSS
LICENSE= BSD3CLAUSE
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
PORTDOCS= README
diff --git a/graphics/py3-cairo/Makefile b/graphics/py3-cairo/Makefile
index 2f35118b566f..363444499fc1 100644
--- a/graphics/py3-cairo/Makefile
+++ b/graphics/py3-cairo/Makefile
@@ -13,8 +13,7 @@ DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Python 3 bindings for Cairo
-USE_PYTHON= 3
-USES= pkgconfig shebangfix tar:bzip2
+USES= pkgconfig python:3 shebangfix tar:bzip2
USE_GNOME= cairo
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/pygts/Makefile b/graphics/pygts/Makefile
index baa2858087d3..ac84e86c09bc 100644
--- a/graphics/pygts/Makefile
+++ b/graphics/pygts/Makefile
@@ -14,8 +14,7 @@ BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libgts.so:${PORTSDIR}/graphics/gts
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-USES= pkgconfig
+USE_PYTHON= distutils
+USES= pkgconfig python
.include <bsd.port.mk>
diff --git a/graphics/pymorph/Makefile b/graphics/pymorph/Makefile
index b6aa44f7ad77..2cd1ae78c215 100644
--- a/graphics/pymorph/Makefile
+++ b/graphics/pymorph/Makefile
@@ -14,8 +14,7 @@ LICENSE= BSD
RUN_DEPENDS+= ${PYNUMPY}
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 1af9cd1468c5..195bb782a619 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -28,8 +28,7 @@ GH_ACCOUNT= qgis
GH_COMMIT= 00ab94f
GH_TAGNAME= ${GH_COMMIT}
-USES= bison cmake gmake
-USE_PYTHON= yes
+USES= bison cmake gmake python
USE_SQLITE= yes
USE_QT4= gui svg xml network sql designer testlib linguist_build \
qmake_build moc_build rcc_build uic_build
diff --git a/graphics/skencil/Makefile b/graphics/skencil/Makefile
index 4b8160053969..49af208830a6 100644
--- a/graphics/skencil/Makefile
+++ b/graphics/skencil/Makefile
@@ -22,11 +22,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}alpha
-USES= tk desktop-file-utils
+USES= tk desktop-file-utils python
USE_XORG= x11 xext
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USE_PYTHON= distutils autoplist
PYDISTUTILS_EGGINFO= ${PORTNAME}-${PORTVERSION:R}alpha-py${PYTHON_VER}.egg-info
CFLAGS+= -I${TK_INCLUDEDIR} -I${LOCALBASE}/include \
diff --git a/graphics/svgfig/Makefile b/graphics/svgfig/Makefile
index 31fb91079427..09961d5b9ca8 100644
--- a/graphics/svgfig/Makefile
+++ b/graphics/svgfig/Makefile
@@ -14,9 +14,8 @@ COMMENT= Draw mathematical figures in SVG using Python
WRKSRC= ${WRKDIR}/${PORTNAME:tl}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
post-patch:
@${REINPLACE_CMD} -e 's|1.1.2|${PORTVERSION}|' ${WRKSRC}/setup.py
diff --git a/graphics/tilecache/Makefile b/graphics/tilecache/Makefile
index f6eba7a7c1d6..00bb3e5f8055 100644
--- a/graphics/tilecache/Makefile
+++ b/graphics/tilecache/Makefile
@@ -15,9 +15,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup \
LICENSE= BSD
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
FILES_ETC= TileCache/Service.py setup.py tilecache_install_config.py
diff --git a/graphics/truevision/Makefile b/graphics/truevision/Makefile
index d52227ba2f6a..66b3ca11aa02 100644
--- a/graphics/truevision/Makefile
+++ b/graphics/truevision/Makefile
@@ -18,10 +18,9 @@ LIB_DEPENDS= libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
- shared-mime-info tar:bzip2
+ python shared-mime-info tar:bzip2
USE_GNOME= gnomeprefix intlhack libgnomeui
USE_GL= gl
-USE_PYTHON= yes
GNU_CONFIGURE= yes
CPPFLAGS+= $$(pkg-config --cflags gtkglext-1.0) \
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index 7a86f062d609..6754b3eebcaf 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -50,8 +50,7 @@ CMAKE_ARGS+= -DWITH_OPENEXR=0
# Should ignore Python3 since commit f51b0b5
#CONFLICTS_BUILD= python3*
CMAKE_ARGS+= -DWITH_VIGRANUMPY=1
-USES+= compiler:gcc-c++11-lib
-USE_PYTHON= 2
+USES+= compiler:gcc-c++11-lib python:2
BUILD_DEPENDS+= nosetests:${PORTSDIR}/devel/py-nose
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:${PORTSDIR}/math/py-numpy
#BUILD_DEPENDS+= sphinx-build:${PORTSDIR}/textproc/py-sphinx