aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/thunderbird-esr/Makefile2
-rw-r--r--mail/thunderbird-esr/distinfo6
-rw-r--r--mail/thunderbird-esr/files/patch-mozilla-xpcom-base-nsStackWalk.cpp10
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/distinfo6
-rw-r--r--mail/thunderbird/files/patch-mozilla-xpcom-base-nsStackWalk.cpp10
6 files changed, 28 insertions, 8 deletions
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index 1cfcb67eadd4..37739d368167 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= thunderbird
-DISTVERSION= 3.1.4
+DISTVERSION= 3.1.5
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
diff --git a/mail/thunderbird-esr/distinfo b/mail/thunderbird-esr/distinfo
index 0e72448134b6..a7dd5c30efda 100644
--- a/mail/thunderbird-esr/distinfo
+++ b/mail/thunderbird-esr/distinfo
@@ -1,3 +1,3 @@
-MD5 (thunderbird-3.1.4.source.tar.bz2) = 08f029e927e2e07aa863096fdf21db84
-SHA256 (thunderbird-3.1.4.source.tar.bz2) = 788905714e768c94025a954e1bea281f8e728d52b8249f2df43e6732d2ea7a08
-SIZE (thunderbird-3.1.4.source.tar.bz2) = 66636919
+MD5 (thunderbird-3.1.5.source.tar.bz2) = 9a75383c7142a9b2487f0ce7e7913824
+SHA256 (thunderbird-3.1.5.source.tar.bz2) = 666e46e2d245ef0286a8c6b09eda3a1f6bf86917755464223789bda5680ac6e2
+SIZE (thunderbird-3.1.5.source.tar.bz2) = 65846402
diff --git a/mail/thunderbird-esr/files/patch-mozilla-xpcom-base-nsStackWalk.cpp b/mail/thunderbird-esr/files/patch-mozilla-xpcom-base-nsStackWalk.cpp
new file mode 100644
index 000000000000..4d2bca2ca692
--- /dev/null
+++ b/mail/thunderbird-esr/files/patch-mozilla-xpcom-base-nsStackWalk.cpp
@@ -0,0 +1,10 @@
+--- mozilla/xpcom/base/nsStackWalk.cpp.orig 2010-09-12 19:34:04.012503905 +0300
++++ mozilla/xpcom/base/nsStackWalk.cpp 2010-09-12 19:34:41.294462134 +0300
+@@ -41,6 +41,7 @@
+ /* API for getting a stack trace of the C/C++ stack on the current thread */
+
+ #include "nsStackWalk.h"
++#include <dlfcn.h>
+
+ #if defined(_WIN32) && (defined(_M_IX86) || defined(_M_AMD64) || defined(_M_IA64)) && !defined(WINCE) // WIN32 x86 stack walking code
+
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 1cfcb67eadd4..37739d368167 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= thunderbird
-DISTVERSION= 3.1.4
+DISTVERSION= 3.1.5
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index 0e72448134b6..a7dd5c30efda 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,3 +1,3 @@
-MD5 (thunderbird-3.1.4.source.tar.bz2) = 08f029e927e2e07aa863096fdf21db84
-SHA256 (thunderbird-3.1.4.source.tar.bz2) = 788905714e768c94025a954e1bea281f8e728d52b8249f2df43e6732d2ea7a08
-SIZE (thunderbird-3.1.4.source.tar.bz2) = 66636919
+MD5 (thunderbird-3.1.5.source.tar.bz2) = 9a75383c7142a9b2487f0ce7e7913824
+SHA256 (thunderbird-3.1.5.source.tar.bz2) = 666e46e2d245ef0286a8c6b09eda3a1f6bf86917755464223789bda5680ac6e2
+SIZE (thunderbird-3.1.5.source.tar.bz2) = 65846402
diff --git a/mail/thunderbird/files/patch-mozilla-xpcom-base-nsStackWalk.cpp b/mail/thunderbird/files/patch-mozilla-xpcom-base-nsStackWalk.cpp
new file mode 100644
index 000000000000..4d2bca2ca692
--- /dev/null
+++ b/mail/thunderbird/files/patch-mozilla-xpcom-base-nsStackWalk.cpp
@@ -0,0 +1,10 @@
+--- mozilla/xpcom/base/nsStackWalk.cpp.orig 2010-09-12 19:34:04.012503905 +0300
++++ mozilla/xpcom/base/nsStackWalk.cpp 2010-09-12 19:34:41.294462134 +0300
+@@ -41,6 +41,7 @@
+ /* API for getting a stack trace of the C/C++ stack on the current thread */
+
+ #include "nsStackWalk.h"
++#include <dlfcn.h>
+
+ #if defined(_WIN32) && (defined(_M_IX86) || defined(_M_AMD64) || defined(_M_IA64)) && !defined(WINCE) // WIN32 x86 stack walking code
+