aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/emacs-emcws/Makefile10
-rw-r--r--japanese/emacs-emcws/files/patch-src:wnnfns.c57
-rw-r--r--japanese/emacs20-emcws/Makefile7
-rw-r--r--japanese/emacs20-emcws/files/patch-src_wnnfns.c57
4 files changed, 127 insertions, 4 deletions
diff --git a/japanese/emacs-emcws/Makefile b/japanese/emacs-emcws/Makefile
index 6475d5321212..8c78612b7532 100644
--- a/japanese/emacs-emcws/Makefile
+++ b/japanese/emacs-emcws/Makefile
@@ -7,7 +7,7 @@
PORTNAME= emcws
PORTVERSION= ${EMACS_VER}
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= japanese editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= emacs
@@ -20,7 +20,6 @@ PATCH_DIST_STRIP= -p1
.if defined(WITH_MENUBAR_FONTSET)
PATCH_SITES+= http://www.nijino.com/ari/emacs/
PATCHFILES+= emacs-21.1-fontset.patch emacs-21.2-menu-encode.patch
-PATCH_DIST_STRIP= -p1
.endif
MAINTAINER= nakaji@jp.freebsd.org
@@ -29,6 +28,11 @@ COMMENT= Emacs + Canna + Wnn + Sj3
BUILD_DEPENDS= emacs-${EMACS_VER}:${PORTSDIR}/editors/emacs
RUN_DEPENDS= emacs-${EMACS_VER}:${PORTSDIR}/editors/emacs
+CONFLICTS= emacs-19.* emacs-20.* \
+ ja-emcws-20.* \
+ xemacs-[0-9]* xemacs-devel-[0-9]* \
+ xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]*
+
WRKSRC= ${WRKDIR}/emacs-${EMACS_VER}
USE_AUTOTOOLS= autoconf:213
@@ -152,7 +156,7 @@ EMACS_BASE=${LOCALBASE}
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
-BROKEN= "Segfault during build on ia64"
+BROKEN= Segfault during build on ia64
CFLAGS:= ${CFLAGS:C/-O.?/-O0/g}
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
.endif
diff --git a/japanese/emacs-emcws/files/patch-src:wnnfns.c b/japanese/emacs-emcws/files/patch-src:wnnfns.c
new file mode 100644
index 000000000000..0fe3b849f7da
--- /dev/null
+++ b/japanese/emacs-emcws/files/patch-src:wnnfns.c
@@ -0,0 +1,57 @@
+--- src/wnnfns.c.orig Mon Dec 25 18:05:08 2006
++++ src/wnnfns.c Mon Dec 25 18:07:15 2006
+@@ -341,6 +341,9 @@
+ static int wnnfns_norm;
+ static unsigned char lc_wnn_server_type[NSERVER] = {LCJP, LCCN, LCINV, LCKR};
+
++static int yes_or_no();
++static void puts2();
++
+ /* Lisp Variables and Constants Definition */
+ Lisp_Object Qjserver;
+ Lisp_Object Qcserver;
+@@ -452,8 +455,6 @@
+ int nargs;
+ register Lisp_Object *args;
+ {
+- static int yes_or_no();
+- static void puts2();
+ struct gcpro gcpro1;
+ int snum;
+ CHECK_STRING (args[0], 0);
+@@ -1293,8 +1294,6 @@
+ int nargs;
+ register Lisp_Object *args;
+ {
+- static int yes_or_no();
+- static void puts2();
+ struct gcpro gcpro1;
+ int snum;
+ CHECK_STRING (args[0], 0);
+@@ -1329,8 +1328,6 @@
+ int nargs;
+ register Lisp_Object *args;
+ {
+- static int yes_or_no();
+- static void puts2();
+ struct gcpro gcpro1;
+ int snum;
+ CHECK_STRING (args[0], 0);
+@@ -1365,8 +1362,6 @@
+ int nargs;
+ register Lisp_Object *args;
+ {
+- static int yes_or_no();
+- static void puts2();
+ struct gcpro gcpro1;
+ int snum;
+ int dic_no;
+@@ -1427,8 +1422,6 @@
+ int nargs;
+ register Lisp_Object *args;
+ {
+- static int yes_or_no();
+- static void puts2();
+ struct gcpro gcpro1;
+ int snum;
+ int dic_no;
diff --git a/japanese/emacs20-emcws/Makefile b/japanese/emacs20-emcws/Makefile
index 2419978a17d6..58b70ff2edde 100644
--- a/japanese/emacs20-emcws/Makefile
+++ b/japanese/emacs20-emcws/Makefile
@@ -8,7 +8,7 @@
PORTNAME= emcws
PORTVERSION= 20.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= japanese editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= emacs
@@ -25,6 +25,11 @@ COMMENT= Emacs + Canna + Wnn + Sj3
BUILD_DEPENDS= emacs-${EMACS_VER}:${PORTSDIR}/editors/emacs20
RUN_DEPENDS= emacs-${EMACS_VER}:${PORTSDIR}/editors/emacs20
+CONFLICTS= emacs-19.* emacs-21.* \
+ ja-emcws-21.* \
+ xemacs-[0-9]* xemacs-devel-[0-9]* \
+ xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]*
+
WRKSRC= ${WRKDIR}/emacs-${EMACS_VER}
LATEST_LINK= ja-emcws20
diff --git a/japanese/emacs20-emcws/files/patch-src_wnnfns.c b/japanese/emacs20-emcws/files/patch-src_wnnfns.c
new file mode 100644
index 000000000000..487ea8be4590
--- /dev/null
+++ b/japanese/emacs20-emcws/files/patch-src_wnnfns.c
@@ -0,0 +1,57 @@
+--- src/wnnfns.c.orig Mon Dec 25 19:49:21 2006
++++ src/wnnfns.c Mon Dec 25 19:50:02 2006
+@@ -341,6 +341,9 @@
+ static int wnnfns_norm;
+ static unsigned char lc_wnn_server_type[NSERVER] = {LCJP, LCCN, LCINV, LCKR};
+
++static int yes_or_no();
++static void puts2();
++
+ /* Lisp Variables and Constants Definition */
+ Lisp_Object Qjserver;
+ Lisp_Object Qcserver;
+@@ -452,8 +455,6 @@
+ int nargs;
+ register Lisp_Object *args;
+ {
+- static int yes_or_no();
+- static void puts2();
+ struct gcpro gcpro1;
+ int snum;
+ CHECK_STRING (args[0], 0);
+@@ -1293,8 +1294,6 @@
+ int nargs;
+ register Lisp_Object *args;
+ {
+- static int yes_or_no();
+- static void puts2();
+ struct gcpro gcpro1;
+ int snum;
+ CHECK_STRING (args[0], 0);
+@@ -1329,8 +1328,6 @@
+ int nargs;
+ register Lisp_Object *args;
+ {
+- static int yes_or_no();
+- static void puts2();
+ struct gcpro gcpro1;
+ int snum;
+ CHECK_STRING (args[0], 0);
+@@ -1365,8 +1362,6 @@
+ int nargs;
+ register Lisp_Object *args;
+ {
+- static int yes_or_no();
+- static void puts2();
+ struct gcpro gcpro1;
+ int snum;
+ int dic_no;
+@@ -1427,8 +1422,6 @@
+ int nargs;
+ register Lisp_Object *args;
+ {
+- static int yes_or_no();
+- static void puts2();
+ struct gcpro gcpro1;
+ int snum;
+ int dic_no;