aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/wxgtk24/Makefile7
-rw-r--r--x11-toolkits/wxgtk26/Makefile6
-rw-r--r--x11-toolkits/wxgtk28/Makefile6
-rw-r--r--x11-toolkits/wxgtk29/Makefile6
4 files changed, 24 insertions, 1 deletions
diff --git a/x11-toolkits/wxgtk24/Makefile b/x11-toolkits/wxgtk24/Makefile
index 0f4daa1e03e8..83d800688eac 100644
--- a/x11-toolkits/wxgtk24/Makefile
+++ b/x11-toolkits/wxgtk24/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wx
PORTVERSION= 2.4.2
-PORTREVISION?= 9
+PORTREVISION?= 10
PKGNAMESUFFIX= ${WXGTK_FLAVOR}
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -53,4 +53,9 @@ WXGTK_FLAVOR?= gtk2
pre-patch:
@${REINPLACE_CMD} -e 's|lgdk|lgdk-x11-2.0|g' ${WRKSRC}/configure
+post-patch:
+ @${REINPLACE_CMD} -e 's|pkg_config_args --cflags|pkg_config_args pangox --cflags|g ; \
+ s|pkg_config_args --libs|pkg_config_args pangox --libs|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/wxgtk26/Makefile b/x11-toolkits/wxgtk26/Makefile
index bc246aa12119..32607492ebd1 100644
--- a/x11-toolkits/wxgtk26/Makefile
+++ b/x11-toolkits/wxgtk26/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wx
PORTVERSION= 2.6.1
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wxwindows
@@ -86,6 +87,11 @@ pre-configure:
.endif # !gtk2-contrib-common
.endif # *-contrib*
+post-patch:
+ @${REINPLACE_CMD} -e 's|pkg_config_args --cflags|pkg_config_args pangox --cflags|g ; \
+ s|pkg_config_args --libs|pkg_config_args pangox --libs|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
.if ${WXGTK_FLAVOR:M*-unicode*} != ""
diff --git a/x11-toolkits/wxgtk28/Makefile b/x11-toolkits/wxgtk28/Makefile
index bc246aa12119..32607492ebd1 100644
--- a/x11-toolkits/wxgtk28/Makefile
+++ b/x11-toolkits/wxgtk28/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wx
PORTVERSION= 2.6.1
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wxwindows
@@ -86,6 +87,11 @@ pre-configure:
.endif # !gtk2-contrib-common
.endif # *-contrib*
+post-patch:
+ @${REINPLACE_CMD} -e 's|pkg_config_args --cflags|pkg_config_args pangox --cflags|g ; \
+ s|pkg_config_args --libs|pkg_config_args pangox --libs|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
.if ${WXGTK_FLAVOR:M*-unicode*} != ""
diff --git a/x11-toolkits/wxgtk29/Makefile b/x11-toolkits/wxgtk29/Makefile
index bc246aa12119..32607492ebd1 100644
--- a/x11-toolkits/wxgtk29/Makefile
+++ b/x11-toolkits/wxgtk29/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wx
PORTVERSION= 2.6.1
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wxwindows
@@ -86,6 +87,11 @@ pre-configure:
.endif # !gtk2-contrib-common
.endif # *-contrib*
+post-patch:
+ @${REINPLACE_CMD} -e 's|pkg_config_args --cflags|pkg_config_args pangox --cflags|g ; \
+ s|pkg_config_args --libs|pkg_config_args pangox --libs|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
.if ${WXGTK_FLAVOR:M*-unicode*} != ""