aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/octave/Makefile53
-rw-r--r--math/octave/distinfo4
-rw-r--r--math/octave/files/octave.in8
-rw-r--r--math/octave/files/patch-configure.in24
-rw-r--r--math/octave/files/patch-examples+Makefile.in17
-rw-r--r--math/octave/files/patch-libcruft+mkf77def.in11
-rw-r--r--math/octave/files/patch-scripts+pkg+pkg.m16
-rw-r--r--math/octave/pkg-plist27
8 files changed, 45 insertions, 115 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 76afa312cd8d..b065c6d884cd 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= octave
-PORTVERSION= 3.2.4
-PORTREVISION= 4
+PORTVERSION= 3.4.0
CATEGORIES= math
-MASTER_SITES= ftp://ftp.octave.org/pub/octave/ \
+MASTER_SITES= ftp://ftp.gnu.org/gnu/octave/ \
ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/
MAINTAINER= maho@FreeBSD.org
@@ -18,11 +17,12 @@ COMMENT= High-level interactive language for numerical computations
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
gsed:${PORTSDIR}/textproc/gsed \
- dvips:${PORTSDIR}/print/dvipsk-tetex
+ dvips:${PORTSDIR}/print/dvipsk-tetex \
+ ${PREFIX}/bin/makeinfo:${PORTSDIR}/print/texinfo
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
- gsed:${PORTSDIR}/textproc/gsed
-LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
- glpk.28:${PORTSDIR}/math/glpk \
+ gsed:${PORTSDIR}/textproc/gsed \
+ ${PREFIX}/bin/makeinfo:${PORTSDIR}/print/texinfo
+LIB_DEPENDS= glpk.28:${PORTSDIR}/math/glpk \
umfpack.1:${PORTSDIR}/math/suitesparse \
qhull:${PORTSDIR}/math/qhull \
arpack:${PORTSDIR}/math/arpack \
@@ -31,16 +31,17 @@ LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
fftw3:${PORTSDIR}/math/fftw3 \
ftgl:${PORTSDIR}/graphics/ftgl \
fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick
+ GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick \
+ curl:${PORTSDIR}/ftp/curl
USE_BZIP2= yes
USE_PERL5_BUILD=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf
+#USE_AUTOTOOLS= autoconf
-INFO= octave liboctave
-MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
+INFO= octave liboctave OctaveFAQ
+MAN1= octave.1 mkoctfile.1 octave-config.1
OPTIONS= LEGACY_HDF5 "Build with HDF5 v1.6 (otherwise with HDF5 v1.8)" on
@@ -90,15 +91,12 @@ CONFIGURE_ENV+= GPERF="${LOCALBASE}/bin/gperf" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CC="${CC}" \
CXX="${CXX}" \
- TERMIOS_H="termios.h"
+ MAKEINFO=${PREFIX}/bin/makeinfo
CONFIGURE_ARGS= --host=${GNU_HOST} \
--with-blas="-L${LOCALBASE}/lib ${BLAS}" \
--with-lapack="${LAPACK}" \
--enable-shared
-SUB_FILES= octave
-SUB_LIST= OCTAVE_VERSION="${OCTAVE_VERSION}" GNU_HOST="${GNU_HOST}"
-
.if (${OSVERSION} <= 700000)
WITH_PTMALLOC=yes
.endif
@@ -108,27 +106,30 @@ LIB_DEPENDS+= ptmalloc:${PORTSDIR}/devel/ptmalloc
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lptmalloc"
.endif
+post-patch:
+ ${REINPLACE_CMD} 's+"makeinfo"+"${PREFIX}/bin/makeinfo"+' ${WRKSRC}/src/help.cc
+
post-install:
- ${INSTALL_DATA} ${WRKSRC}/doc/liboctave/liboctave.info ${PREFIX}/info
- ${MV} ${PREFIX}/bin/${PORTNAME}-${PORTVERSION} ${PREFIX}/libexec/${PORTNAME}/${PORTVERSION}/exec/${GNU_HOST}
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}-${PORTVERSION}
- ${LN} -fs ${PREFIX}/bin/${PORTNAME}-${PORTVERSION} ${PREFIX}/bin/${PORTNAME}
${MKDIR} ${DESKTOPDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/octave.desktop \
+ ${INSTALL_DATA} ${WRKSRC}/doc/icons/octave.desktop \
${DESKTOPDIR}/www.octave.org-octave.desktop
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in faq/Octave-FAQ.ps liboctave/liboctave.ps \
- refcard/refcard-a4.ps refcard/refcard-legal.ps refcard/refcard-letter.ps
+.for file in faq/OctaveFAQ.ps liboctave/liboctave.ps \
+ refcard/refcard-a4.ps refcard/refcard-legal.ps \
+ refcard/refcard-letter.ps interpreter/octave.ps
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
.endfor
.endif
- ${RM} -f ${WRKDIR}/PLIST
+ ${RM} -f ${WRKDIR}/PLIST
.for d in ${PREFIX}/include/octave-${OCTAVE_VERSION} ${PREFIX}/share/octave ${PREFIX}/libexec/octave ${PREFIX}/lib/octave-${OCTAVE_VERSION}
@${FIND} -s $d -not -type d | \
- ${SED} -e 's#^${PREFIX}/##' >> ${WRKDIR}/PLIST
- @${FIND} $d -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
+ ${SED} -e 's#^${PREFIX}/##' >> ${WRKDIR}/PLIST
+ @${FIND} -s $d -type d -empty | \
+ ${SED} -e 's,^${PREFIX}/,@exec mkdir -p %D/,' \
+ -e 's,$$, 2>/dev/null || true,' >> ${WRKDIR}/PLIST
+ @${FIND} -s $d -type d -depth | \
+ ${SED} -e 's,^${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
.endfor
cd ${WRKDIR} ; ${SED} -i -e "/PLIST/ r PLIST" ${TMPPLIST}
diff --git a/math/octave/distinfo b/math/octave/distinfo
index f70f033dee74..aadaa07dfb44 100644
--- a/math/octave/distinfo
+++ b/math/octave/distinfo
@@ -1,2 +1,2 @@
-SHA256 (octave-3.2.4.tar.bz2) = 48471d05c7ed9c0a5a4d5fa4ae8a857447ac3da1197f86cfe79b9d8f4fdfd147
-SIZE (octave-3.2.4.tar.bz2) = 12080959
+SHA256 (octave-3.4.0.tar.bz2) = 0fb4f78f43320eec82477c1bbde42877e0e490a9f4903966b1682a9600ffcc2b
+SIZE (octave-3.4.0.tar.bz2) = 14619487
diff --git a/math/octave/files/octave.in b/math/octave/files/octave.in
deleted file mode 100644
index c2455ab5082f..000000000000
--- a/math/octave/files/octave.in
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD: /tmp/pcvs/ports/math/octave/files/Attic/octave.in,v 1.3 2007-12-25 03:37:51 maho Exp $
-
-OCTAVE_EXEC=%%PREFIX%%/libexec/octave/%%OCTAVE_VERSION%%/exec/%%GNU_HOST%%/octave-%%OCTAVE_VERSION%%
-LD_LIBRARY_PATH=%%PREFIX%%/lib/octave-%%OCTAVE_VERSION%%; export LD_LIBRARY_PATH
-
-exec $OCTAVE_EXEC "$@"
diff --git a/math/octave/files/patch-configure.in b/math/octave/files/patch-configure.in
deleted file mode 100644
index 1548cc521dac..000000000000
--- a/math/octave/files/patch-configure.in
+++ /dev/null
@@ -1,24 +0,0 @@
---- configure.in 2009-05-26 20:38:48.000000000 +0900
-+++ configure.in 2009-08-07 13:12:41.000000000 +0900
-@@ -890,9 +890,10 @@
- ### Checks for BLAS and LAPACK libraries:
- # (Build subdirectories of libcruft if they aren't found on the system.)
- sinclude(acx_blas.m4)
--sinclude(acx_blas_f77_func.m4)
-+#sinclude(acx_blas_f77_func.m4)
- sinclude(acx_lapack.m4)
--ACX_BLAS_WITH_F77_FUNC([], [BLAS_DIR="blas"])
-+ACX_BLAS([], [BLAS_DIR="blas"])
-+#ACX_BLAS_WITH_F77_FUNC([], [BLAS_DIR="blas"])
- ACX_LAPACK([BLAS_LIBS="$LAPACK_LIBS $BLAS_LIBS"], [LAPACK_DIR="lapack"])
- AC_SUBST(BLAS_DIR)
- AC_SUBST(LAPACK_DIR)
-@@ -1120,7 +1121,7 @@
- warn_arpack="arpack not found. This will result in a lack of the eigs function."
- if test "$with_arpack" = yes; then
- with_arpack=no
-- AC_CHECK_LIB(arpack, F77_FUNC(dseupd,DSEUPD), [ARPACK_LIBS="-larpack"; with_arpack=yes], , $LAPACK_LIBS $FLIBS)
-+ AC_CHECK_LIB(arpack, F77_FUNC(dseupd,DSEUPD), [ARPACK_LIBS="-larpack"; with_arpack=yes], , $BLAS_LIBS $LAPACK_LIBS $FLIBS)
- if test "$with_arpack" = yes; then
- AC_DEFINE(HAVE_ARPACK, 1, [Define if the ARPACK library is used.])
- warn_arpack=
diff --git a/math/octave/files/patch-examples+Makefile.in b/math/octave/files/patch-examples+Makefile.in
deleted file mode 100644
index 177e7d8cc6c6..000000000000
--- a/math/octave/files/patch-examples+Makefile.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- examples/Makefile.in~ 2008-07-22 00:59:03.000000000 +0900
-+++ examples/Makefile.in 2008-08-23 05:46:34.000000000 +0900
-@@ -95,10 +95,10 @@
- rm -f $(DESTDIR)$(imagedir)/$$f; \
- $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(imagedir)/$$f; \
- done
-- -if test -n "$(DESKTOP_FILE_INSTALL)"; then \
-- $(DESKTOP_FILE_INSTALL) --dir=$(DESTDIR)$(datadir)/applications \
-- --vendor www.octave.org octave.desktop; \
-- fi
-+# -if test -n "$(DESKTOP_FILE_INSTALL)"; then \
-+# $(DESKTOP_FILE_INSTALL) --dir=$(DESTDIR)$(datadir)/applications \
-+# --vendor www.octave.org octave.desktop; \
-+# fi
- .PHONY: install install-strip
-
- uninstall:
diff --git a/math/octave/files/patch-libcruft+mkf77def.in b/math/octave/files/patch-libcruft+mkf77def.in
index baf35379b2b6..7383c372bf5d 100644
--- a/math/octave/files/patch-libcruft+mkf77def.in
+++ b/math/octave/files/patch-libcruft+mkf77def.in
@@ -1,10 +1,11 @@
---- libcruft/mkf77def.in~ Sat Oct 28 08:19:17 2006
-+++ libcruft/mkf77def.in Wed Jun 27 16:17:36 2007
-@@ -1,6 +1,6 @@
- #! /bin/sh
+--- libcruft/mkf77def.in.orig 2011-02-08 04:00:51.000000000 -0600
++++ libcruft/mkf77def.in 2011-04-20 18:26:34.000000000 -0500
+@@ -18,7 +18,7 @@
+ # along with Octave; see the file COPYING. If not, see
+ # <http://www.gnu.org/licenses/>.
-SED=${SED:-'sed'}
+SED=gsed
AWK=${AWK:-'awk'}
- F77_TOLOWER=%F77_APPEND_UNDERSCORE%
+ F77_TOLOWER="@F77_APPEND_UNDERSCORE@"
diff --git a/math/octave/files/patch-scripts+pkg+pkg.m b/math/octave/files/patch-scripts+pkg+pkg.m
index ec414d29ebf6..a6387b96f962 100644
--- a/math/octave/files/patch-scripts+pkg+pkg.m
+++ b/math/octave/files/patch-scripts+pkg+pkg.m
@@ -1,11 +1,11 @@
---- scripts/pkg/pkg.m~ 2009-07-27 18:31:53.000000000 +0900
-+++ scripts/pkg/pkg.m 2009-07-27 18:32:52.000000000 +0900
-@@ -1247,7 +1247,7 @@
+--- scripts/pkg/pkg.m.orig 2011-02-08 19:00:51.000000000 +0900
++++ scripts/pkg/pkg.m 2011-05-09 12:18:05.000000000 +0900
+@@ -1326,7 +1326,7 @@
+
## Make.
if (exist (fullfile (src, "Makefile"), "file"))
- [status, output] = shell (cstrcat ("export INSTALLDIR=\"", desc.dir,
-- "\"; make -C '", src, "'"));
-+ "\"; gmake -C '", src, "'"));
+- [status, output] = shell (cstrcat (scenv, "make -C '", src, "'"));
++ [status, output] = shell (cstrcat (scenv, "gmake -C '", src, "'"));
if (status != 0)
- rm_rf (desc.dir);
- error ("'make' returned the following error: %s", output);
+ rm_rf (desc.dir);
+ error ("'make' returned the following error: %s", output);
diff --git a/math/octave/pkg-plist b/math/octave/pkg-plist
index 61823f3a0a3c..febe145e88aa 100644
--- a/math/octave/pkg-plist
+++ b/math/octave/pkg-plist
@@ -2,38 +2,15 @@ bin/mkoctfile
bin/mkoctfile-%%OCTAVE_VERSION%%
bin/octave
bin/octave-%%OCTAVE_VERSION%%
-bin/octave-bug
-bin/octave-bug-%%OCTAVE_VERSION%%
bin/octave-config
bin/octave-config-%%OCTAVE_VERSION%%
share/applications/www.octave.org-octave.desktop
-%%PORTDOCS%%%%DOCSDIR%%/Octave-FAQ.ps
+%%PORTDOCS%%%%DOCSDIR%%/OctaveFAQ.ps
%%PORTDOCS%%%%DOCSDIR%%/liboctave.ps
%%PORTDOCS%%%%DOCSDIR%%/refcard-a4.ps
%%PORTDOCS%%%%DOCSDIR%%/refcard-legal.ps
%%PORTDOCS%%%%DOCSDIR%%/refcard-letter.ps
+%%PORTDOCS%%%%DOCSDIR%%/octave.ps
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@comment octave diggs some empty directories
-@exec mkdir -p %D/share/octave/site/m/startup/octaverc 2>/dev/null || true
-@exec mkdir -p %D/share/octave/site/api-v37/m 2>/dev/null || true
-@exec mkdir -p %D/share/octave/site/api-v37 2>/dev/null || true
-@exec mkdir -p %D/share/octave/%%OCTAVE_VERSION%%/site/m 2>/dev/null || true
-@exec mkdir -p %D/share/octave/%%OCTAVE_VERSION%%/site 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/site/oct/%%GNU_HOST%% 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/site/oct/api-v37/%%GNU_HOST%% 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/site/oct/api-v37 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/site/oct 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/site/exec/%%GNU_HOST%% 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/site/exec 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/site 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/api-v37/site/exec/%%GNU_HOST%% 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/api-v37/site/exec 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/api-v37/site 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/api-v37 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/%%OCTAVE_VERSION%%/site/oct/%%GNU_HOST%% 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/%%OCTAVE_VERSION%%/site/oct 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/%%OCTAVE_VERSION%%/site/exec/%%GNU_HOST%% 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/%%OCTAVE_VERSION%%/site/exec 2>/dev/null || true
-@exec mkdir -p %D/libexec/octave/%%OCTAVE_VERSION%%/site 2>/dev/null || true
@comment Insert PLIST here
@dirrmtry share/applications