aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/xinetd/Makefile2
-rw-r--r--security/xinetd/files/patch-af11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index c4e1836b5ed2..1dc4550c861d 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= vanilla@FreeBSD.org
FETCH_BEFORE_ARGS= -b
GNU_CONFIGURE= yes
ALL_TARGET= build
-CONFIGURE_ARGS= --with-loadavg --with-libwrap
+CONFIGURE_ARGS= --with-loadavg --with-libwrap --with-inet6
MAN5= xinetd.conf.5
MAN8= xinetd.8 xinetd.log.8
diff --git a/security/xinetd/files/patch-af b/security/xinetd/files/patch-af
new file mode 100644
index 000000000000..46f406a3c1b5
--- /dev/null
+++ b/security/xinetd/files/patch-af
@@ -0,0 +1,11 @@
+--- xinetd/child.c.orig Sun Apr 30 16:13:07 2000
++++ xinetd/child.c Sun Apr 30 16:13:47 2000
+@@ -320,7 +320,7 @@
+ "(%s service) %s", program_name, SC_ID( scp ) ) ;
+
+ #ifdef INET6
+- if ( SC_ACCEPTS_CONNECTIONS( scp ) && !IN6_IS_ADDR_UNSPECIFIED(sinp) )
++ if ( SC_ACCEPTS_CONNECTIONS( scp ) && !IN6_IS_ADDR_UNSPECIFIED(&(sinp->sin6_addr)) )
+ strx_print( INT_NULL, &name[ len ], namelen - len,
+ " %s" , xntoa( *sinp ) ) ;
+ #else