aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-Sysadm-Install/Makefile43
-rw-r--r--sysutils/p5-Sysadm-Install/distinfo3
-rw-r--r--sysutils/p5-Sysadm-Install/pkg-descr5
-rw-r--r--sysutils/p5-Sysadm-Install/pkg-plist6
5 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index a50e995d4d4d..25b9f1b60b1f 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -438,6 +438,7 @@
SUBDIR += p5-Sys-Hostname-FQDN
SUBDIR += p5-Sys-Hostname-Long
SUBDIR += p5-Sys-Utmp
+ SUBDIR += p5-Sysadm-Install
SUBDIR += p5-SyslogScan
SUBDIR += p5-Tie-Syslog
SUBDIR += p5-UPS-Nut
diff --git a/sysutils/p5-Sysadm-Install/Makefile b/sysutils/p5-Sysadm-Install/Makefile
new file mode 100644
index 000000000000..c352b55db377
--- /dev/null
+++ b/sysutils/p5-Sysadm-Install/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: p5-Algorithm-Bucketizer
+# Date created: 28 Nov 2006
+# Whom: Christopher Boumenot <boumenot@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sysadm-Install
+PORTVERSION= 0.22
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MS/MSCHILLI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= boumenot@gmail.com
+COMMENT= Typical installation tasks for system administrators
+
+BUILD_DEPENDS= ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
+ ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.if defined(WITH_ARCHIVE_TAR)
+BUILD_DEPENDS+= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar
+RUN_DEPENDS+= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar
+.endif
+
+.if defined(WITH_EXPECT)
+BUILD_DEPENDS+= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
+RUN_DEPENDS+= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
+.endif
+
+PERL_CONFIGURE= yes
+
+MAN3= Sysadm::Install.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6.0 or superior. Install lang/perl5.6 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-Sysadm-Install/distinfo b/sysutils/p5-Sysadm-Install/distinfo
new file mode 100644
index 000000000000..1a58bd101b41
--- /dev/null
+++ b/sysutils/p5-Sysadm-Install/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sysadm-Install-0.22.tar.gz) = 8caa398f855dcca9dc72afcfa4dba2e1
+SHA256 (Sysadm-Install-0.22.tar.gz) = deb3d338b3d9568d4a3ec1903a76897605994910b1712dfb2a7da39519857f38
+SIZE (Sysadm-Install-0.22.tar.gz) = 19613
diff --git a/sysutils/p5-Sysadm-Install/pkg-descr b/sysutils/p5-Sysadm-Install/pkg-descr
new file mode 100644
index 000000000000..dfa64ea48551
--- /dev/null
+++ b/sysutils/p5-Sysadm-Install/pkg-descr
@@ -0,0 +1,5 @@
+Sysadm::Install executes shell-like commands performing typical installation
+tasks: Copying files, extracting tarballs, calling make.
+
+Author: Mike Schilli <m@perlmeister.com>
+WWW: http://search.cpan.org/dist/Sysadm-Install
diff --git a/sysutils/p5-Sysadm-Install/pkg-plist b/sysutils/p5-Sysadm-Install/pkg-plist
new file mode 100644
index 000000000000..821577857a1a
--- /dev/null
+++ b/sysutils/p5-Sysadm-Install/pkg-plist
@@ -0,0 +1,6 @@
+bin/one-liner
+%%SITE_PERL%%/Sysadm/Install.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sysadm/Install/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sysadm/Install
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sysadm
+@dirrmtry %%SITE_PERL%%/Sysadm