aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/py-protocols-devel/Makefile38
-rw-r--r--devel/py-protocols-devel/distinfo6
-rw-r--r--devel/py-protocols-devel/files/pkg-deinstall.in17
-rw-r--r--devel/py-protocols-devel/files/pkg-install.in16
-rw-r--r--devel/py-protocols-devel/pkg-plist1
5 files changed, 14 insertions, 64 deletions
diff --git a/devel/py-protocols-devel/Makefile b/devel/py-protocols-devel/Makefile
index 73c1c15cffaf..0dad05d1bec9 100644
--- a/devel/py-protocols-devel/Makefile
+++ b/devel/py-protocols-devel/Makefile
@@ -6,39 +6,21 @@
#
PORTNAME= PyProtocols
-PORTVERSION= 1.0.a0.r2082
+PORTVERSION= 1.0.a0.r2302
CATEGORIES= devel python
-MASTER_SITES= http://peak.telecommunity.com/snapshots/ \
- http://dryice.name/computer/FreeBSD/distfiles/
+MASTER_SITES= http://files.turbogears.org/eggs/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}-1.0a0dev_r2082
+DISTNAME= ${PORTNAME}-1.0a0dev-r2302
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= wenheping@gmail.com
COMMENT= Protocol Definition, Declaration, and Adaptation for Python
-BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}DecoratorTools>=1.7:${PORTSDIR}/devel/py-decoratortools
-NO_PACKAGE= not yet
-
-PLIST_FILES= ${PYTHON_SITELIBDIR:S,${PREFIX}/,,}/${PYPROTOCOLS_EGG}
-PLIST_SUB= PYPROTOCOLS_EGG="${PYPROTOCOLS_EGG}"
-
-SUB_FILES+= pkg-deinstall pkg-install
-SUB_LIST+= EGG="PyProtocols==${PYPROTOCOLS_VER}" \
- PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
-
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_PKGVERSION= 1.0a0
USE_ZIP= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
+PYDISTUTILS_PKGVERSION= 1.0a0dev-r2302
-PYDISTUTILS_NOEGGINFO= yes # XXX convert easy_install support to bsd.python.mk's
-PYPROTOCOLS_EGG= PyProtocols-${PYPROTOCOLS_VER}-py${PYTHON_VERSION:S/^python//}-${OPSYS:L}-${OSRELEASE}-${ARCH}.egg
-PYPROTOCOLS_VER?= 1.0a0
-
-.include <bsd.port.pre.mk>
-
-OSRELEASE!= /usr/bin/uname -r
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-protocols-devel/distinfo b/devel/py-protocols-devel/distinfo
index adac17e8e7e4..c204e1092c8d 100644
--- a/devel/py-protocols-devel/distinfo
+++ b/devel/py-protocols-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (PyProtocols-1.0a0dev_r2082.zip) = 11c5871560b65cf72b45845013297b94
-SHA256 (PyProtocols-1.0a0dev_r2082.zip) = fb8b9a3db25e0b447fbf327c26b859368cefdc14438b9752ab248b788f119016
-SIZE (PyProtocols-1.0a0dev_r2082.zip) = 124061
+MD5 (PyProtocols-1.0a0dev-r2302.zip) = 04ab0051ceb961919607b025a92671f7
+SHA256 (PyProtocols-1.0a0dev-r2302.zip) = b17f625fe6c2eb8a1ad4fefb0ac93edbf9267213f636132f1e094409931f1858
+SIZE (PyProtocols-1.0a0dev-r2302.zip) = 124071
diff --git a/devel/py-protocols-devel/files/pkg-deinstall.in b/devel/py-protocols-devel/files/pkg-deinstall.in
deleted file mode 100644
index 8ee207b16f16..000000000000
--- a/devel/py-protocols-devel/files/pkg-deinstall.in
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-PKGNAME=$1
-#
-case $2 in
- DEINSTALL)
- easy_install -q -m -x -S %%PYTHON_SITELIBDIR%% %%EGG%%
- ;;
- POST-DEINSTALL)
- exit 0
- ;;
- *)
- echo "Unexpected Argument $2!!!"
- exit 1
- ;;
-esac
-exit 0
diff --git a/devel/py-protocols-devel/files/pkg-install.in b/devel/py-protocols-devel/files/pkg-install.in
deleted file mode 100644
index 9cddbe28f167..000000000000
--- a/devel/py-protocols-devel/files/pkg-install.in
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-PKGNAME=$1
-#
-case $2 in
- POST-INSTALL)
- easy_install -q -N -S %%PYTHON_SITELIBDIR%% %%EGG%%
- ;;
- PRE-INSTALL)
- ;;
- *)
- echo "Unexpected Argument $2!!!"
- exit 1
- ;;
-esac
-exit 0
diff --git a/devel/py-protocols-devel/pkg-plist b/devel/py-protocols-devel/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/devel/py-protocols-devel/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%