aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/juk/Makefile8
-rw-r--r--audio/lindele/Makefile8
-rw-r--r--comms/klog/Makefile8
-rw-r--r--deskutils/kluje/Makefile8
-rw-r--r--devel/libsigcx/Makefile8
-rw-r--r--ftp/kftpgrabber/Makefile8
-rw-r--r--games/KnightCap/Makefile8
-rw-r--r--games/kpacman/Makefile8
-rw-r--r--graphics/k3d/Makefile4
-rw-r--r--java/jlint/Makefile4
-rw-r--r--korean/bitchx/Makefile4
-rw-r--r--korean/han/Makefile8
-rw-r--r--math/kaskade/Makefile8
-rw-r--r--math/linalg/Makefile4
-rw-r--r--net/l2tpd/Makefile4
-rw-r--r--sysutils/lineakd/Makefile8
-rw-r--r--textproc/latte/Makefile9
-rw-r--r--www/larbin/Makefile8
-rw-r--r--www/linux-nvu/Makefile2
19 files changed, 114 insertions, 13 deletions
diff --git a/audio/juk/Makefile b/audio/juk/Makefile
index 6c567ebdd326..d0fbb8169014 100644
--- a/audio/juk/Makefile
+++ b/audio/juk/Makefile
@@ -25,9 +25,15 @@ USE_REINPLACE= yes
CONFIGURE_TARGET= --build=${ARCH}-portsbld-freebsd${OSREL}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g; s|-pedantic ||g; \
s|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/lindele/Makefile b/audio/lindele/Makefile
index 181db1719139..d0fe28b69c5c 100644
--- a/audio/lindele/Makefile
+++ b/audio/lindele/Makefile
@@ -24,4 +24,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/klog/Makefile b/comms/klog/Makefile
index b27bf8dd3ab9..a6632e4dfa10 100644
--- a/comms/klog/Makefile
+++ b/comms/klog/Makefile
@@ -16,4 +16,10 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/kluje/Makefile b/deskutils/kluje/Makefile
index 9b8b80052f1b..06f78d5ca820 100644
--- a/deskutils/kluje/Makefile
+++ b/deskutils/kluje/Makefile
@@ -20,8 +20,14 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libsigcx/Makefile b/devel/libsigcx/Makefile
index eb436fd1e200..554280128ee3 100644
--- a/devel/libsigcx/Makefile
+++ b/devel/libsigcx/Makefile
@@ -26,4 +26,10 @@ CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-static --enable-shared
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ftp/kftpgrabber/Makefile b/ftp/kftpgrabber/Makefile
index 4d4533c33d08..ea8e8cfbdcba 100644
--- a/ftp/kftpgrabber/Makefile
+++ b/ftp/kftpgrabber/Makefile
@@ -22,7 +22,13 @@ USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/KnightCap/Makefile b/games/KnightCap/Makefile
index edfe375fb86f..33b735facb14 100644
--- a/games/KnightCap/Makefile
+++ b/games/KnightCap/Makefile
@@ -26,6 +26,12 @@ DOCSDIR= ${PREFIX}/share/doc/KnightCap
PORTDOCS= README
PLIST_FILES= bin/KnightCap
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/KnightCap ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@@ -33,4 +39,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/kpacman/Makefile b/games/kpacman/Makefile
index 6241dd8393b4..40614d3e2969 100644
--- a/games/kpacman/Makefile
+++ b/games/kpacman/Makefile
@@ -24,7 +24,13 @@ CONFIGURE_TARGET=
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s,-lqt,-lqt-mt ${PTHREAD_LIBS}," ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
index fe49989cd134..8db00015d221 100644
--- a/graphics/k3d/Makefile
+++ b/graphics/k3d/Makefile
@@ -43,6 +43,10 @@ MAN1= k3d.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${OSVERSION} < 500000
BROKEN= "Does not compile on FreeBSD 4.x"
.endif
diff --git a/java/jlint/Makefile b/java/jlint/Makefile
index 1372d3a5fd5c..d5c1e5fe8ff1 100644
--- a/java/jlint/Makefile
+++ b/java/jlint/Makefile
@@ -18,6 +18,10 @@ USE_REINPLACE= YES
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' ${WRKSRC}/jlint.sh
diff --git a/korean/bitchx/Makefile b/korean/bitchx/Makefile
index 7aecd1fd3a51..23b46703f2ea 100644
--- a/korean/bitchx/Makefile
+++ b/korean/bitchx/Makefile
@@ -34,6 +34,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${ARCH} == "sparc64"
BROKEN= "Does not compile on sparc64 (needs -fPIC)"
.endif
diff --git a/korean/han/Makefile b/korean/han/Makefile
index 9294d0103e1b..fcc10702c6f8 100644
--- a/korean/han/Makefile
+++ b/korean/han/Makefile
@@ -19,6 +19,12 @@ ONLY_FOR_ARCHS= i386
USE_GMAKE= YES
USE_REINPLACE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/src/vt.c ${WRKSRC}/lib/mem.c
@@ -33,4 +39,4 @@ post-configure:
-e 's%%DISTDIR%%${DISTDIR}' \
${FILESDIR}/han.sh > ${WRKSRC}/han.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/kaskade/Makefile b/math/kaskade/Makefile
index 63a33c604731..027f73d23590 100644
--- a/math/kaskade/Makefile
+++ b/math/kaskade/Makefile
@@ -20,6 +20,12 @@ GNU_CONFIGURE= yes
DIST_SUBDIR= kaskade
WRKSRC= ${WRKDIR}/3.2.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
${CP} ${FILESDIR}/Makefile ${WRKSRC}
${CP} ${FILESDIR}/configure ${WRKSRC}
@@ -34,4 +40,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/data/*.mat ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/linalg/Makefile b/math/linalg/Makefile
index 47e9e46f70cb..5f5d7d395ed1 100644
--- a/math/linalg/Makefile
+++ b/math/linalg/Makefile
@@ -22,6 +22,10 @@ USE_GMAKE= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
$(INSTALL_DATA) ${WRKSRC}/libla.a ${PREFIX}/lib
${MKDIR} ${PREFIX}/include/LinAlg
diff --git a/net/l2tpd/Makefile b/net/l2tpd/Makefile
index 429f460c4e85..244cc9deead2 100644
--- a/net/l2tpd/Makefile
+++ b/net/l2tpd/Makefile
@@ -21,6 +21,10 @@ MAN8= l2tpd.8
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
do-configure:
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/doc/l2tpd.8 \
${WRKSRC}/doc/l2tpd.conf.sample ${WRKSRC}/doc/l2tp-secrets.5 \
diff --git a/sysutils/lineakd/Makefile b/sysutils/lineakd/Makefile
index 3b87c4ab4a53..a445f87789b4 100644
--- a/sysutils/lineakd/Makefile
+++ b/sysutils/lineakd/Makefile
@@ -30,6 +30,12 @@ LIB_DEPENDS+= xosd.4:${PORTSDIR}/misc/xosd
PORTDOCS= README TODO AUTHORS
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread||' ${WRKSRC}/lineakd/Makefile.in
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
@@ -44,4 +50,4 @@ post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/lineakd.conf.example ${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/latte/Makefile b/textproc/latte/Makefile
index c95fac3eb2ab..62a9d7d965fb 100644
--- a/textproc/latte/Makefile
+++ b/textproc/latte/Makefile
@@ -29,6 +29,13 @@ INFO= latte liblatte
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+
+.endif
+
post-extract:
-@${RM} ${WRKSRC}/getopt*
@@ -42,4 +49,4 @@ post-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/larbin/Makefile b/www/larbin/Makefile
index dc61bb357ca1..36a39eb9665b 100644
--- a/www/larbin/Makefile
+++ b/www/larbin/Makefile
@@ -24,6 +24,12 @@ USE_REINPLACE= yes
PATCH_WRKSRC= ${WRKSRC}/src
MAKE_ARGS= CXX=${CXX}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${SED} -e 's,CC=,CC?=,' -e 's,CFLAGS=-O3,CFLAGS+=,' < \
${WRKSRC}/adns/Makefile > ${WRKSRC}/adns/Makefile.new
@@ -59,4 +65,4 @@ post-install:
@${ECHO} ""
@${ECHO} "====================================================================="
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/linux-nvu/Makefile b/www/linux-nvu/Makefile
index e79191a45d13..6009a1c3838a 100644
--- a/www/linux-nvu/Makefile
+++ b/www/linux-nvu/Makefile
@@ -23,6 +23,8 @@ RUN_DEPENDS= \
${LINUXBASE}/usr/lib/libpango-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango \
${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig
+BROKEN= "Conflicting dependencies (linux_base 7.x and 8.x)"
+
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
ONLY_FOR_ARCHS= i386