aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/knapster/Makefile2
-rw-r--r--audio/krio/Makefile2
-rw-r--r--devel/kdbg/Makefile2
-rw-r--r--graphics/killustrator/Makefile2
-rw-r--r--japanese/kebook/Makefile2
-rw-r--r--misc/khotkeys/Makefile2
-rw-r--r--net/kmud/Makefile2
7 files changed, 14 insertions, 0 deletions
diff --git a/audio/knapster/Makefile b/audio/knapster/Makefile
index 1863d8b610d5..76f2799f0eef 100644
--- a/audio/knapster/Makefile
+++ b/audio/knapster/Makefile
@@ -17,6 +17,8 @@ MAINTAINER= jedgar@FreeBSD.org
LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
RUN_DEPENDS= kdehelp:${PORTSDIR}/x11/kdebase11
+BROKEN= "KDE 1.x is no longer in the the ports tree"
+
USE_AUTOCONF= yes
USE_GMAKE= yes
USE_QT= yes
diff --git a/audio/krio/Makefile b/audio/krio/Makefile
index 0cdb3892b8fd..d3237e451796 100644
--- a/audio/krio/Makefile
+++ b/audio/krio/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11 \
kfile.3:${PORTSDIR}/x11/kdelibs11
RUN_DEPENDS= kdehelp:${PORTSDIR}/x11/kdebase11
+BROKEN= "KDE 1.x is no longer in the ports tree"
+
USE_QT= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
diff --git a/devel/kdbg/Makefile b/devel/kdbg/Makefile
index ae10737b4ae7..444513c92027 100644
--- a/devel/kdbg/Makefile
+++ b/devel/kdbg/Makefile
@@ -17,6 +17,8 @@ BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
RUN_DEPENDS= kdehelp:${PORTSDIR}/x11/kdebase11
+BROKEN= "KDE 1.x is no longer in the ports tree"
+
GNU_CONFIGURE= yes
USE_QT= yes
diff --git a/graphics/killustrator/Makefile b/graphics/killustrator/Makefile
index 925f1fde5d9f..9d5832f72701 100644
--- a/graphics/killustrator/Makefile
+++ b/graphics/killustrator/Makefile
@@ -17,6 +17,8 @@ LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11 \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
RUN_DEPENDS= ${LOCALBASE}/bin/kdehelp:${PORTSDIR}/x11/kdebase11
+BROKEN= "KDE 1.x is no longer in the ports tree"
+
USE_QT= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
diff --git a/japanese/kebook/Makefile b/japanese/kebook/Makefile
index d54bbba8c179..c2b36a5dac54 100644
--- a/japanese/kebook/Makefile
+++ b/japanese/kebook/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11 \
BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
RUN_DEPENDS= kfm:${PORTSDIR}/x11/kdebase11
+BROKEN= "KDE 1.x is no longer in the ports tree"
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_NEWGCC= yes
diff --git a/misc/khotkeys/Makefile b/misc/khotkeys/Makefile
index f4ec5985b049..4601f0880405 100644
--- a/misc/khotkeys/Makefile
+++ b/misc/khotkeys/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11 \
kfile.3:${PORTSDIR}/x11/kdelibs11
RUN_DEPENDS= kcontrol:${PORTSDIR}/x11/kdebase11
+BROKEN= "KDE 1.x is no longer in the ports tree"
+
NO_LATEST_LINK= yes
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/net/kmud/Makefile b/net/kmud/Makefile
index db65b8d5058d..9c21dd63ebb4 100644
--- a/net/kmud/Makefile
+++ b/net/kmud/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
BUILD_DEPENDS= gettext:${PORTSDIR}/devel/gettext
RUN_DEPENDS= kdehelp:${PORTSDIR}/x11/kdebase11
+BROKEN= "KDE 1.x is no longer in the ports tree"
+
USE_QT= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \