aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/gtksql/Makefile1
-rw-r--r--databases/gtksql/files/patch-aa4
-rw-r--r--databases/gtksql/files/patch-postgres.c11
-rw-r--r--databases/p5-DBD-Pg-13/Makefile16
-rw-r--r--databases/p5-DBD-Pg/Makefile16
-rw-r--r--databases/p5-Pg/Makefile5
-rw-r--r--databases/pgaccess/Makefile8
-rw-r--r--databases/pgaccess/distinfo2
-rw-r--r--databases/pgaccess/pkg-plist2
-rw-r--r--databases/phppgadmin/Makefile4
-rw-r--r--databases/py-PyGreSQL/Makefile44
-rw-r--r--databases/py-PyGreSQL/distinfo2
-rw-r--r--databases/py-PyGreSQL/files/Makefile4
-rw-r--r--databases/ruby-postgres/Makefile6
-rw-r--r--databases/rubygem-postgres/Makefile6
-rw-r--r--databases/zpygresqlda/Makefile5
-rw-r--r--security/pam-pgsql/Makefile3
-rw-r--r--security/pam-pgsql/files/Makefile.bsd6
-rw-r--r--www/mod_auth_pgsql/Makefile10
-rw-r--r--www/mod_auth_pgsql/files/patch-configure40
-rw-r--r--www/mod_php3/Makefile1
-rw-r--r--www/mod_php3/scripts/configure.php4
-rw-r--r--www/mod_php4/Makefile1
-rw-r--r--www/mod_php4/scripts/configure.php4
-rw-r--r--www/mod_php5/Makefile1
-rw-r--r--www/mod_php5/scripts/configure.php4
26 files changed, 133 insertions, 77 deletions
diff --git a/databases/gtksql/Makefile b/databases/gtksql/Makefile
index d05a0ae62521..4d553e5a8ba6 100644
--- a/databases/gtksql/Makefile
+++ b/databases/gtksql/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtksql
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.multimania.com/bbrox/GtkSQL/
diff --git a/databases/gtksql/files/patch-aa b/databases/gtksql/files/patch-aa
index dd92f953583d..a75bec6e00e4 100644
--- a/databases/gtksql/files/patch-aa
+++ b/databases/gtksql/files/patch-aa
@@ -11,8 +11,8 @@
-PGSQLIBS = -L/usr/local/pgsql/lib -lpq
-PGSQLCFLAGS = -I/usr/local/pgsql/include -DUSE_POSTGRESQL
-PGSQLOBJS = postgres.o
-+#PGSQLIBS = -L/usr/local/pgsql/lib -lpq
-+#PGSQLCFLAGS = -I/usr/local/pgsql/include -DUSE_POSTGRESQL
++#PGSQLIBS = -L/usr/local/lib -lpq
++#PGSQLCFLAGS = -I/usr/local/include/pgsql -DUSE_POSTGRESQL
+#PGSQLOBJS = postgres.o
# Here, what you need for MySQL
diff --git a/databases/gtksql/files/patch-postgres.c b/databases/gtksql/files/patch-postgres.c
new file mode 100644
index 000000000000..4e291b4cb0b7
--- /dev/null
+++ b/databases/gtksql/files/patch-postgres.c
@@ -0,0 +1,11 @@
+--- postgres.c.orig Sat Apr 21 19:16:37 2001
++++ postgres.c Sat Apr 21 19:16:47 2001
+@@ -18,7 +18,7 @@
+
+ #include <libpq-fe.h>
+ #include <string.h>
+-#include <postgres.h>
++#include <c.h>
+
+ #include "common.h"
+ #include "status.h"
diff --git a/databases/p5-DBD-Pg-13/Makefile b/databases/p5-DBD-Pg-13/Makefile
index 7d49ca266097..b90fad1f64d6 100644
--- a/databases/p5-DBD-Pg-13/Makefile
+++ b/databases/p5-DBD-Pg-13/Makefile
@@ -5,25 +5,25 @@
# $FreeBSD$
#
-PORTNAME= DBD-Pg
+PORTNAME= DBD-Pg
PORTVERSION= 0.96
-PORTREVISION= 1
-CATEGORIES= databases perl5
+PORTREVISION= 2
+CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
PKGNAMEPREFIX= p5-
-MAINTAINER= demon@FreeBSD.org
+MAINTAINER= demon@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-CONFIGURE_ENV+= POSTGRES_INCLUDE=${PREFIX}/pgsql/include \
- POSTGRES_LIB=${PREFIX}/pgsql/lib
+CONFIGURE_ENV+= POSTGRES_INCLUDE=${PREFIX}/include/pgsql \
+ POSTGRES_LIB=${PREFIX}/lib
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= DBD::Pg.3 DBD::dbd-pg.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= DBD::Pg.3 DBD::dbd-pg.3
.include <bsd.port.mk>
diff --git a/databases/p5-DBD-Pg/Makefile b/databases/p5-DBD-Pg/Makefile
index 7d49ca266097..b90fad1f64d6 100644
--- a/databases/p5-DBD-Pg/Makefile
+++ b/databases/p5-DBD-Pg/Makefile
@@ -5,25 +5,25 @@
# $FreeBSD$
#
-PORTNAME= DBD-Pg
+PORTNAME= DBD-Pg
PORTVERSION= 0.96
-PORTREVISION= 1
-CATEGORIES= databases perl5
+PORTREVISION= 2
+CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
PKGNAMEPREFIX= p5-
-MAINTAINER= demon@FreeBSD.org
+MAINTAINER= demon@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-CONFIGURE_ENV+= POSTGRES_INCLUDE=${PREFIX}/pgsql/include \
- POSTGRES_LIB=${PREFIX}/pgsql/lib
+CONFIGURE_ENV+= POSTGRES_INCLUDE=${PREFIX}/include/pgsql \
+ POSTGRES_LIB=${PREFIX}/lib
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= DBD::Pg.3 DBD::dbd-pg.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= DBD::Pg.3 DBD::dbd-pg.3
.include <bsd.port.mk>
diff --git a/databases/p5-Pg/Makefile b/databases/p5-Pg/Makefile
index b6f032ada864..882762de81dd 100644
--- a/databases/p5-Pg/Makefile
+++ b/databases/p5-Pg/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Pg
PORTVERSION= 1.9.0
+PORTREVISION= 1
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pg
@@ -18,8 +19,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
PERL_CONFIGURE= yes
-CONFIGURE_ENV= POSTGRES_INCLUDE=${LOCALBASE}/pgsql/include \
- POSTGRES_LIB=${LOCALBASE}/pgsql/lib
+CONFIGURE_ENV= POSTGRES_INCLUDE=${LOCALBASE}/include/pgsql \
+ POSTGRES_LIB=${LOCALBASE}/lib
MAN3= Pg.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/databases/pgaccess/Makefile b/databases/pgaccess/Makefile
index 4ce97f9ce57a..cb9d3d4bf63f 100644
--- a/databases/pgaccess/Makefile
+++ b/databases/pgaccess/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= pgaccess
-PORTVERSION= 0.98.6
+PORTVERSION= 0.98.7
CATEGORIES= databases
-MASTER_SITES= ftp://speedy.flex.ro/pub/pgaccess/
+MASTER_SITES= http://www.flex.ro/pgaccess/download/
MAINTAINER= ports@FreeBSD.org
-RUN_DEPENDS= ${LOCALBASE}/pgsql/bin/postmaster:${PORTSDIR}/databases/postgresql7\
- wish8.3:${PORTSDIR}/x11-toolkits/tk83
+RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+LIB_DEPENDS= pgtcl.2:${PORTSDIR}/databases/postgresql7
WRKSRC= ${WRKDIR}/pgaccess
NO_BUILD= yes
diff --git a/databases/pgaccess/distinfo b/databases/pgaccess/distinfo
index 5a057288a128..74b3ba10cda4 100644
--- a/databases/pgaccess/distinfo
+++ b/databases/pgaccess/distinfo
@@ -1 +1 @@
-MD5 (pgaccess-0.98.6.tar.gz) = a7b49bb82974828ffa46b211b74885a0
+MD5 (pgaccess-0.98.7.tar.gz) = 3da929e46db515809d9072a68d8d6407
diff --git a/databases/pgaccess/pkg-plist b/databases/pgaccess/pkg-plist
index 81771c5eacfd..120216e792e6 100644
--- a/databases/pgaccess/pkg-plist
+++ b/databases/pgaccess/pkg-plist
@@ -99,8 +99,10 @@ share/pgaccess/lib/forms.tcl
share/pgaccess/lib/reports.tcl
share/pgaccess/lib/languages/czech
share/pgaccess/lib/languages/deutsch
+share/pgaccess/lib/languages/euskara
share/pgaccess/lib/languages/francais
share/pgaccess/lib/languages/italiano
+share/pgaccess/lib/languages/japanese
share/pgaccess/lib/languages/magyar
share/pgaccess/lib/languages/nederlands
share/pgaccess/lib/languages/portugues
diff --git a/databases/phppgadmin/Makefile b/databases/phppgadmin/Makefile
index f1305d844f9a..996c4217c5e2 100644
--- a/databases/phppgadmin/Makefile
+++ b/databases/phppgadmin/Makefile
@@ -7,18 +7,19 @@
PORTNAME= phppgadmin
PORTVERSION= 2.2.1.p1
+PORTREVISION= 1
CATEGORIES= databases www
MASTER_SITES= ftp://ftp.greatbridge.org/pub/phppgadmin/stable/
DISTNAME= phpPgAdmin_2-2-1-pl1
MAINTAINER= nbm@FreeBSD.org
-RUN_DEPENDS= ${LOCALBASE}/pgsql/lib/libpq.so:${PORTSDIR}/databases/postgresql7
.if defined(WITH_PHP4)
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
.else
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
.endif
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
WRKSRC= ${WRKDIR}/phpPgAdmin
NO_BUILD= YES
@@ -27,5 +28,4 @@ do-install:
${MKDIR} ${PREFIX}/www/data.default/phpPgAdmin/
${CP} -R ${WRKSRC}/* ${PREFIX}/www/data.default/phpPgAdmin/
-
.include <bsd.port.mk>
diff --git a/databases/py-PyGreSQL/Makefile b/databases/py-PyGreSQL/Makefile
index 323994cf000b..41c093d77e73 100644
--- a/databases/py-PyGreSQL/Makefile
+++ b/databases/py-PyGreSQL/Makefile
@@ -5,28 +5,28 @@
# $FreeBSD$
#
-PORTNAME= PyGreSQL
-PORTVERSION= 3.0
-CATEGORIES= databases python
-MASTER_SITES= ftp://ftp.druid.net/pub/distrib/
-PKGNAMEPREFIX= py-
-DISTNAME= PyGreSQL-${PORTVERSION}
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= nectar@FreeBSD.org
-
-BUILD_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
-RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
-LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
-
-USE_PYTHON= yes
-MAKE_ENV= PYTHON_VERSION=${PYTHON_VERSION} \
- PYTHON_LIBDIR=${PYTHON_LIBDIR} \
- PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} \
- PYTHON=${PYTHON_CMD} \
- LN="${LN}" SETENV="${SETENV}" MKDIR="${MKDIR}"
-
-DATETIME_DEP= ${PYTHON_SITELIBDIR}/mx/DateTime/__init__.py
+PORTNAME= PyGreSQL
+PORTVERSION= 3.1
+CATEGORIES= databases python
+MASTER_SITES= ftp://ftp.druid.net/pub/distrib/
+PKGNAMEPREFIX= py-
+DISTNAME= PyGreSQL-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nectar@FreeBSD.org
+
+BUILD_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
+RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
+
+USE_PYTHON= yes
+MAKE_ENV= PYTHON_VERSION=${PYTHON_VERSION} \
+ PYTHON_LIBDIR=${PYTHON_LIBDIR} \
+ PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} \
+ PYTHON=${PYTHON_CMD} \
+ LN="${LN}" SETENV="${SETENV}" MKDIR="${MKDIR}"
+
+DATETIME_DEP= ${PYTHON_SITELIBDIR}/mx/DateTime/__init__.py
pre-build:
${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
diff --git a/databases/py-PyGreSQL/distinfo b/databases/py-PyGreSQL/distinfo
index f25e8f0efbb0..eea1cb60cbcc 100644
--- a/databases/py-PyGreSQL/distinfo
+++ b/databases/py-PyGreSQL/distinfo
@@ -1 +1 @@
-MD5 (PyGreSQL-3.0.tgz) = 3f67b76d6cfece4ac21eee1a9154a206
+MD5 (PyGreSQL-3.1.tgz) = 6c7cef080d3c3b732ff7090dc9e051c1
diff --git a/databases/py-PyGreSQL/files/Makefile b/databases/py-PyGreSQL/files/Makefile
index b1aa7a29fc6c..3ebb172d0424 100644
--- a/databases/py-PyGreSQL/files/Makefile
+++ b/databases/py-PyGreSQL/files/Makefile
@@ -15,12 +15,12 @@ clean:
_pgmodule.so: pgmodule.o
${LD} -Bshareable -lc_r -L${PYTHON_LIBDIR}/config \
- -l${PYTHON_VERSION} -L${PREFIX}/pgsql/lib -lpq \
+ -l${PYTHON_VERSION} -L${PREFIX}/lib -lpq \
${.ALLSRC} -o ${.TARGET}
pgmodule.o: pgmodule.c
${CC} -c -I${PREFIX}/include/${PYTHON_VERSION} \
- -I${PREFIX}/pgsql/include ${.ALLSRC}
+ -I${PREFIX}/include/pgsql ${.ALLSRC}
.py.pyc:
${SETENV} PYTHONPATH=${.CURDIR} ${PYTHON} -c 'import ${.IMPSRC:.py=}'
diff --git a/databases/ruby-postgres/Makefile b/databases/ruby-postgres/Makefile
index a48759ebac9b..5338e8e85ee1 100644
--- a/databases/ruby-postgres/Makefile
+++ b/databases/ruby-postgres/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postgres
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= databases ruby
MASTER_SITES= http://webclub.kcom.ne.jp/mb/noborus/ruby/archive/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -20,12 +21,9 @@ LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-CONFIGURE_ARGS= --with-pgsql-include-dir="${PGDIR}/include" \
- --with-pgsql-lib-dir="${PGDIR}/lib"
+CONFIGURE_ARGS= --with-pgsql-include-dir="${LOCALBASE}/include/pgsql"
INSTALL_TARGET= site-install
-PGDIR?= ${PREFIX}/pgsql
-
DOCS_EN= ChangeLog README doc/postgres.html
DOCS_JA= README.jp doc/postgres.jp.html
diff --git a/databases/rubygem-postgres/Makefile b/databases/rubygem-postgres/Makefile
index a48759ebac9b..5338e8e85ee1 100644
--- a/databases/rubygem-postgres/Makefile
+++ b/databases/rubygem-postgres/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postgres
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= databases ruby
MASTER_SITES= http://webclub.kcom.ne.jp/mb/noborus/ruby/archive/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -20,12 +21,9 @@ LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-CONFIGURE_ARGS= --with-pgsql-include-dir="${PGDIR}/include" \
- --with-pgsql-lib-dir="${PGDIR}/lib"
+CONFIGURE_ARGS= --with-pgsql-include-dir="${LOCALBASE}/include/pgsql"
INSTALL_TARGET= site-install
-PGDIR?= ${PREFIX}/pgsql
-
DOCS_EN= ChangeLog README doc/postgres.html
DOCS_JA= README.jp doc/postgres.jp.html
diff --git a/databases/zpygresqlda/Makefile b/databases/zpygresqlda/Makefile
index 9746d6730ca8..25f8abcc0a40 100644
--- a/databases/zpygresqlda/Makefile
+++ b/databases/zpygresqlda/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zpygresqlda
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.zope.org/Members/reedstrm/ZPyGreSQLDA-rjr/
DISTNAME= ZPyGreSQLDA-0.3-rjr2
@@ -34,8 +35,8 @@ do-build:
@${ECHO} '*shared*' > ${WRKSRC}/src/Setup
@${ECHO} '' >> ${WRKSRC}/src/Setup
@${ECHO} '_pg pgmodule.c ' \
- '-I${LOCALBASE}/pgsql/include ' \
- '-L${LOCALBASE}/pgsql/lib ' \
+ '-I${LOCALBASE}/include/pgsql ' \
+ '-L${LOCALBASE}/lib ' \
'-lpq -lcrypt' >> ${WRKSRC}/src/Setup
@(cd ${WRKSRC}/src && \
make -f Makefile.pre.in boot && \
diff --git a/security/pam-pgsql/Makefile b/security/pam-pgsql/Makefile
index f7688756ab5d..1210f997e279 100644
--- a/security/pam-pgsql/Makefile
+++ b/security/pam-pgsql/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pam-pgsql
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= security databases
# When the family of Debian mirrors is added to bsd.port.mk,
# this will suddenly start making sense:
@@ -18,7 +19,7 @@ DISTFILES= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= mi@aldan.algebra.com
-LIB_DEPENDS= pq:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ARGS+= -j 2
diff --git a/security/pam-pgsql/files/Makefile.bsd b/security/pam-pgsql/files/Makefile.bsd
index 849bc8782ef7..43e689a0de99 100644
--- a/security/pam-pgsql/files/Makefile.bsd
+++ b/security/pam-pgsql/files/Makefile.bsd
@@ -4,9 +4,9 @@ SRCS= pam_pgsql.c pam_get_pass.c pam_std_option.c pam_get_service.c
LIB= pam_pgsql
SHLIB_NAME=${LIB}.so
-LDADD= -lpam -L${LOCALBASE}/pgsql/lib -lpq
-INCLUDE= -I${LOCALBASE}/pgsql/include
-CFLAGS+= -Wall -D_GNU_SOURCE -I${LOCALBASE}/pgsql/include
+LDADD= -lpam -L${LOCALBASE}/lib -lpq
+INCLUDE= -I${LOCALBASE}/include/pgsql
+CFLAGS+= -Wall -D_GNU_SOURCE -I${LOCALBASE}/include/pgsql
INTERNALLIB= we don't need no stinking static lib
diff --git a/www/mod_auth_pgsql/Makefile b/www/mod_auth_pgsql/Makefile
index 1edca2dfcc4c..73037103da46 100644
--- a/www/mod_auth_pgsql/Makefile
+++ b/www/mod_auth_pgsql/Makefile
@@ -6,15 +6,15 @@
PORTNAME= mod_auth_pgsql
PORTVERSION= 0.9.5a
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.eurolink.it/pub/linux/postgreSQL/mod_auth_pgsql/
MAINTAINER= mi@aldan.algebra.com
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/${AP_PORT} \
- ${LOCALBASE}/pgsql/lib/libpq.so:${PORTSDIR}/databases/postgresql7
-RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${PORTSDIR}/www/${AP_PORT} \
- ${LOCALBASE}/pgsql/lib/libpq.so:${PORTSDIR}/databases/postgresql7
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/${AP_PORT}
+RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${PORTSDIR}/www/${AP_PORT}
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
@@ -46,7 +46,7 @@ PLIST_SUB+= AUTH_PGSQL_DOCS="${AUTH_PGSQL_DOCS}"
PKGMESSAGE= ${WRKSRC}/.install_notes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --with-pgsql=${PREFIX}/pgsql \
+CONFIGURE_ARGS= --with-pgsql=${PREFIX} \
--with-apxs=${APXS}
.if !defined(NOPORTDOCS)
diff --git a/www/mod_auth_pgsql/files/patch-configure b/www/mod_auth_pgsql/files/patch-configure
new file mode 100644
index 000000000000..f13c0017d002
--- /dev/null
+++ b/www/mod_auth_pgsql/files/patch-configure
@@ -0,0 +1,40 @@
+--- configure.orig Sat Apr 21 19:23:27 2001
++++ configure Sat Apr 21 19:24:38 2001
+@@ -1077,20 +1077,20 @@
+ withval="$with_pgsql"
+
+ if test "$withval" != "no" ; then
+- if test -f "$withval/include/libpq-fe.h" ; then
++ if test -f "$withval/include/pgsql/libpq-fe.h" ; then
+ PG_DIR=$withval
+- PG_INCLUDE="$withval/include"
++ PG_INCLUDE="$withval/include/pgsql"
+ PG_LIB="$withval/lib"
+ fi
+ if test "$PG_DIR" = "" ; then
+- if test -f "$withval/include/libpq-fe.h" ; then
++ if test -f "$withval/include/pgsql/libpq-fe.h" ; then
+ XML_DIR=$withval
+- XML_INCLUDE="$withval/include"
++ XML_INCLUDE="$withval/include/pgsql"
+ XML_LIB="$withval/lib"
+ fi
+ fi
+ if test "$PG_DIR" = "" ; then
+- if test -f "$withval/lib/libpq.a" -a -f "$withval/include/libpq-fe.h" ; then
++ if test -f "$withval/lib/libpq.a" -a -f "$withval/include/pgsql/libpq-fe.h" ; then
+ XML_DIR=$withval
+ XML_INCLUDE="$withval/include"
+ XML_LIB=$withval/lib
+@@ -1106,9 +1106,9 @@
+
+ if test "$PG_DIR" = ""; then
+ for i in /usr /usr/local /usr/local/postgres; do
+- if test -f "$i/include/libpq-fe.h"; then
++ if test -f "$i/include/pgsql/libpq-fe.h"; then
+ PG_DIR=$i
+- PG_INCLUDE="$i/include"
++ PG_INCLUDE="$i/include/pgsql"
+ PG_LIB="$i/lib"
+ elif test -f "$i/include/pgsql/libpq-fe.h"; then
+ PG_DIR=$i
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index 51375fc6d365..179bcb76f2bd 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= mod_php3
PORTVERSION= 3.0.18
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES= ftp://ftp.php.net/pub/${PHP_DISTDIR}/ \
http://us.php.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index 5e7cad763a09..585b67f5d559 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -105,8 +105,8 @@ while [ "$1" ]; do
;;
\"PostgreSQL\")
echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7"
- echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}/pgsql"
- if /usr/bin/ldd ${PREFIX}/pgsql/bin/postgres | /usr/bin/grep -q "libssl"; then
+ echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}"
+ if /usr/bin/ldd ${PREFIX}/bin/postgres | /usr/bin/grep -q "libssl"; then
LIBS="-lcrypto -lssl"
fi
;;
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 9c7ba331528b..3ae8b2b8d5e3 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.0.4pl1
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 4bd4ef2a17d0..585fb91eee0e 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -113,8 +113,8 @@ while [ "$1" ]; do
;;
\"PostgreSQL\")
echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7"
- echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}/pgsql"
- if /usr/bin/ldd ${PREFIX}/pgsql/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
+ echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}"
+ if /usr/bin/ldd ${PREFIX}/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
echo "USE_OPENSSL= yes"
LIBS="${LIBS} -L\${OPENSSLBASE}/lib -lcrypto -lssl"
fi
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 9c7ba331528b..3ae8b2b8d5e3 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.0.4pl1
+PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 4bd4ef2a17d0..585fb91eee0e 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -113,8 +113,8 @@ while [ "$1" ]; do
;;
\"PostgreSQL\")
echo "LIB_DEPENDS+= pq.2:\${PORTSDIR}/databases/postgresql7"
- echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}/pgsql"
- if /usr/bin/ldd ${PREFIX}/pgsql/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
+ echo "CONFIGURE_ARGS+=--with-pgsql=\${PREFIX}"
+ if /usr/bin/ldd ${PREFIX}/bin/postgres 2> /dev/null | /usr/bin/grep -q "libssl"; then
echo "USE_OPENSSL= yes"
LIBS="${LIBS} -L\${OPENSSLBASE}/lib -lcrypto -lssl"
fi