aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--korean/Makefile1
-rw-r--r--korean/hunspell/Makefile38
-rw-r--r--korean/hunspell/distinfo2
-rw-r--r--korean/hunspell/files/patch-Makefile8
-rw-r--r--korean/hunspell/pkg-descr3
5 files changed, 52 insertions, 0 deletions
diff --git a/korean/Makefile b/korean/Makefile
index 97d2ea0367f0..f0e8e81445cb 100644
--- a/korean/Makefile
+++ b/korean/Makefile
@@ -28,6 +28,7 @@
SUBDIR += hlatexfonts-ocf
SUBDIR += hmconv
SUBDIR += hpscat
+ SUBDIR += hunspell
SUBDIR += ibus-hangul
SUBDIR += imhangul
SUBDIR += johabfonts
diff --git a/korean/hunspell/Makefile b/korean/hunspell/Makefile
new file mode 100644
index 000000000000..6c8c95b064e8
--- /dev/null
+++ b/korean/hunspell/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Korean hunspell dictionaries
+# Date created: August 9, 2011
+# Whom: Jung-uk Kim <jkim@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hunspell
+PORTVERSION= 0.5.4
+CATEGORIES= korean textproc
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= ${PORTNAME}-dict-ko-${PORTVERSION}
+
+MAINTAINER= jkim@FreeBSD.org
+COMMENT= Korean hunspell dictionaries
+
+LICENSE= GPLv2 LGPL21 MPL
+LICENSE_COMB= dual
+
+BUILD_DEPENDS+= py*-lxml>=0:${PORTSDIR}/devel/py-lxml
+
+USE_GMAKE= yes
+USE_PYTHON_BUILD= yes
+
+PLIST_FILES= %%DATADIR%%/ko-KR.aff \
+ %%DATADIR%%/ko-KR.dic
+PLIST_DIRSTRY= %%DATADIR%%
+
+PROJECTHOST= spellcheck-ko
+
+MAKE_ENV+= PYTHON=${PYTHON_CMD}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ko.aff ${DATADIR}/ko-KR.aff
+ ${INSTALL_DATA} ${WRKSRC}/ko.dic ${DATADIR}/ko-KR.dic
+
+.include <bsd.port.mk>
diff --git a/korean/hunspell/distinfo b/korean/hunspell/distinfo
new file mode 100644
index 000000000000..1e28775f39af
--- /dev/null
+++ b/korean/hunspell/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hunspell-dict-ko-0.5.4.tar.gz) = 419c420740a118b01a2aeb41030e0df2959172b0e62b43336d46591c04c2bdea
+SIZE (hunspell-dict-ko-0.5.4.tar.gz) = 428360
diff --git a/korean/hunspell/files/patch-Makefile b/korean/hunspell/files/patch-Makefile
new file mode 100644
index 000000000000..11a064d3d9c2
--- /dev/null
+++ b/korean/hunspell/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- Makefile.orig 2011-07-17 16:15:50.000000000 -0400
++++ Makefile 2011-08-09 13:54:44.000000000 -0400
+@@ -1,4 +1,4 @@
+-PYTHON = python
++PYTHON ?= python
+ ZIP = zip -r
+
+ AFFIX = ko.aff
diff --git a/korean/hunspell/pkg-descr b/korean/hunspell/pkg-descr
new file mode 100644
index 000000000000..c41840dfebf2
--- /dev/null
+++ b/korean/hunspell/pkg-descr
@@ -0,0 +1,3 @@
+Korean hunspell dictionaries
+
+WWW: http://code.google.com/p/spellcheck-ko/