aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/ifp-line/Makefile2
-rw-r--r--audio/rioutil/Makefile2
-rw-r--r--comms/libticables/Makefile2
-rw-r--r--devel/libusb/Makefile5
-rw-r--r--devel/libusb/distinfo4
-rw-r--r--devel/libusb/files/patch-bsd.c62
-rw-r--r--devel/libusb/files/patch-configure19
-rw-r--r--devel/libusb/files/patch-ltmain.sh16
-rw-r--r--devel/libusb/pkg-plist7
-rw-r--r--graphics/libgphoto2/Makefile2
-rw-r--r--graphics/s10sh/Makefile2
-rw-r--r--graphics/sane-backends/Makefile2
-rw-r--r--misc/gplink/Makefile2
13 files changed, 40 insertions, 87 deletions
diff --git a/audio/ifp-line/Makefile b/audio/ifp-line/Makefile
index b26ef8401640..b967e0cc17e9 100644
--- a/audio/ifp-line/Makefile
+++ b/audio/ifp-line/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ifp-driver
MAINTAINER= riggs@rrr.de
COMMENT= Command line interface to iRiver music players
-LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
MAN1= ifp.1
diff --git a/audio/rioutil/Makefile b/audio/rioutil/Makefile
index 606bcf7fe9da..fad003365b89 100644
--- a/audio/rioutil/Makefile
+++ b/audio/rioutil/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A program to inferface with the Rio600, Rio800 and psa[play devices
-LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
USE_GETOPT_LONG= yes
USE_GMAKE= yes
diff --git a/comms/libticables/Makefile b/comms/libticables/Makefile
index 62fefc6313d9..f3e9d9125ff0 100644
--- a/comms/libticables/Makefile
+++ b/comms/libticables/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= tilp
MAINTAINER= tijl@ulyssis.org
COMMENT= TI calculator link cables library
-LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
GNU_CONFIGURE= yes
USE_GETTEXT= yes
diff --git a/devel/libusb/Makefile b/devel/libusb/Makefile
index 3630bc2a620b..a0dcd04cf3b5 100644
--- a/devel/libusb/Makefile
+++ b/devel/libusb/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= libusb
-PORTVERSION= 0.1.7
-PORTREVISION= 1
+PORTVERSION= 0.1.10a
+#PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,5 +18,6 @@ COMMENT= Library giving userland programs access to USB devices
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-build-docs
INSTALLS_SHLIB= yes
+USE_GCC= 3.1+
.include <bsd.port.mk>
diff --git a/devel/libusb/distinfo b/devel/libusb/distinfo
index a512b5498fc7..b887fec70b2d 100644
--- a/devel/libusb/distinfo
+++ b/devel/libusb/distinfo
@@ -1,2 +1,2 @@
-MD5 (libusb-0.1.7.tar.gz) = 4c7abee86d8715bccb43428a500d2170
-SIZE (libusb-0.1.7.tar.gz) = 193075
+MD5 (libusb-0.1.10a.tar.gz) = c6062b29acd2cef414bcc34e0decbdd1
+SIZE (libusb-0.1.10a.tar.gz) = 375144
diff --git a/devel/libusb/files/patch-bsd.c b/devel/libusb/files/patch-bsd.c
deleted file mode 100644
index 7f188bf7feb0..000000000000
--- a/devel/libusb/files/patch-bsd.c
+++ /dev/null
@@ -1,62 +0,0 @@
---- bsd.c.orig Mon Nov 11 19:04:16 2002
-+++ bsd.c Sun Nov 23 15:51:49 2003
-@@ -276,7 +276,7 @@
- int usb_bulk_write(usb_dev_handle *dev, int ep, char *bytes, int size,
- int timeout)
- {
-- int fd, ret, sent = 0;
-+ int fd, ret;
-
- /* Ensure the endpoint address is correct */
- ep &= ~USB_ENDPOINT_IN;
-@@ -298,8 +298,7 @@
- USB_ERROR_STR(ret, "error setting timeout: %s",
- strerror(errno));
-
-- do {
-- ret = write(fd, bytes+sent, size-sent);
-+ ret = write(fd, bytes, size);
- if (ret < 0)
- #if __FreeBSD__
- USB_ERROR_STR(ret, "error writing to bulk endpoint %s.%d: %s",
-@@ -309,16 +308,13 @@
- dev->device->filename, UE_GET_ADDR(ep), strerror(errno));
- #endif
-
-- sent += ret;
-- } while(ret > 0 && sent < size);
--
-- return sent;
-+ return ret;
- }
-
- int usb_bulk_read(usb_dev_handle *dev, int ep, char *bytes, int size,
- int timeout)
- {
-- int fd, ret, retrieved = 0, one = 1;
-+ int fd, ret, one = 1;
-
- /* Ensure the endpoint address is correct */
- ep |= USB_ENDPOINT_IN;
-@@ -345,8 +341,7 @@
- USB_ERROR_STR(ret, "error setting short xfer: %s",
- strerror(errno));
-
-- do {
-- ret = read(fd, bytes+retrieved, size-retrieved);
-+ ret = read(fd, bytes, size);
- if (ret < 0)
- #if __FreeBSD__
- USB_ERROR_STR(ret, "error reading from bulk endpoint %s.%d: %s",
-@@ -355,10 +350,8 @@
- USB_ERROR_STR(ret, "error reading from bulk endpoint %s.%02d: %s",
- dev->device->filename, UE_GET_ADDR(ep), strerror(errno));
- #endif
-- retrieved += ret;
-- } while (ret > 0 && retrieved < size);
-
-- return retrieved;
-+ return ret;
- }
-
- int usb_control_msg(usb_dev_handle *dev, int requesttype, int request,
diff --git a/devel/libusb/files/patch-configure b/devel/libusb/files/patch-configure
new file mode 100644
index 000000000000..86fff3308225
--- /dev/null
+++ b/devel/libusb/files/patch-configure
@@ -0,0 +1,19 @@
+--- configure.orig Fri Feb 25 23:04:35 2005
++++ configure Fri Feb 25 23:05:03 2005
+@@ -21635,16 +21635,10 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <dev/usb/usb.h>
+-int
+-main ()
+-{
+ int main(void)
+ {
+ int a = ((struct usb_ctl_request *)0L)->ucr_addr;
+ return 0;
+ }
+- ;
+- return 0;
+-}
+ _ACEOF
+ rm -f conftest.$ac_objext
diff --git a/devel/libusb/files/patch-ltmain.sh b/devel/libusb/files/patch-ltmain.sh
index e71718a9f08e..3fd2c8d82822 100644
--- a/devel/libusb/files/patch-ltmain.sh
+++ b/devel/libusb/files/patch-ltmain.sh
@@ -1,16 +1,6 @@
---- ltmain.sh.orig Sat Sep 22 20:10:52 2001
-+++ ltmain.sh Tue Nov 20 21:14:55 2001
-@@ -2444,6 +2444,9 @@
- *-*-openbsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
-@@ -4210,10 +4213,12 @@
+--- ltmain.sh.orig Fri Feb 25 21:55:10 2005
++++ ltmain.sh Fri Feb 25 21:55:38 2005
+@@ -5550,10 +5550,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/devel/libusb/pkg-plist b/devel/libusb/pkg-plist
index 6633c0a45124..6e7f1c475334 100644
--- a/devel/libusb/pkg-plist
+++ b/devel/libusb/pkg-plist
@@ -1,6 +1,11 @@
bin/libusb-config
include/usb.h
-lib/libusb-0.1.so.7
+include/usbpp.h
+lib/libusb-0.1.so.8
lib/libusb-0.1.so
lib/libusb.so
lib/libusb.a
+lib/libusbpp-0.1.so.8
+lib/libusbpp-0.1.so
+lib/libusbpp.so
+lib/libusbpp.a
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index 19855884c45a..d7d3674998e2 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= gphoto
MAINTAINER= ports@FreeBSD.org
COMMENT= A universal digital camera picture control tool
-LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb \
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb \
exif.12:${PORTSDIR}/graphics/libexif
USE_GNOME= gnometarget pkgconfig
diff --git a/graphics/s10sh/Makefile b/graphics/s10sh/Makefile
index 8eb023bb87b9..1c5e0ffd56b3 100644
--- a/graphics/s10sh/Makefile
+++ b/graphics/s10sh/Makefile
@@ -17,7 +17,7 @@ COMMENT= USB/serial userspace driver for the Canon PowerShot digital cameras
.if defined(NOUSB) || defined(WITHOUT_USB)
MAKE_ENV+= WITHOUT_USB=YES
.else
-LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
.endif
# Don't extract the libusb bundled with s10sh:
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 89d8747655e9..24dae6b14901 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -39,7 +39,7 @@ OPTIONS= USB "USB support" on \
CONFIGURE_ARGS+= --disable-libusb
PLIST_SUB+= USB="@comment "
.else
-LIB_DEPENDS+= usb-0.1.7:${PORTSDIR}/devel/libusb
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
PLIST_SUB+= USB=""
.endif
diff --git a/misc/gplink/Makefile b/misc/gplink/Makefile
index bdc81e30b35f..8836ee13891d 100644
--- a/misc/gplink/Makefile
+++ b/misc/gplink/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://dexy.mine.nu/gp32/gplink/
MAINTAINER= king@v2project.com
COMMENT= A GP32 USB linker tool
-LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src