aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/audacious/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/multimedia/audacious/Makefile b/multimedia/audacious/Makefile
index d033abdd862c..95a075a62574 100644
--- a/multimedia/audacious/Makefile
+++ b/multimedia/audacious/Makefile
@@ -32,15 +32,13 @@ MAN1= audacious.1 audtool.1
PORTDOCS= README AUTHORS
-# no ports for:
-# CHARSET "Build with automatic charset detection" off \
-
OPTIONS= DBUS "Build with dbus support" on \
GNOME "Build with gconf support" off \
- ICONV "Build with iconv support" on \
+ ICONV "Build with iconv support" on \
NLS "Native Language Support" on \
EXECINFO "Build with libexecinfo support" on \
- SSE2 "Build with SSE2 instruction set" on
+ SSE2 "Build with SSE2 instruction set" on \
+ CHARSET "Build with automatic charset detection" on
.include <bsd.port.pre.mk>
@@ -79,6 +77,13 @@ PLIST_SUB+= NLS="@comment "
CONFIGURE_ARGS+=--disable-sse2
.endif
+.if defined(WITH_CHARSET)
+LIB_DEPENDS+= guess.1:${PORTSDIR}/textproc/libguess
+CONFIGURE_ARGS+=--enable-chardet
+.else
+CONFIGURE_ARGS+=--disable-chardet
+.endif
+
post-patch:
@${REINPLACE_CMD} 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|g' \
${WRKSRC}/Makefile