aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-oursql/Makefile19
-rw-r--r--databases/py-oursql/distinfo2
-rw-r--r--databases/py-oursql/pkg-descr5
4 files changed, 27 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e5905ac487d7..cf2aa20ea309 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -745,6 +745,7 @@
SUBDIR += py-mysql2pgsql
SUBDIR += py-odbc
SUBDIR += py-oops
+ SUBDIR += py-oursql
SUBDIR += py-peewee
SUBDIR += py-pg8000
SUBDIR += py-pg_pqueue
diff --git a/databases/py-oursql/Makefile b/databases/py-oursql/Makefile
new file mode 100644
index 000000000000..e74338422843
--- /dev/null
+++ b/databases/py-oursql/Makefile
@@ -0,0 +1,19 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= oursql
+PORTVERSION= 0.9.3.1
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= MySQL bindings for python
+
+LICENSE= BSD2CLAUSE
+
+USES= python
+USE_MYSQL= client
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/databases/py-oursql/distinfo b/databases/py-oursql/distinfo
new file mode 100644
index 000000000000..7876b22e4c82
--- /dev/null
+++ b/databases/py-oursql/distinfo
@@ -0,0 +1,2 @@
+SHA256 (oursql-0.9.3.1.tar.gz) = 260d7101ffda97b1aeda3260d88233f769288a79ad2041f3fc9efee3a9f64aca
+SIZE (oursql-0.9.3.1.tar.gz) = 164715
diff --git a/databases/py-oursql/pkg-descr b/databases/py-oursql/pkg-descr
new file mode 100644
index 000000000000..8c588018ea16
--- /dev/null
+++ b/databases/py-oursql/pkg-descr
@@ -0,0 +1,5 @@
+oursql is a set of MySQL bindings for python 2.4+ with a focus
+on wrapping the MYSQL_STMT API to provide real parameterization
+and real server-side cursors. MySQL 4.1.2 or better is required.
+
+WWW: https://launchpad.net/oursql