aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/node12/Makefile3
-rw-r--r--www/node12/distinfo6
-rw-r--r--www/node12/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc6
3 files changed, 7 insertions, 8 deletions
diff --git a/www/node12/Makefile b/www/node12/Makefile
index 4b7130b09a10..22accee929a2 100644
--- a/www/node12/Makefile
+++ b/www/node12/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 12.18.2
-PORTREVISION= 1
+PORTVERSION= 12.18.4
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
diff --git a/www/node12/distinfo b/www/node12/distinfo
index 8ac2484dcdac..ae10bdfdda88 100644
--- a/www/node12/distinfo
+++ b/www/node12/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1593546106
-SHA256 (node-v12.18.2.tar.gz) = 2be366d6068f9e1a5eb3f6f21c5ea246eb0a1faf48f98b88e68c8bb193d85a14
-SIZE (node-v12.18.2.tar.gz) = 52422795
+TIMESTAMP = 1600242147
+SHA256 (node-v12.18.4.tar.gz) = a802d87e579e46fc52771ed6f2667048320caca867be3276f4c4f1bbb41389c3
+SIZE (node-v12.18.4.tar.gz) = 52459484
diff --git a/www/node12/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc b/www/node12/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc
index dddaebe14ea2..2038a1e3c910 100644
--- a/www/node12/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc
+++ b/www/node12/files/patch-deps_v8_src_compiler_backend_instruction-selector.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/compiler/backend/instruction-selector.cc.orig 2020-04-21 11:38:50 UTC
+--- deps/v8/src/compiler/backend/instruction-selector.cc.orig 2020-07-22 15:26:52 UTC
+++ deps/v8/src/compiler/backend/instruction-selector.cc
-@@ -2783,7 +2783,7 @@ void InstructionSelector::VisitCall(Node* node, BasicB
+@@ -2788,7 +2788,7 @@ void InstructionSelector::VisitCall(Node* node, BasicB
switch (call_descriptor->kind()) {
case CallDescriptor::kCallAddress: {
int misc_field = static_cast<int>(call_descriptor->ParameterCount());
@@ -8,4 +8,4 @@
+#if defined(_AIX) || (V8_TARGET_ARCH_PPC_BE && (!defined(_CALL_ELF) || _CALL_ELF == 1))
// Highest misc_field bit is used on AIX to indicate if a CFunction call
// has function descriptor or not.
- if (!call_descriptor->NoFunctionDescriptor()) {
+ misc_field |= call_descriptor->HasFunctionDescriptor()