aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-openpyxl/Makefile2
-rw-r--r--textproc/py-openpyxl1/Makefile23
-rw-r--r--textproc/py-openpyxl1/distinfo2
-rw-r--r--textproc/py-openpyxl1/pkg-descr3
5 files changed, 31 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 5948156ba026..7ca0a9585ff4 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1159,6 +1159,7 @@
SUBDIR += py-markdown
SUBDIR += py-markdown2
SUBDIR += py-openpyxl
+ SUBDIR += py-openpyxl1
SUBDIR += py-paragrep
SUBDIR += py-pdfminer
SUBDIR += py-pss
diff --git a/textproc/py-openpyxl/Makefile b/textproc/py-openpyxl/Makefile
index 00835be7bf6e..087ce0caff06 100644
--- a/textproc/py-openpyxl/Makefile
+++ b/textproc/py-openpyxl/Makefile
@@ -14,6 +14,8 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jdcal>=0:${PORTSDIR}/devel/py-jdcal
+CONFLICTS_INSTALL= py*-openpyxl1-[0-9]*
+
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_AUTOPLIST=yes
diff --git a/textproc/py-openpyxl1/Makefile b/textproc/py-openpyxl1/Makefile
new file mode 100644
index 000000000000..82c8c1f19e43
--- /dev/null
+++ b/textproc/py-openpyxl1/Makefile
@@ -0,0 +1,23 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= openpyxl
+PORTVERSION= 1.8.6
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 1
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Python library to read/write Excel 2007 xlsx/xlsm files
+
+LICENSE= MIT
+
+DEPRECATED= Use textproc/py-openpyxl instead
+CONFLICTS_INSTALL= py*-openpyxl-[0-9]*
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST=yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-openpyxl1/distinfo b/textproc/py-openpyxl1/distinfo
new file mode 100644
index 000000000000..6ae57b67d8be
--- /dev/null
+++ b/textproc/py-openpyxl1/distinfo
@@ -0,0 +1,2 @@
+SHA256 (openpyxl-1.8.6.tar.gz) = aa11a4acd2765392808bca2041f6f9ba17565c72dccc3f5d876bf78effa06126
+SIZE (openpyxl-1.8.6.tar.gz) = 76555
diff --git a/textproc/py-openpyxl1/pkg-descr b/textproc/py-openpyxl1/pkg-descr
new file mode 100644
index 000000000000..63726cdf922c
--- /dev/null
+++ b/textproc/py-openpyxl1/pkg-descr
@@ -0,0 +1,3 @@
+OpenPyxl is a Python library to read/write Excel 2007 xlsx/xlsm files.
+
+WWW: http://openpyxl.readthedocs.org/