aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/cvsd/Makefile9
-rw-r--r--devel/p5-AnyEvent-Connection/Makefile3
-rw-r--r--devel/p5-App-Control/Makefile9
-rw-r--r--devel/p5-Config-Grammar/Makefile9
-rw-r--r--devel/p5-Data-SExpression/Makefile8
-rw-r--r--devel/p5-Data-TreeDumper-Renderer-GTK/Makefile3
-rw-r--r--devel/p5-File-ChangeNotify/Makefile3
-rw-r--r--devel/p5-Filesys-Notify-KQueue/Makefile8
-rw-r--r--devel/p5-HOP-Lexer/Makefile9
-rw-r--r--devel/p5-List-Group/Makefile9
-rw-r--r--devel/p5-Log-Accounting-SVN/Makefile9
-rw-r--r--devel/p5-MooseX-StrictConstructor/Makefile9
-rw-r--r--devel/p5-MouseX-AttributeHelpers/Makefile8
-rw-r--r--devel/p5-Parallel-Scoreboard/Makefile8
-rw-r--r--devel/p5-ParseLex/Makefile9
-rw-r--r--devel/p5-RRDTool-OO/Makefile9
-rw-r--r--devel/p5-Test-Filename/Makefile3
-rw-r--r--devel/p5-ZConf-GUI/Makefile9
-rw-r--r--devel/p5-accessors/Makefile9
19 files changed, 48 insertions, 95 deletions
diff --git a/devel/cvsd/Makefile b/devel/cvsd/Makefile
index 924bcebc4036..d0738d3d63dc 100644
--- a/devel/cvsd/Makefile
+++ b/devel/cvsd/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: cvsd
-# Date Created: Dec 31, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= cvsd
PORTVERSION= 1.0.18
@@ -17,7 +12,7 @@ COMMENT= CVS pserver daemon
EXTRA_PATCHES= ${FILESDIR}/extra-cvsd-buildroot.in
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libwrap
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/devel/p5-AnyEvent-Connection/Makefile b/devel/p5-AnyEvent-Connection/Makefile
index 7a79fbb71fc8..9269eb77e07f 100644
--- a/devel/p5-AnyEvent-Connection/Makefile
+++ b/devel/p5-AnyEvent-Connection/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-AnyEvent>=5:${PORTSDIR}/devel/p5-AnyEvent \
p5-Object-Event>=1.21:${PORTSDIR}/devel/p5-Object-Event \
p5-common-sense>=2:${PORTSDIR}/devel/p5-common-sense
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::Connection.3
.include <bsd.port.mk>
diff --git a/devel/p5-App-Control/Makefile b/devel/p5-App-Control/Makefile
index be7a86edea00..831ba7aa9c8a 100644
--- a/devel/p5-App-Control/Makefile
+++ b/devel/p5-App-Control/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-App-Control
-# Date created: Dec 29 2006
-# Whom: Rong-En Fan <rafan@FreeBSD.org>
-#
+# Created by: Rong-En Fan <rafan@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= App-Control
PORTVERSION= 1.02
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rafan@FreeBSD.org
COMMENT= An apachectl style control of another script or executable
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= App::Control.3
diff --git a/devel/p5-Config-Grammar/Makefile b/devel/p5-Config-Grammar/Makefile
index 6558440e7a30..974db209feb6 100644
--- a/devel/p5-Config-Grammar/Makefile
+++ b/devel/p5-Config-Grammar/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Config-Grammar
-# Date created: 12 Nov 2011
-# Whom: Dikshie <dikshie@sfc.wide.ad.jp>
-#
+# Created by: Dikshie <dikshie@sfc.wide.ad.jp>
# $FreeBSD$
-#
PORTNAME= Config-Grammar
PORTVERSION= 1.10
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dikshie@sfc.wide.ad.jp
COMMENT= A grammar-based, user-friendly config parser
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Config::Grammar.3 Config::Grammar::Dynamic.3
diff --git a/devel/p5-Data-SExpression/Makefile b/devel/p5-Data-SExpression/Makefile
index cfc3ee344fa0..d3f145d1c4ec 100644
--- a/devel/p5-Data-SExpression/Makefile
+++ b/devel/p5-Data-SExpression/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Data::SExpression
-# Date created: 19 Mar 2012
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Data-SExpression
PORTVERSION= 0.41
@@ -19,7 +14,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::SExpression.3 \
Data::SExpression::Cons.3 \
diff --git a/devel/p5-Data-TreeDumper-Renderer-GTK/Makefile b/devel/p5-Data-TreeDumper-Renderer-GTK/Makefile
index 9ae22b413fae..7fc398726b61 100644
--- a/devel/p5-Data-TreeDumper-Renderer-GTK/Makefile
+++ b/devel/p5-Data-TreeDumper-Renderer-GTK/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Data-TreeDumper>=0:${PORTSDIR}/devel/p5-Data-TreeDumper \
p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::TreeDumper::Renderer::GTK.3
diff --git a/devel/p5-File-ChangeNotify/Makefile b/devel/p5-File-ChangeNotify/Makefile
index dd307d39094f..4bd4fddb55e7 100644
--- a/devel/p5-File-ChangeNotify/Makefile
+++ b/devel/p5-File-ChangeNotify/Makefile
@@ -28,6 +28,7 @@ MAN3= File::ChangeNotify.3 \
File::ChangeNotify::Watcher::Inotify.3 \
File::ChangeNotify::Watcher::KQueue.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/devel/p5-Filesys-Notify-KQueue/Makefile b/devel/p5-Filesys-Notify-KQueue/Makefile
index d630d39834b5..ad9c17fd6ca3 100644
--- a/devel/p5-Filesys-Notify-KQueue/Makefile
+++ b/devel/p5-Filesys-Notify-KQueue/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Filesys::Notify::KQueue
-# Date created: 05 Mar 2012
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Filesys-Notify-KQueue
PORTVERSION= 0.08
@@ -19,7 +14,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-SharedFork>=0.19:${PORTSDIR}/devel/p5-Test-SharedFork
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Filesys::Notify::KQueue.3 \
Filesys::Notify::README.3
diff --git a/devel/p5-HOP-Lexer/Makefile b/devel/p5-HOP-Lexer/Makefile
index e9cf08e525de..781d6a9089f5 100644
--- a/devel/p5-HOP-Lexer/Makefile
+++ b/devel/p5-HOP-Lexer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-HOP-Lexer
-# Date created: 2010-03-04
-# Whom: Steve Wills <steve@mouf.net>
-#
+# Created by: Steve Wills <steve@mouf.net>
# $FreeBSD$
-#
PORTNAME= HOP-Lexer
PORTVERSION= 0.032
@@ -19,7 +15,8 @@ COMMENT= Higher Order Perl Lexer
BUILD_DEPENDS= p5-HOP-Stream>=0.01:${PORTSDIR}/devel/p5-HOP-Stream
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= HOP::Lexer.3 \
HOP::Lexer::Article.3
diff --git a/devel/p5-List-Group/Makefile b/devel/p5-List-Group/Makefile
index bd622f7cabd7..cf55261357dc 100644
--- a/devel/p5-List-Group/Makefile
+++ b/devel/p5-List-Group/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: List-Group
-# Date created: Thu Oct 14 2004
-# Whom: Tillman Hodgson <tillman@seekingfire.com>
-#
+# Created by: Tillman Hodgson <tillman@seekingfire.com>
# $FreeBSD$
-#
PORTNAME= List-Group
PORTVERSION= 1.3
@@ -16,7 +12,8 @@ COMMENT= Perl module that allows you to group a list by columns or rows
TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= List::Group.3
diff --git a/devel/p5-Log-Accounting-SVN/Makefile b/devel/p5-Log-Accounting-SVN/Makefile
index cd8c57b71c39..65c0fd5f1d0b 100644
--- a/devel/p5-Log-Accounting-SVN/Makefile
+++ b/devel/p5-Log-Accounting-SVN/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Log-Accounting-SVN
-# Date created: 2006-06-26
-# Whom: Yuan-Chung Hsiao & <ychsiao@ychsiao.org>
-#
+# Created by: Yuan-Chung Hsiao & <ychsiao@ychsiao.org>
# $FreeBSD$
-#
PORTNAME= Log-Accounting-SVN
PORTVERSION= 0.01
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Log::Accounting::SVN.3
diff --git a/devel/p5-MooseX-StrictConstructor/Makefile b/devel/p5-MooseX-StrictConstructor/Makefile
index a673f43422bf..9e102a38dac2 100644
--- a/devel/p5-MooseX-StrictConstructor/Makefile
+++ b/devel/p5-MooseX-StrictConstructor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-MooseX-StrictConstructor
-# Date created: 2008-10-23
-# Whom: glarkin
-#
+# Created by: glarkin
# $FreeBSD$
-#
PORTNAME= MooseX-StrictConstructor
PORTVERSION= 0.19
@@ -21,7 +17,8 @@ RUN_DEPENDS= p5-Moose>=0.94:${PORTSDIR}/devel/p5-Moose \
TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MooseX::StrictConstructor.3 \
MooseX::StrictConstructor::Trait::Class.3 \
diff --git a/devel/p5-MouseX-AttributeHelpers/Makefile b/devel/p5-MouseX-AttributeHelpers/Makefile
index 7c0d345e2b1d..f023e0253efb 100644
--- a/devel/p5-MouseX-AttributeHelpers/Makefile
+++ b/devel/p5-MouseX-AttributeHelpers/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: MouseX::AttributeHelpers
-# Date created: 14 Mar 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= MouseX-AttributeHelpers
PORTVERSION= 0.07
@@ -23,7 +18,8 @@ TEST_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
p5-Test-UseAllModules>=0:${PORTSDIR}/devel/p5-Test-UseAllModules \
p5-Test-Data>=0:${PORTSDIR}/devel/p5-Test-Data
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MouseX::AttributeHelpers.3 \
MouseX::AttributeHelpers::Base.3 \
diff --git a/devel/p5-Parallel-Scoreboard/Makefile b/devel/p5-Parallel-Scoreboard/Makefile
index c2af8f835c96..1950b1417224 100644
--- a/devel/p5-Parallel-Scoreboard/Makefile
+++ b/devel/p5-Parallel-Scoreboard/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Parallel::Scoreboard
-# Date created: 31 Dec 2011
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Parallel-Scoreboard
PORTVERSION= 0.03
@@ -20,7 +15,8 @@ RUN_DEPENDS= \
p5-JSON>0:${PORTSDIR}/converters/p5-JSON
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Parallel::Scoreboard.3 \
Parallel::Scoreboard::PSGI::App.3 \
diff --git a/devel/p5-ParseLex/Makefile b/devel/p5-ParseLex/Makefile
index 8c255d314cba..1002afee0ae2 100644
--- a/devel/p5-ParseLex/Makefile
+++ b/devel/p5-ParseLex/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-ParseLex
-# Date created: 16 February 2004
-# Whom: Jim Pirzyk <pirzyk@uiuc.edu>
-#
+# Created by: Jim Pirzyk <pirzyk@uiuc.edu>
# $FreeBSD$
-#
PORTNAME= ParseLex
PORTVERSION= 2.21
@@ -17,7 +13,8 @@ COMMENT= Object-oriented generator of lexical analyzers
BUILD_DEPENDS= p5-ParseTemplate>=3.01:${PORTSDIR}/devel/p5-ParseTemplate
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Parse::ALex.3 Parse::Lex.3 Parse::Token.3 Parse::YYLex.3 \
Parse::LexEvent.3 Parse::CLex.3 Parse::Trace.3
diff --git a/devel/p5-RRDTool-OO/Makefile b/devel/p5-RRDTool-OO/Makefile
index cd9cb3d2db3a..ec3c68cd9d09 100644
--- a/devel/p5-RRDTool-OO/Makefile
+++ b/devel/p5-RRDTool-OO/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: RRDTool-OO
-# Date created: 13 Feb 2006
-# Whom: Stefan Pauly <stefan@fh-mainz.de>
-#
+# Created by: Stefan Pauly <stefan@fh-mainz.de>
# $FreeBSD$
-#
PORTNAME= RRDTool-OO
PORTVERSION= 0.32
@@ -19,7 +15,8 @@ BUILD_DEPENDS= rrdtool>=0:${PORTSDIR}/databases/rrdtool \
p5-Log-Log4perl>=0.40:${PORTSDIR}/devel/p5-Log-Log4perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= RRDTool::OO.3
diff --git a/devel/p5-Test-Filename/Makefile b/devel/p5-Test-Filename/Makefile
index 63d2b6bed9a8..1daec3ac0114 100644
--- a/devel/p5-Test-Filename/Makefile
+++ b/devel/p5-Test-Filename/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
TEST_DEPENDS= \
p5-Test-Tester>0:${PORTSDIR}/devel/p5-Test-Tester
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Filename.3
diff --git a/devel/p5-ZConf-GUI/Makefile b/devel/p5-ZConf-GUI/Makefile
index 34d7b2e84df5..b5ba62c8e989 100644
--- a/devel/p5-ZConf-GUI/Makefile
+++ b/devel/p5-ZConf-GUI/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-ZConf-GUI
-# Date created: 2009-05-25
-# Whom: Zane C, Bowers <vvelox@vvelox.net>
-#
+# Created by: Zane C, Bowers <vvelox@vvelox.net>
# $FreeBSD$
-#
PORTNAME= ZConf-GUI
PORTVERSION= 1.1.0
@@ -24,7 +20,8 @@ BUILD_DEPENDS= p5-ZConf>=6.1.0:${PORTSDIR}/net/p5-ZConf \
${LOCALBASE}/bin/xhost:${PORTSDIR}/x11/xhost
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ZConf::GUI.3
diff --git a/devel/p5-accessors/Makefile b/devel/p5-accessors/Makefile
index 8033af4b697a..3fda53039358 100644
--- a/devel/p5-accessors/Makefile
+++ b/devel/p5-accessors/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-accessors
-# Date created: 17 September 2005
-# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
-#
+# Created by: Yen-Ming Lee <leeym@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= accessors
PORTVERSION= 1.01
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= leeym@FreeBSD.org
COMMENT= Create accessor methods in caller's package #'
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= accessors.3 accessors::chained.3 accessors::classic.3 \
accessors::ro.3 accessors::rw.3