aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/arm/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/security/arm/Makefile b/security/arm/Makefile
index 0507780b70f5..4cd59625d405 100644
--- a/security/arm/Makefile
+++ b/security/arm/Makefile
@@ -28,21 +28,28 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
PORTDOCS= armrc.sample
-OPTIONS= TOR "Install tor locally" On
+OPTIONS_DEFINE= TOR \
+ DOCS
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT=TOR DOCS
+
+TOR_DESC= Enable local tor support
+
+.include <bsd.port.options.mk>
-.if defined(WITH_TOR)
+.if ${PORT_OPTIONS:MTOR}
RUN_DEPENDS+= lsof:${PORTSDIR}/sysutils/lsof \
tor:${PORTSDIR}/security/tor
.endif
+.include <bsd.port.pre.mk>
+
post-patch:
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 's,/usr/share/doc/,${WRKSRC}/src,g' \
+.if ${PORT_OPTIONS:MDOCS}
+ @${REINPLACE_CMD} -e 's,/usr/share/doc,${PREFIX}/share/doc,g' \
${WRKSRC}/setup.py
.else
- @${REINPLACE_CMD} -e 's,/usr/share/doc,${PREFIX}/share/doc,g' \
+ @${REINPLACE_CMD} -e 's,/usr/share/doc/,${WRKSRC}/src,g' \
${WRKSRC}/setup.py
.endif