aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/ocaml-camomile/Makefile2
-rw-r--r--devel/ocaml-pcre/Makefile2
-rw-r--r--devel/ocaml-sdl/Makefile2
-rw-r--r--devel/ocaml-ulex/Makefile2
-rw-r--r--ftp/ocaml-ocurl/Makefile2
-rw-r--r--graphics/ocaml-images/Makefile2
-rw-r--r--textproc/ocaml-expat/Makefile2
7 files changed, 14 insertions, 0 deletions
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
index 7d93811352d2..0f87e5248f84 100644
--- a/devel/ocaml-camomile/Makefile
+++ b/devel/ocaml-camomile/Makefile
@@ -19,6 +19,8 @@ COMMENT= A comprehensive Unicode library for objective caml language
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+BROKEN= Changes permissions of installed file
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/devel/ocaml-pcre/Makefile b/devel/ocaml-pcre/Makefile
index 0fc9269a6930..a4106383d47f 100644
--- a/devel/ocaml-pcre/Makefile
+++ b/devel/ocaml-pcre/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre-utf8
+BROKEN= Changes permissions of installed file
+
USE_GMAKE= yes
MAKE_ENV= OCAML_LIB_INSTALL="${PREFIX}/lib/ocaml/site-lib/pcre" \
INCDIRS="${LOCALBASE}/include" LIBDIRS="${LOCALBASE}/lib"
diff --git a/devel/ocaml-sdl/Makefile b/devel/ocaml-sdl/Makefile
index de983b2403cd..ff5d28fdd2de 100644
--- a/devel/ocaml-sdl/Makefile
+++ b/devel/ocaml-sdl/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
lablgl:${PORTSDIR}/graphics/ocaml-lablgl
+BROKEN= Changes permissions of installed file
+
USE_SDL= sdl ttf image mixer
USE_AUTOCONF_VER=259
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/devel/ocaml-ulex/Makefile b/devel/ocaml-ulex/Makefile
index 079c9a41a4d7..732bbee92f83 100644
--- a/devel/ocaml-ulex/Makefile
+++ b/devel/ocaml-ulex/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+BROKEN= Changes permissions of installed file
+
USE_GMAKE= yes
ALL_TARGET= all all.opt
diff --git a/ftp/ocaml-ocurl/Makefile b/ftp/ocaml-ocurl/Makefile
index 75e14a639d7d..d737f94ebc3e 100644
--- a/ftp/ocaml-ocurl/Makefile
+++ b/ftp/ocaml-ocurl/Makefile
@@ -20,6 +20,8 @@ RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+BROKEN= Changes permissions of installed file
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+="--with-findlib"
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index 3760f66e75a3..851df5c9ddc0 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -29,6 +29,8 @@ LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
+BROKEN= Changes permissions of installed file
+
USE_XPM= yes
USE_FREETYPE= yes
GNU_CONFIGURE= yes
diff --git a/textproc/ocaml-expat/Makefile b/textproc/ocaml-expat/Makefile
index 547fed4b482b..93b1137d536d 100644
--- a/textproc/ocaml-expat/Makefile
+++ b/textproc/ocaml-expat/Makefile
@@ -20,6 +20,8 @@ RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
+BROKEN= Changes permissions of installed file
+
USE_GMAKE= yes
MAKE_ARGS= EXPAT_LIBDIR=${LOCALBASE}/lib \
EXPAT_INCDIR=${LOCALBASE}/include \