aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-term-ansicolor/Makefile35
-rw-r--r--devel/ruby-term-ansicolor/distinfo3
-rw-r--r--devel/ruby-term-ansicolor/pkg-descr11
-rw-r--r--devel/ruby-term-ansicolor/pkg-plist7
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a76cbc39d5bb..cdaa22fd3f84 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1899,6 +1899,7 @@
SUBDIR += ruby-slang
SUBDIR += ruby-strongtyping
SUBDIR += ruby-sysvipc
+ SUBDIR += ruby-term-ansicolor
SUBDIR += ruby-textbuf
SUBDIR += ruby-tzfile
SUBDIR += ruby-wirble
diff --git a/devel/ruby-term-ansicolor/Makefile b/devel/ruby-term-ansicolor/Makefile
new file mode 100644
index 000000000000..b87028371fa2
--- /dev/null
+++ b/devel/ruby-term-ansicolor/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ruby-term-ansicolor
+# Date created: 2007-01-12
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= term-ansicolor
+PORTVERSION= 1.0.2
+CATEGORIES= devel ruby
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Term::ANSIColor for Ruby
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+DOCS= README.en
+EXAMPLES= examples/*
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/,} ${RUBY_MODEXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-term-ansicolor/distinfo b/devel/ruby-term-ansicolor/distinfo
new file mode 100644
index 000000000000..e978ad4c089b
--- /dev/null
+++ b/devel/ruby-term-ansicolor/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/term-ansicolor-1.0.2.tgz) = 9595cb55890b8773ea28575f88bbe25b
+SHA256 (ruby/term-ansicolor-1.0.2.tgz) = f154e9f59b4923e7feda3332770f7e034e3939158642d21d720379ba66318d56
+SIZE (ruby/term-ansicolor-1.0.2.tgz) = 11210
diff --git a/devel/ruby-term-ansicolor/pkg-descr b/devel/ruby-term-ansicolor/pkg-descr
new file mode 100644
index 000000000000..4009426f937a
--- /dev/null
+++ b/devel/ruby-term-ansicolor/pkg-descr
@@ -0,0 +1,11 @@
+Small Ruby library that colors strings using ANSI escape sequences.
+It's possible to use constants:
+
+ include Term::ANSIColor
+ print red, bold, "red bold", reset, "\n"
+
+ or
+
+ print red(bold("red bold")), "\n"
+
+WWW: http://term-ansicolor.rubyforge.org/
diff --git a/devel/ruby-term-ansicolor/pkg-plist b/devel/ruby-term-ansicolor/pkg-plist
new file mode 100644
index 000000000000..6a7d3374c1ec
--- /dev/null
+++ b/devel/ruby-term-ansicolor/pkg-plist
@@ -0,0 +1,7 @@
+%%RUBY_SITELIBDIR%%/term/ansicolor.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/cdiff.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/example.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.en
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+@dirrmtry %%RUBY_SITELIBDIR%%/term