aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/dovecot2-antispam-plugin/Makefile2
-rw-r--r--mail/dovecot2-pigeonhole/Makefile2
-rw-r--r--mail/dovecot2/Makefile5
-rw-r--r--mail/dovecot2/distinfo5
-rw-r--r--mail/dovecot2/files/patch-kqueue64
-rw-r--r--mail/dovecot2/pkg-plist20
6 files changed, 91 insertions, 7 deletions
diff --git a/mail/dovecot2-antispam-plugin/Makefile b/mail/dovecot2-antispam-plugin/Makefile
index 0680cf18645e..47a14ff05f38 100644
--- a/mail/dovecot2-antispam-plugin/Makefile
+++ b/mail/dovecot2-antispam-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dovecot2-antispam-plugin
PORTVERSION= 20130429
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= mail
MASTER_SITES= http://olgeni.olgeni.com/~olgeni/distfiles/ \
LOCAL/olgeni
diff --git a/mail/dovecot2-pigeonhole/Makefile b/mail/dovecot2-pigeonhole/Makefile
index 0c79098472e7..ec509432b1e4 100644
--- a/mail/dovecot2-pigeonhole/Makefile
+++ b/mail/dovecot2-pigeonhole/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dovecot-pigeonhole
PORTVERSION= 0.4.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://pigeonhole.dovecot.org/releases/${DOVECOTVERSION}/
DISTNAME= ${PORTNAME:C/-/-${DOVECOTVERSION}-/}-${PORTVERSION}
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index fc527134dcc9..63611734e83e 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -13,7 +13,7 @@
######################################################################
PORTNAME= dovecot
-PORTVERSION= 2.2.24
+PORTVERSION= 2.2.25
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/${PORTVERSION:R}/
PKGNAMESUFFIX= 2
@@ -26,9 +26,8 @@ LICENSE_COMB= dual
CONFLICTS= dovecot-1.[0-9]*
-USES= cpe iconv libtool
+USES= cpe iconv libtool ssl
USE_RC_SUBR= dovecot
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \
diff --git a/mail/dovecot2/distinfo b/mail/dovecot2/distinfo
index 09427e6e0417..6ce560748957 100644
--- a/mail/dovecot2/distinfo
+++ b/mail/dovecot2/distinfo
@@ -1,2 +1,3 @@
-SHA256 (dovecot-2.2.24.tar.gz) = 71c86891ea8deb5703d3dbbc3ea31ce2cbf7638f1aa395d9e8794d3ff7aebeb7
-SIZE (dovecot-2.2.24.tar.gz) = 5345872
+TIMESTAMP = 1467385503
+SHA256 (dovecot-2.2.25.tar.gz) = d8d9f32c846397f7c22749a84c5cf6f59c55ff7ded3dc9f07749a255182f9667
+SIZE (dovecot-2.2.25.tar.gz) = 5576235
diff --git a/mail/dovecot2/files/patch-kqueue b/mail/dovecot2/files/patch-kqueue
new file mode 100644
index 000000000000..2953f5ec19ce
--- /dev/null
+++ b/mail/dovecot2/files/patch-kqueue
@@ -0,0 +1,64 @@
+From ffd8dc932516bc55bf01d91355540daab365e5e9 Mon Sep 17 00:00:00 2001
+From: Timo Sirainen <timo.sirainen@dovecot.fi>
+Date: Mon, 4 Jul 2016 15:05:00 +0300
+Subject: [PATCH] master: Add master socket's io listener later.
+
+Most importantly this fixes startup failure with kqueue:
+
+Panic: kevent(EV_ADD, READ, 56) failed: Bad file descriptor
+
+kqueue doesn't survive a fork(), so this change delays its creation until
+after fork().
+---
+ src/master/service-listen.c | 5 -----
+ src/master/service-monitor.c | 7 +++++++
+ 2 files changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/src/master/service-listen.c b/src/master/service-listen.c
+index 1d3e399..96b52e8 100644
+--- src/master/service-listen.c
++++ src/master/service-listen.c
+@@ -6,7 +6,6 @@
+ #include "fd-close-on-exec.h"
+ #include "ioloop.h"
+ #include "net.h"
+-#include "master-client.h"
+ #ifdef HAVE_SYSTEMD
+ #include "sd-daemon.h"
+ #endif
+@@ -357,10 +356,6 @@ static int services_listen_master(struct service_list *service_list)
+
+ if (service_list->master_fd == -1)
+ return 0;
+-
+- service_list->io_master =
+- io_add(service_list->master_fd, IO_READ,
+- master_client_connected, service_list);
+ return 1;
+ }
+
+diff --git a/src/master/service-monitor.c b/src/master/service-monitor.c
+index 44cdb26..408edf4 100644
+--- src/master/service-monitor.c
++++ src/master/service-monitor.c
+@@ -7,6 +7,7 @@
+ #include "hash.h"
+ #include "str.h"
+ #include "safe-mkstemp.h"
++#include "master-client.h"
+ #include "service.h"
+ #include "service-process.h"
+ #include "service-process-notify.h"
+@@ -452,6 +453,12 @@ void services_monitor_start(struct service_list *service_list)
+ return;
+ service_anvil_monitor_start(service_list);
+
++ if (service_list->io_master == NULL) {
++ service_list->io_master =
++ io_add(service_list->master_fd, IO_READ,
++ master_client_connected, service_list);
++ }
++
+ array_foreach(&service_list->services, services) {
+ struct service *service = *services;
+
diff --git a/mail/dovecot2/pkg-plist b/mail/dovecot2/pkg-plist
index 7fa88abf6acb..8ffc9625af9b 100644
--- a/mail/dovecot2/pkg-plist
+++ b/mail/dovecot2/pkg-plist
@@ -56,6 +56,7 @@ include/dovecot/auth-fields.h
include/dovecot/auth-master-connection.h
include/dovecot/auth-master.h
include/dovecot/auth-penalty.h
+include/dovecot/auth-policy.h
include/dovecot/auth-postfix-connection.h
include/dovecot/auth-request-handler.h
include/dovecot/auth-request-stats.h
@@ -89,6 +90,9 @@ include/dovecot/crc32.h
include/dovecot/cydir-storage.h
include/dovecot/cydir-sync.h
include/dovecot/data-stack.h
+include/dovecot/dcrypt-iostream-private.h
+include/dovecot/dcrypt-private.h
+include/dovecot/dcrypt.h
include/dovecot/db-checkpassword.h
include/dovecot/db-dict.h
include/dovecot/db-ldap.h
@@ -243,6 +247,7 @@ include/dovecot/imem.h
include/dovecot/index-attachment.h
include/dovecot/index-mail.h
include/dovecot/index-mailbox-size.h
+include/dovecot/index-pop3-uidl.h
include/dovecot/index-rebuild.h
include/dovecot/index-search-private.h
include/dovecot/index-search-result.h
@@ -277,6 +282,7 @@ include/dovecot/istream-callback.h
include/dovecot/istream-chain.h
include/dovecot/istream-concat.h
include/dovecot/istream-crlf.h
+include/dovecot/istream-decrypt.h
include/dovecot/istream-dot.h
include/dovecot/istream-failure-at.h
include/dovecot/istream-file-private.h
@@ -435,6 +441,7 @@ include/dovecot/notify-plugin.h
include/dovecot/numpack.h
include/dovecot/ostream-cmp.h
include/dovecot/ostream-dot.h
+include/dovecot/ostream-encrypt.h
include/dovecot/ostream-escaped.h
include/dovecot/ostream-failure-at.h
include/dovecot/ostream-hash.h
@@ -449,6 +456,7 @@ include/dovecot/passdb-cache.h
include/dovecot/passdb-template.h
include/dovecot/passdb.h
include/dovecot/password-scheme.h
+include/dovecot/pkcs5.h
include/dovecot/pop3-capability.h
include/dovecot/pop3-client.h
include/dovecot/pop3-commands.h
@@ -610,6 +618,9 @@ lib/dovecot/lib90_stats_plugin.a
lib/dovecot/lib90_stats_plugin.so
lib/dovecot/lib95_imap_stats_plugin.a
lib/dovecot/lib95_imap_stats_plugin.so
+lib/dovecot/lib99_welcome_plugin.a
+lib/dovecot/lib99_welcome_plugin.so
+lib/dovecot/libdcrypt_openssl.so
lib/dovecot/libdovecot-compression.a
lib/dovecot/libdovecot-compression.so
lib/dovecot/libdovecot-compression.so.0
@@ -699,6 +710,7 @@ man/man1/doveadm-expunge.1.gz
man/man1/doveadm-fetch.1.gz
man/man1/doveadm-flags.1.gz
man/man1/doveadm-force-resync.1.gz
+man/man1/doveadm-fs.1.gz
man/man1/doveadm-fts.1.gz
man/man1/doveadm-help.1.gz
man/man1/doveadm-import.1.gz
@@ -730,10 +742,18 @@ man/man1/dsync.1.gz
man/man7/doveadm-search-query.7.gz
sbin/dovecot
share/aclocal/dovecot.m4
+%%DATADIR%%/stopwords/stopwords_da.txt
+%%DATADIR%%/stopwords/stopwords_de.txt
%%DATADIR%%/stopwords/stopwords_en.txt
+%%DATADIR%%/stopwords/stopwords_es.txt
%%DATADIR%%/stopwords/stopwords_fi.txt
%%DATADIR%%/stopwords/stopwords_fr.txt
+%%DATADIR%%/stopwords/stopwords_it.txt
+%%DATADIR%%/stopwords/stopwords_nl.txt
%%DATADIR%%/stopwords/stopwords_no.txt
+%%DATADIR%%/stopwords/stopwords_pt.txt
+%%DATADIR%%/stopwords/stopwords_ro.txt
+%%DATADIR%%/stopwords/stopwords_ru.txt
%%DATADIR%%/stopwords/stopwords_sv.txt
%%LIBWRAP%%libexec/dovecot/tcpwrap
%%LDAP%%include/dovecot/ldap-client.h