aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/flowgrep/Makefile31
-rw-r--r--net/flowgrep/distinfo2
-rw-r--r--net/flowgrep/pkg-descr11
4 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8ef02d611790..327b504a3090 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -135,6 +135,7 @@
SUBDIR += fidelio
SUBDIR += findmtu
SUBDIR += firetalk
+ SUBDIR += flowgrep
SUBDIR += forg
SUBDIR += fpc-inet
SUBDIR += fping
diff --git a/net/flowgrep/Makefile b/net/flowgrep/Makefile
new file mode 100644
index 000000000000..305fd4c81c25
--- /dev/null
+++ b/net/flowgrep/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: flowgrep
+# Date created: 22 Jun 2005
+# Whom: Corey Smith
+#
+# $FreeBSD$
+#
+
+PORTNAME= flowgrep
+PORTVERSION= 0.8a
+CATEGORIES= net security
+MASTER_SITES= http://www.monkey.org/~jose/software/flowgrep/
+DISTNAME= flowgrep-${PORTVERSION}
+
+MAINTAINER= corsmith@gmail.com
+COMMENT= TCP stream/UDP/IP payload 'grep' utility
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/nidsmodule.so:${PORTSDIR}/net/pynids
+
+USE_PYTHON= YES
+
+NO_BUILD= YES
+
+PLIST_FILES= sbin/flowgrep
+
+MAN8= flowgrep.8
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/flowgrep.py ${PREFIX}/sbin/flowgrep
+ ${INSTALL_MAN} ${WRKSRC}/flowgrep.8 ${PREFIX}/man/man8/flowgrep.8
+
+.include <bsd.port.mk>
diff --git a/net/flowgrep/distinfo b/net/flowgrep/distinfo
new file mode 100644
index 000000000000..b91193458b9a
--- /dev/null
+++ b/net/flowgrep/distinfo
@@ -0,0 +1,2 @@
+MD5 (flowgrep-0.8a.tar.gz) = d4ee7ddc9a32f0e904fe14d3db24954c
+SIZE (flowgrep-0.8a.tar.gz) = 7410
diff --git a/net/flowgrep/pkg-descr b/net/flowgrep/pkg-descr
new file mode 100644
index 000000000000..bb935d93b65a
--- /dev/null
+++ b/net/flowgrep/pkg-descr
@@ -0,0 +1,11 @@
+flowgrep is a basic IDS/IPS tool written in python as a way to help you
+investigate and manage your network. it works by sniffing traffic, reassembling
+TCP streams, and IP and UDP fragments into single packets, and allowing you to
+"grep" through their payloads using regular expressions. the quality of the
+regular expression engine is similar to Perl's. think of it as a marriage of
+tcpflow, tcpkill, and ngrep.
+
+WWW: http://www.monkey.org/~jose/software/flowgrep/
+
+- Corey Smith
+corsmith@gmail.com