aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/highlnk/Makefile38
-rw-r--r--sysutils/highlnk/distinfo2
-rw-r--r--sysutils/highlnk/pkg-descr11
4 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 34fd05ac8331..753fd670a574 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -212,6 +212,7 @@
SUBDIR += healthd
SUBDIR += heartbeat
SUBDIR += heirloom
+ SUBDIR += highlnk
SUBDIR += hourglass
SUBDIR += httplog
SUBDIR += i855vidctl10
diff --git a/sysutils/highlnk/Makefile b/sysutils/highlnk/Makefile
new file mode 100644
index 000000000000..f94572a47f23
--- /dev/null
+++ b/sysutils/highlnk/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: highlnk
+# Date created: 20 Jun 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= highlnk
+DISTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://www.perli.net/projekte/highlnk/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A tool to save disk space on hard disks by using hardlinks
+
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/highlnk
+PORTDOCS= README
+MAN1= highlnk.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|linux/limits.h|sys/syslimits.h|' \
+ ${WRKSRC}/finder.c \
+ ${WRKSRC}/highlnk.c
+ @${REINPLACE_CMD} -e 's|^FLAGS.*|FLAGS = ${CFLAGS}|; s|^\(CC\).*|\1?=gcc|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/highlnk/distinfo b/sysutils/highlnk/distinfo
new file mode 100644
index 000000000000..c2d019641870
--- /dev/null
+++ b/sysutils/highlnk/distinfo
@@ -0,0 +1,2 @@
+MD5 (highlnk-0.2.tar.gz) = 8a3364e84eac8c3f908a82951d9437b7
+SIZE (highlnk-0.2.tar.gz) = 14533
diff --git a/sysutils/highlnk/pkg-descr b/sysutils/highlnk/pkg-descr
new file mode 100644
index 000000000000..30a7e6113809
--- /dev/null
+++ b/sysutils/highlnk/pkg-descr
@@ -0,0 +1,11 @@
+HighLnk is a high-performance hardlinking tool, which takes the contents of the
+current directory, and hard-links files with different content to the target
+directory. Files with same content will also be hard-linked but in a way that
+storage space is saved. This is useful if you have many files on a read-only
+partition, or if you plan to put many files on a CD/DVD, but the whole tree is
+just too big to fit on the media.
+
+WWW: http://www.thpinfo.com/highlnk/
+
+- ehaupt
+ehaupt@critical.ch