aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libreatlas/Makefile56
-rw-r--r--graphics/libreatlas/distinfo2
-rw-r--r--graphics/libreatlas/pkg-descr5
4 files changed, 64 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index deed7f5d3327..b220b01ecefa 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -500,6 +500,7 @@
SUBDIR += libqrencode
SUBDIR += librasterlite
SUBDIR += libraw
+ SUBDIR += libreatlas
SUBDIR += librsvg2
SUBDIR += libspiro
SUBDIR += libsvg
diff --git a/graphics/libreatlas/Makefile b/graphics/libreatlas/Makefile
new file mode 100644
index 000000000000..b0be60877c80
--- /dev/null
+++ b/graphics/libreatlas/Makefile
@@ -0,0 +1,56 @@
+# Created by: lbartoletti <coder@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= libreatlas
+PORTVERSION= 1.0.0a
+CATEGORIES= graphics geography
+MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Open Source Geography Education application
+
+LIB_DEPENDS= mspack:${PORTSDIR}/archivers/libmspack \
+ spatialite:${PORTSDIR}/databases/spatialite \
+ sqlite3:${PORTSDIR}/databases/sqlite3 \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ cairo:${PORTSDIR}/graphics/cairo \
+ geos:${PORTSDIR}/graphics/geos \
+ jbig:${PORTSDIR}/graphics/jbigkit \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ geotiff:${PORTSDIR}/graphics/libgeotiff \
+ rasterlite:${PORTSDIR}/graphics/librasterlite \
+ png15:${PORTSDIR}/graphics/png \
+ proj:${PORTSDIR}/graphics/proj \
+ tiff:${PORTSDIR}/graphics/tiff \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ freexl:${PORTSDIR}/textproc/freexl \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_PKGCONFIG= build
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
+ xfixes xi xinerama xrandr xrender xxf86vm
+USE_GNOME= atk gdkpixbuf2 glib20 gtk20 pango
+USE_WX= 2.8
+WANT_UNICODE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/LibreAtlas
+
+DESKTOP_ENTRIES="LibreAtlas" "${COMMENT}" "" "LibreAtlas" \
+ "Graphics;Viewer;" true
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|wx-config|$${WX_CONFIG}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|$$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/libreatlas/distinfo b/graphics/libreatlas/distinfo
new file mode 100644
index 000000000000..3e05498658bf
--- /dev/null
+++ b/graphics/libreatlas/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libreatlas-1.0.0a.tar.gz) = f8de0433455d2f033de7cec253f28aa7d2cf26e075234467a607feb1e68a417c
+SIZE (libreatlas-1.0.0a.tar.gz) = 814624
diff --git a/graphics/libreatlas/pkg-descr b/graphics/libreatlas/pkg-descr
new file mode 100644
index 000000000000..39477ac0adcd
--- /dev/null
+++ b/graphics/libreatlas/pkg-descr
@@ -0,0 +1,5 @@
+LibreAtlas is an open source Geography Education application built on top of
+SpatiaLite and RasterLite. It uses LibreAtlas databases which are a digital
+alternative to a paper atlas.
+
+WWW: https://www.gaia-gis.it/fossil/libreatlas/index