aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libprojectm/Makefile44
-rw-r--r--graphics/libprojectm/distinfo5
-rw-r--r--graphics/libprojectm/files/patch-Renderer_TextureManager.cpp10
-rw-r--r--graphics/libprojectm/files/patch-c++1187
-rw-r--r--graphics/libprojectm/files/patch-cmake_FindFreetype2.cmake11
-rw-r--r--graphics/libprojectm/files/patch-src_libprojectM_CMakeLists.txt20
-rw-r--r--graphics/libprojectm/files/patch-src_libprojectM_NativePresetFactory_CMakeLists.txt17
-rw-r--r--graphics/libprojectm/pkg-plist13
-rw-r--r--graphics/projectm-libvisual/Makefile34
-rw-r--r--graphics/projectm-libvisual/distinfo2
-rw-r--r--graphics/projectm-libvisual/files/patch-actor_projectM-cpp18
-rw-r--r--graphics/projectm-libvisual/pkg-descr4
14 files changed, 78 insertions, 189 deletions
diff --git a/MOVED b/MOVED
index fe88fa9640f2..50bcea97d6ba 100644
--- a/MOVED
+++ b/MOVED
@@ -10351,3 +10351,4 @@ astro/p5-ZConf-Weather||2018-07-16|Has expired: Unmaintained
sysutils/p5-ZConf-Cron||2018-07-16|Has expired: Unmaintained
misc/artikulate-kde4||2018-07-17|Has expired: broken for more than three years
vietnamese/kde4-l10||2018-07-17|Has expired: broken for more than three years
+graphics/projectm-libvisual|graphics/libprojectm|2018-07-17|Code of projectm-libvisual was merged into graphics/libprojectm
diff --git a/graphics/Makefile b/graphics/Makefile
index 8a6ec52c2125..bce2fca9d991 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -871,7 +871,6 @@
SUBDIR += prison
SUBDIR += processing
SUBDIR += proj
- SUBDIR += projectm-libvisual
SUBDIR += pstoedit
SUBDIR += pstoepsi
SUBDIR += ptex
diff --git a/graphics/libprojectm/Makefile b/graphics/libprojectm/Makefile
index c67b328c0473..6e85cd443379 100644
--- a/graphics/libprojectm/Makefile
+++ b/graphics/libprojectm/Makefile
@@ -1,36 +1,42 @@
# $FreeBSD$
PORTNAME= libprojectM
-PORTVERSION= 2.0.1
-PORTREVISION= 5
+DISTVERSION= 2.1.0
CATEGORIES= graphics audio
MASTER_SITES= SF/${PORTNAME:tl:S/lib//}/${PORTVERSION}/
-DISTNAME= ${PORTNAME:S/lib//}-${DISTVERSION}-Source
+DISTNAME= ${PORTNAME:S/lib//}-complete-${DISTVERSION}-Source
MAINTAINER= yuri@FreeBSD.org
COMMENT= Awesome music visualiser
LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
LIB_DEPENDS= libftgl.so:graphics/ftgl \
- libfreetype.so:print/freetype2
+ libfreetype.so:print/freetype2 \
+ libvisual-0.4.so:graphics/libvisual04
-USES= cmake localbase:ldflags
-CMAKE_ARGS= -DUSE_OPENMP=OFF # openmp breaks build on 11.x
-USE_GL= glew
+USES= cmake:outsource localbase:ldflags pkgconfig qt:4
+USE_QT= corelib gui opengl xml moc_build qmake_build rcc_build uic_build
+USE_SDL= sdl
+USE_GL= gl glu glew
USE_LDCONFIG= yes
-post-patch:
-# Install config.inp.sample instead of overwriting user's file.
-# Needs to be specific enough not to rename config.inp.in too!
-# Also correct pkgconfig destination dir -- fiddly
- @${REINPLACE_CMD} -e 's/config.inp\([\" ]\)/config.inp.sample\1/' \
- -e 's#\(/lib\)[^}]*}\(/pkgconfig\)#\1data\2#' \
- ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e 's#/usr/X11R6#${LOCALBASE}#' \
- ${WRKSRC}/cmake/FindFreetype2.cmake
-# Fix empty libdir in pkgconfig file to stop vlc complaining
- @${REINPLACE_CMD} -e 's#^\(libdir=\).*#\1${PREFIX}/lib#' \
- ${WRKSRC}/${PORTNAME}.pc.in
+CMAKE_ARGS= -DUSE_OPENMP=OFF # openmp breaks build on 11.x
+CMAKE_OFF= INCLUDE-PROJECTM-TEST
+
+OPTIONS_DEFINE= PULSEAUDIO JACK
+OPTIONS_DEFAULT= PULSEAUDIO
+OPTIONS_SUB= yes
+
+PULSEAUDIO_CMAKE_BOOL= INCLUDE-PROJECTM-PULSEAUDIO
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+
+JACK_CMAKE_BOOL= INCLUDE-PROJECTM-JACK
+JACK_LIB_DEPENDS= libjack.so:audio/jack
+
+post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/share/projectM/config.inp ${STAGEDIR}${PREFIX}/share/projectM/config.inp.sample
+ ${INSTALL_DATA} ${WRKSRC}/fonts/Vera.ttf ${STAGEDIR}${PREFIX}/share/projectM/fonts/
.include <bsd.port.mk>
diff --git a/graphics/libprojectm/distinfo b/graphics/libprojectm/distinfo
index c214136c57dd..e03e3074e6ea 100644
--- a/graphics/libprojectm/distinfo
+++ b/graphics/libprojectm/distinfo
@@ -1,2 +1,3 @@
-SHA256 (projectM-2.0.1-Source.tar.gz) = c305182dfc8b7f87b82a146af6cf50a982e7c9c647877a0559dfef4b11dacb93
-SIZE (projectM-2.0.1-Source.tar.gz) = 865784
+TIMESTAMP = 1531809872
+SHA256 (projectM-complete-2.1.0-Source.tar.gz) = 513204f033006bd3dcdf8aada196d816d6b7187266ddcbb1594d0285cc9406ee
+SIZE (projectM-complete-2.1.0-Source.tar.gz) = 31130351
diff --git a/graphics/libprojectm/files/patch-Renderer_TextureManager.cpp b/graphics/libprojectm/files/patch-Renderer_TextureManager.cpp
deleted file mode 100644
index 0507a21e3e8e..000000000000
--- a/graphics/libprojectm/files/patch-Renderer_TextureManager.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- Renderer/TextureManager.cpp.orig 2009-12-06 02:42:51.000000000 +0100
-+++ Renderer/TextureManager.cpp
-@@ -25,6 +25,7 @@
- #ifdef MACOS
- #include <dirent.h>
- #endif
-+#include <sys/types.h>
- #include "TextureManager.hpp"
- #include "Common.hpp"
- #include "IdleTextures.hpp"
diff --git a/graphics/libprojectm/files/patch-c++11 b/graphics/libprojectm/files/patch-c++11
deleted file mode 100644
index 724a51430904..000000000000
--- a/graphics/libprojectm/files/patch-c++11
+++ /dev/null
@@ -1,87 +0,0 @@
-https://github.com/projectM-visualizer/projectm/commit/92226e25192a
-
-with a fix not yet upstream for
-
-Renderer/VideoEcho.cpp:77:30: error: non-constant-expression cannot be narrowed from type 'double' to 'float' in initializer list [-Wc++11-narrowing]
- float pointsFlip[4][2] = {{-0.5*flipx, -0.5*flipy},
- ^~~~~~~~~~
-Renderer/VideoEcho.cpp:77:30: note: insert an explicit cast to silence this issue
- float pointsFlip[4][2] = {{-0.5*flipx, -0.5*flipy},
- ^~~~~~~~~~
- static_cast<float>( )
-
---- Common.hpp.orig 2009-12-06 01:42:51 UTC
-+++ Common.hpp
-@@ -55,7 +55,7 @@ extern FILE *fmemopen(void *buf, size_t len, const cha
-
- #ifdef LINUX
- #include <cstdlib>
--#define projectM_isnan isnan
-+#define projectM_isnan std::isnan
-
- #endif
-
---- MilkdropPresetFactory/Parser.cpp.orig 2009-12-06 01:42:51 UTC
-+++ MilkdropPresetFactory/Parser.cpp
-@@ -1405,7 +1405,7 @@ PerFrameEqn * Parser::parse_implicit_per_frame_eqn(std
- PerFrameEqn * per_frame_eqn;
- GenExpr * gen_expr;
-
-- if (fs == NULL)
-+ if (fs.fail())
- return NULL;
- if (param_string == NULL)
- return NULL;
-@@ -1560,7 +1560,7 @@ InitCond * Parser::parse_per_frame_init_eqn(std::istre
-
- if (preset == NULL)
- return NULL;
-- if (fs == NULL)
-+ if (fs.fail())
- return NULL;
-
- if ((token = parseToken(fs, name)) != tEq)
-@@ -1874,7 +1874,7 @@ int Parser::parse_shapecode(char * token, std::istream
- /* Null argument checks */
- if (preset == NULL)
- return PROJECTM_FAILURE;
-- if (fs == NULL)
-+ if (fs.fail())
- return PROJECTM_FAILURE;
- if (token == NULL)
- return PROJECTM_FAILURE;
-@@ -2165,7 +2165,7 @@ int Parser::parse_wave(char * token, std::istream & f
-
- if (token == NULL)
- return PROJECTM_FAILURE;
-- if (fs == NULL)
-+ if (fs.fail())
- return PROJECTM_FAILURE;
- if (preset == NULL)
- return PROJECTM_FAILURE;
-@@ -2347,7 +2347,7 @@ int Parser::parse_shape(char * token, std::istream &
- if (token == NULL)
-
- return PROJECTM_FAILURE;
-- if (fs == NULL)
-+ if (fs.fail())
- return PROJECTM_FAILURE;
- if (preset == NULL)
- return PROJECTM_FAILURE;
---- Renderer/VideoEcho.cpp.orig 2009-12-06 01:42:51 UTC
-+++ Renderer/VideoEcho.cpp
-@@ -74,10 +74,10 @@ void VideoEcho::Draw(RenderContext &context)
- default: flipx=1;flipy=1; break;
- }
-
-- float pointsFlip[4][2] = {{-0.5*flipx, -0.5*flipy},
-- {-0.5*flipx, 0.5*flipy},
-- { 0.5*flipx, 0.5*flipy},
-- { 0.5*flipx, -0.5*flipy}};
-+ float pointsFlip[4][2] = {{-0.5f*flipx, -0.5f*flipy},
-+ {-0.5f*flipx, 0.5f*flipy},
-+ { 0.5f*flipx, 0.5f*flipy},
-+ { 0.5f*flipx, -0.5f*flipy}};
-
- glVertexPointer(2,GL_FLOAT,0,pointsFlip);
- glDrawArrays(GL_TRIANGLE_FAN,0,4);
diff --git a/graphics/libprojectm/files/patch-cmake_FindFreetype2.cmake b/graphics/libprojectm/files/patch-cmake_FindFreetype2.cmake
deleted file mode 100644
index d5a97dc8d602..000000000000
--- a/graphics/libprojectm/files/patch-cmake_FindFreetype2.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake/FindFreetype2.cmake.orig 2013-12-24 19:02:55.000000000 +0100
-+++ cmake/FindFreetype2.cmake 2013-12-24 19:03:21.000000000 +0100
-@@ -67,7 +67,7 @@
- NO_DEFAULT_PATH
- )
-
--FIND_PATH(FREETYPE2_FT2BUILD ft2build.h
-+FIND_PATH(FREETYPE2_FT2BUILD freetype2/ft2build.h
- ${ADDITIONAL_INCLUDE_PATH}
- /usr/include
- /usr/X11/include
diff --git a/graphics/libprojectm/files/patch-src_libprojectM_CMakeLists.txt b/graphics/libprojectm/files/patch-src_libprojectM_CMakeLists.txt
new file mode 100644
index 000000000000..142f9efb486e
--- /dev/null
+++ b/graphics/libprojectm/files/patch-src_libprojectM_CMakeLists.txt
@@ -0,0 +1,20 @@
+--- src/libprojectM/CMakeLists.txt.orig 2018-07-17 06:57:00 UTC
++++ src/libprojectM/CMakeLists.txt
+@@ -199,7 +199,7 @@ if(BUILD_PROJECTM_STATIC)
+ ${GLEW_LIBRARY}
+ ${FTGL_LINK_TARGETS}
+ ${MATH_LIBRARIES}
+- dl
++ ${CMAKE_DL_LIBS}
+ ${OPENGL_LIBRARIES}
+ )
+ else(BUILD_PROJECTM_STATIC)
+@@ -210,7 +210,7 @@ else(BUILD_PROJECTM_STATIC)
+ ${GLEW_LIBRARY}
+ ${FTGL_LINK_TARGETS}
+ ${MATH_LIBRARIES}
+- dl
++ ${CMAKE_DL_LIBS}
+ ${OPENGL_LIBRARIES}
+ )
+ endif(BUILD_PROJECTM_STATIC)
diff --git a/graphics/libprojectm/files/patch-src_libprojectM_NativePresetFactory_CMakeLists.txt b/graphics/libprojectm/files/patch-src_libprojectM_NativePresetFactory_CMakeLists.txt
new file mode 100644
index 000000000000..ec76636843c4
--- /dev/null
+++ b/graphics/libprojectm/files/patch-src_libprojectM_NativePresetFactory_CMakeLists.txt
@@ -0,0 +1,17 @@
+--- src/libprojectM/NativePresetFactory/CMakeLists.txt.orig 2018-07-17 06:48:40 UTC
++++ src/libprojectM/NativePresetFactory/CMakeLists.txt
+@@ -5,7 +5,7 @@ SET(NativePresetFactory_SOURCES NativePr
+ IF(NOT MSVC)
+ SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
+ ENDIF(NOT MSVC)
+-find_library(DL_LIBRARIES dl)
++#find_library(DL_LIBRARIES dl)
+
+ if(MSVC)
+ SET (MATH_LIBRARIES )
+@@ -15,4 +15,4 @@ endif(MSVC)
+
+ INCLUDE_DIRECTORIES(${projectM_SOURCE_DIR} ${Renderer_SOURCE_DIR})
+ ADD_LIBRARY(NativePresetFactory STATIC ${NativePresetFactory_SOURCES})
+-TARGET_LINK_LIBRARIES(NativePresetFactory Renderer ${MATH_LIBRARIES} ${DL_LIBRARIES})
++TARGET_LINK_LIBRARIES(NativePresetFactory Renderer ${MATH_LIBRARIES} ${CMAKE_DL_LIBS})
diff --git a/graphics/libprojectm/pkg-plist b/graphics/libprojectm/pkg-plist
index c6f2ed4eddb8..84181600e85f 100644
--- a/graphics/libprojectm/pkg-plist
+++ b/graphics/libprojectm/pkg-plist
@@ -1,13 +1,24 @@
+%%JACK%%bin/projectM-jack
+%%PULSEAUDIO%%bin/projectM-pulseaudio
+include/libprojectM-qt/qprojectm_mainwindow.hpp
include/libprojectM/Common.hpp
include/libprojectM/PCM.hpp
include/libprojectM/dlldefs.h
include/libprojectM/event.h
include/libprojectM/fatal.h
include/libprojectM/projectM.hpp
+lib/libprojectM-qt.so
+lib/libprojectM-qt.so.1
+lib/libprojectM-qt.so.1.10
lib/libprojectM.so
lib/libprojectM.so.2
-lib/libprojectM.so.2.00
+lib/libprojectM.so.2.1.0
+lib/libvisual-0.4/actor/libprojectM_libvisual.so
+libdata/pkgconfig/libprojectM-qt.pc
libdata/pkgconfig/libprojectM.pc
+%%JACK%%share/applications/projectM-jack.desktop
+%%PULSEAUDIO%%share/applications/projectM-pulseaudio.desktop
+share/pixmaps/prjm16-transparent.svg
@sample share/projectM/config.inp.sample
share/projectM/fonts/Vera.ttf
share/projectM/fonts/VeraMono.ttf
diff --git a/graphics/projectm-libvisual/Makefile b/graphics/projectm-libvisual/Makefile
deleted file mode 100644
index 7c13334154ae..000000000000
--- a/graphics/projectm-libvisual/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= projectM-libvisual
-PORTVERSION= 2.0.1
-PORTREVISION= 2
-CATEGORIES= graphics audio
-MASTER_SITES= SF/${PORTNAME:tl:S/-libvisual//}/${PORTVERSION}
-DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}-Source
-
-MAINTAINER= crees@FreeBSD.org
-COMMENT= Allows projectM to be used with libvisual
-
-LICENSE= GPLv2
-
-LIB_DEPENDS= libprojectM.so:graphics/libprojectm \
- libvisual-${LIBVISUAL_VER}.so:graphics/libvisual${LIBVISUAL_VER:S/.//} \
- libSDL.so:devel/sdl12
-
-USES= cmake pkgconfig
-CMAKE_ARGS+= -DLIBVISUAL_LIBRARIES=visual-${LIBVISUAL_VER}
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-LIBVISUAL_VER= 0.4
-
-PLIST_FILES= lib/libvisual-${LIBVISUAL_VER}/actor/libprojectM_libvisual.so
-
-post-patch:
- @${FIND} ${WRKSRC} -name "*.[hc]*" | ${XARGS} ${REINPLACE_CMD} \
- -e 's#<libvisual#<libvisual-${LIBVISUAL_VER}/libvisual#g'
- @${REINPLACE_CMD} -e 's#/usr/local#${PREFIX}#' \
- ${WRKSRC}/CPackConfig.cmake \
- ${WRKSRC}/cmake_install.cmake \
- ${WRKSRC}/CPackSourceConfig.cmake
-
-.include <bsd.port.mk>
diff --git a/graphics/projectm-libvisual/distinfo b/graphics/projectm-libvisual/distinfo
deleted file mode 100644
index bbcbf29a2dcd..000000000000
--- a/graphics/projectm-libvisual/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (projectM_libvisual-2.0.1-Source.tar.gz) = 8526b8687caebcef5f3374dd61665732f10030e970a7db4804eb65a06da18ea0
-SIZE (projectM_libvisual-2.0.1-Source.tar.gz) = 23128
diff --git a/graphics/projectm-libvisual/files/patch-actor_projectM-cpp b/graphics/projectm-libvisual/files/patch-actor_projectM-cpp
deleted file mode 100644
index 80bdcfc2c5a3..000000000000
--- a/graphics/projectm-libvisual/files/patch-actor_projectM-cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- actor_projectM.cpp.orig 2011-02-06 15:46:19.000000000 +0000
-+++ actor_projectM.cpp 2011-02-06 15:46:38.000000000 +0000
-@@ -56,7 +56,6 @@
- static VisPluginInfo info[1];
-
- actor[0].requisition = lv_projectm_requisition;
-- actor[0].palette = lv_projectm_palette;
- actor[0].render = lv_projectm_render;
- actor[0].vidoptions.depth = VISUAL_VIDEO_DEPTH_GL; /* We want GL clearly */
-
-@@ -209,7 +208,6 @@
- * we aren't with projectm, so just ignore :) */
- extern "C" VisPalette *lv_projectm_palette (VisPluginData *plugin)
- {
-- return NULL;
- }
-
- /* This is where the real rendering happens! This function is what we call, many times
diff --git a/graphics/projectm-libvisual/pkg-descr b/graphics/projectm-libvisual/pkg-descr
deleted file mode 100644
index 5db446ed747e..000000000000
--- a/graphics/projectm-libvisual/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-projectM is an LGPL'ed reimplementation of Milkdrop under OpenGL. All projectM
-requires is a video card with 3D acceleration and your favorite music.
-
-WWW: http://projectm.sourceforge.net/