aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/tora/Makefile4
-rw-r--r--devel/cppunit/Makefile8
-rw-r--r--devel/cppunit/distinfo6
-rw-r--r--devel/cppunit/pkg-plist6
-rw-r--r--graphics/crystalentitylayer-devel/Makefile2
-rw-r--r--graphics/crystalentitylayer/Makefile2
-rw-r--r--graphics/crystalspace-devel/Makefile2
-rw-r--r--graphics/crystalspace/Makefile2
-rw-r--r--graphics/epdfview/Makefile2
-rw-r--r--net/sipxtacklib/Makefile1
10 files changed, 19 insertions, 16 deletions
diff --git a/databases/tora/Makefile b/databases/tora/Makefile
index 730e7a1830a1..1038e794526b 100644
--- a/databases/tora/Makefile
+++ b/databases/tora/Makefile
@@ -16,9 +16,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Toolkit for Oracle
-BUILD_DEPENDS= ${ORACLE_HOME}/lib/libclntsh.a:${PORTSDIR}/databases/oracle8-client
+BUILD_DEPENDS= ${ORACLE_HOME}/lib/libclntsh.a:${PORTSDIR}/databases/oracle8-client \
+ cppunit-config:${PORTSDIR}/devel/cppunit
LIB_DEPENDS= qscintilla.7:${PORTSDIR}/x11-toolkits/qscintilla \
- cppunit-1.10.2:${PORTSDIR}/devel/cppunit \
pcre.0:${PORTSDIR}/devel/pcre
RUN_DEPENDS= ${ORACLE_HOME}/network/admin/tnsnames.ora:${PORTSDIR}/databases/oracle8-client
diff --git a/devel/cppunit/Makefile b/devel/cppunit/Makefile
index f944ecee0edf..f873bb6d8a5f 100644
--- a/devel/cppunit/Makefile
+++ b/devel/cppunit/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= cppunit
-PORTVERSION= 1.10.2
+PORTVERSION= 1.12.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -39,6 +39,10 @@ pre-everything::
@${ECHO_MSG}
.endif
+post-patch:
+ ${REINPLACE_CMD} -Ee "s,^(pkgconfigdatadir).*,\1 = ${LOCALBASE}/libdata/pkgconfig," \
+ ${WRKSRC}/Makefile.in
+
post-install:
@${FIND} ${PREFIX}/include/cppunit ! -type d | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@@ -50,5 +54,5 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/NEWS ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
.endif
-
+
.include <bsd.port.mk>
diff --git a/devel/cppunit/distinfo b/devel/cppunit/distinfo
index 4ee3f08c33aa..1521aaba9b09 100644
--- a/devel/cppunit/distinfo
+++ b/devel/cppunit/distinfo
@@ -1,3 +1,3 @@
-MD5 (cppunit-1.10.2.tar.gz) = 0bc06cd219410f7d4f6bbfc9bdd7c824
-SHA256 (cppunit-1.10.2.tar.gz) = 71b626958e3d8927d236f462b2becd192a113d1d6d38b8d567bdc181b5069ccf
-SIZE (cppunit-1.10.2.tar.gz) = 723340
+MD5 (cppunit-1.12.0.tar.gz) = 7493718733ded49a96cf763c5d3eea7f
+SHA256 (cppunit-1.12.0.tar.gz) = 98a5c38cbcad916aea4dbd8fb42a41bc16174e42426d949127292adf4af7fe1f
+SIZE (cppunit-1.12.0.tar.gz) = 760409
diff --git a/devel/cppunit/pkg-plist b/devel/cppunit/pkg-plist
index 3ca642e5351c..52552c74dd0f 100644
--- a/devel/cppunit/pkg-plist
+++ b/devel/cppunit/pkg-plist
@@ -1,9 +1,9 @@
bin/DllPlugInTester
bin/cppunit-config
-bin/simple
-lib/libcppunit-1.10.so
-lib/libcppunit-1.10.so.2
+lib/libcppunit-1.12.so
+lib/libcppunit-1.12.so.0
lib/libcppunit.a
lib/libcppunit.la
lib/libcppunit.so
+libdata/pkgconfig/cppunit.pc
share/aclocal/cppunit.m4
diff --git a/graphics/crystalentitylayer-devel/Makefile b/graphics/crystalentitylayer-devel/Makefile
index 12160488d38e..8f77df5b8e9c 100644
--- a/graphics/crystalentitylayer-devel/Makefile
+++ b/graphics/crystalentitylayer-devel/Makefile
@@ -57,7 +57,7 @@ CONFIGURE_ARGS+= --without-python
.endif
.if!defined(WITHOUT_CPPUNIT)
-LIB_DEPENDS+= cppunit-1.10:${PORTSDIR}/devel/cppunit
+BUILD_DEPENDS+= cppunit-config:${PORTSDIR}/devel/cppunit
.else
CONFIGURE_ARGS+= --without-cppunit
.endif
diff --git a/graphics/crystalentitylayer/Makefile b/graphics/crystalentitylayer/Makefile
index 1a711410c421..b0050c4a25bc 100644
--- a/graphics/crystalentitylayer/Makefile
+++ b/graphics/crystalentitylayer/Makefile
@@ -58,7 +58,7 @@ CONFIGURE_ARGS+= --without-python
.endif
.if!defined(WITHOUT_CPPUNIT)
-LIB_DEPENDS+= cppunit-1.10:${PORTSDIR}/devel/cppunit
+BUILD_DEPENDS+= cppunit-config:${PORTSDIR}/devel/cppunit
.else
CONFIGURE_ARGS+= --without-cppunit
.endif
diff --git a/graphics/crystalspace-devel/Makefile b/graphics/crystalspace-devel/Makefile
index 57a45d6fd6c7..225a99bfeecb 100644
--- a/graphics/crystalspace-devel/Makefile
+++ b/graphics/crystalspace-devel/Makefile
@@ -150,7 +150,7 @@ CONFIGURE_ARGS+= --without-caca
.endif
.if !defined(WITHOUT_CPPUNIT)
-LIB_DEPENDS+= cppunit-1.10:${PORTSDIR}/devel/cppunit
+BUILD_DEPENDS+= cppunit-config:${PORTSDIR}/devel/cppunit
.else
CONFIGURE_ARGS+= --without-cppunit
.endif
diff --git a/graphics/crystalspace/Makefile b/graphics/crystalspace/Makefile
index 39222b614e30..2930b61aa8ae 100644
--- a/graphics/crystalspace/Makefile
+++ b/graphics/crystalspace/Makefile
@@ -156,7 +156,7 @@ CONFIGURE_ARGS+= --without-caca
.endif
.if !defined(WITHOUT_CPPUNIT)
-LIB_DEPENDS+= cppunit-1.10:${PORTSDIR}/devel/cppunit
+BUILD_DEPENDS+= cppunit-config:${PORTSDIR}/devel/cppunit
.else
CONFIGURE_ARGS+= --without-cppunit
.endif
diff --git a/graphics/epdfview/Makefile b/graphics/epdfview/Makefile
index 680384ab1579..1300ad2d2d31 100644
--- a/graphics/epdfview/Makefile
+++ b/graphics/epdfview/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= http://trac.emma-soft.com/epdfview/chrome/site/releases/ \
MAINTAINER= chinsan@FreeBSD.org
COMMENT= A lightweight PDF document viewer
-BUILD_DEPENDS= DllPlugInTester:${PORTSDIR}/devel/cppunit
+BUILD_DEPENDS= cppunit-config:${PORTSDIR}/devel/cppunit
LIB_DEPENDS= poppler-glib.2:${PORTSDIR}/graphics/poppler-gtk
USE_BZIP2= yes
diff --git a/net/sipxtacklib/Makefile b/net/sipxtacklib/Makefile
index 3f0c1fe39b1c..41f71a17c5b4 100644
--- a/net/sipxtacklib/Makefile
+++ b/net/sipxtacklib/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
pcre.0:${PORTSDIR}/devel/pcre
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
BUILD_DEPENDS= ant:${PORTSDIR}/devel/apache-ant \
- cppunit-config:${PORTSDIR}/devel/cppunit \
ginstall:${PORTSDIR}/sysutils/coreutils \
cppunit-config:${PORTSDIR}/devel/cppunit