aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/conky-awesome/Makefile4
-rw-r--r--sysutils/conky-awesome/files/patch-src_conky.c11
-rw-r--r--sysutils/conky/Makefile5
-rw-r--r--sysutils/conky/distinfo6
-rw-r--r--sysutils/conky/files/patch-configure10
5 files changed, 17 insertions, 19 deletions
diff --git a/sysutils/conky-awesome/Makefile b/sysutils/conky-awesome/Makefile
index 4bd77a4b2e9b..bc4408719a06 100644
--- a/sysutils/conky-awesome/Makefile
+++ b/sysutils/conky-awesome/Makefile
@@ -13,12 +13,10 @@ COMMENT= An advanced, highly configurable system monitor (configured for x11-wm/
MASTERDIR= ${.CURDIR}/../../sysutils/conky
DESCR= ${.CURDIR}/pkg-descr
-EXTRA_PATCHES= ${.CURDIR}/files/patch-*
-
CONFLICTS= conky-[0-9]*
USE_XORG= # This is a comment
USE_GNOME= pkgconfig
-CONFIGURE_ARGS+= --disable-x11
+CONFIGURE_ARGS+= --disable-x11 --disable-own-window
.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/conky-awesome/files/patch-src_conky.c b/sysutils/conky-awesome/files/patch-src_conky.c
deleted file mode 100644
index e9d48cb9d33a..000000000000
--- a/sysutils/conky-awesome/files/patch-src_conky.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/conky.c.orig 2008-08-19 16:02:53.000000000 -0700
-+++ src/conky.c 2008-08-19 16:03:36.000000000 -0700
-@@ -6672,7 +6672,7 @@ static void draw_string(const char *s)
-
- width_of_s = get_string_width(s);
- if ((output_methods & TO_STDOUT) && draw_mode == FG) {
-- printf("%s\n", s);
-+ printf("%s\n\n", s);
- fflush(stdout); /* output immediately, don't buffer */
- }
- memset(tmpstring1, 0, text_buffer_size);
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index 9f940bf7fe7c..91147184472d 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= conky
-PORTVERSION= 1.7.1.1
-PORTREVISION= 2
+PORTVERSION= 1.7.2
CATEGORIES= sysutils
MASTER_SITES= SF
@@ -109,6 +108,8 @@ CONFIGURE_ARGS+= --disable-double-buffer
post-patch:
@${REINPLACE_CMD} -e 's,lua5\.1,lua-5.1,g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's,imlib_context_disconnect_display();,,g' \
+ ${WRKSRC}/src/imlib2.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/conky ${PREFIX}/bin
diff --git a/sysutils/conky/distinfo b/sysutils/conky/distinfo
index b73fe4d42ed8..f8ad55fa1043 100644
--- a/sysutils/conky/distinfo
+++ b/sysutils/conky/distinfo
@@ -1,3 +1,3 @@
-MD5 (conky-1.7.1.1.tar.bz2) = 153a661e78a466c95b1b332e7cd599cb
-SHA256 (conky-1.7.1.1.tar.bz2) = aa7277c01dc5da407f12b27ae4d6b6ab72f24667d60818e9be28e7bdf26cd3ca
-SIZE (conky-1.7.1.1.tar.bz2) = 512566
+MD5 (conky-1.7.2.tar.bz2) = cf6f5d45d42ad68c618c00271813b80d
+SHA256 (conky-1.7.2.tar.bz2) = b3c0a1b0ff90579d48df542a6070adbe67d3926d6d0c66ee12b52b2d5a2c675c
+SIZE (conky-1.7.2.tar.bz2) = 585099
diff --git a/sysutils/conky/files/patch-configure b/sysutils/conky/files/patch-configure
new file mode 100644
index 000000000000..9e5434264b55
--- /dev/null
+++ b/sysutils/conky/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig 2009-09-17 09:53:21.000000000 +0300
++++ configure 2009-09-17 10:13:11.000000000 +0300
+@@ -19845,7 +19845,6 @@
+ ac_res=$ac_cv_search_clock_gettime
+ if test "$ac_res" != no; then
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
+- conky_LIBS="$conky_LIBS -lrt"
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_CLOCK_GETTIME 1