aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-listen2/Makefile28
-rw-r--r--devel/rubygem-listen2/distinfo2
-rw-r--r--devel/rubygem-listen2/pkg-descr15
-rw-r--r--sysutils/vagrant/Makefile3
-rw-r--r--www/rubygem-jekyll-watch/Makefile3
6 files changed, 50 insertions, 2 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 988e961d6bfb..1d03b21d73eb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4673,6 +4673,7 @@
SUBDIR += rubygem-librarianp
SUBDIR += rubygem-libyajl2
SUBDIR += rubygem-listen
+ SUBDIR += rubygem-listen2
SUBDIR += rubygem-little-plugger
SUBDIR += rubygem-locale
SUBDIR += rubygem-lockfile
diff --git a/devel/rubygem-listen2/Makefile b/devel/rubygem-listen2/Makefile
new file mode 100644
index 000000000000..055ad988bbff
--- /dev/null
+++ b/devel/rubygem-listen2/Makefile
@@ -0,0 +1,28 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= listen
+PORTVERSION= 2.10.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 2
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Listen to file modifications and notify about the changes
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-celluloid>=0.16.0:${PORTSDIR}/devel/rubygem-celluloid \
+ rubygem-rb-fsevent>=0.9.3:${PORTSDIR}/devel/rubygem-rb-fsevent \
+ rubygem-rb-inotify>=0.9:${PORTSDIR}/devel/rubygem-rb-inotify \
+ rubygem-rb-kqueue>=0.2:${PORTSDIR}/devel/rubygem-rb-kqueue
+
+NO_ARCH= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/bin/listen
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-listen2/distinfo b/devel/rubygem-listen2/distinfo
new file mode 100644
index 000000000000..492795e0ec7d
--- /dev/null
+++ b/devel/rubygem-listen2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/listen-2.10.1.gem) = 0fc7366e034515b24713cbc529dddf3d5a53a3ec7aae36553fd106d1978deac6
+SIZE (rubygem/listen-2.10.1.gem) = 26624
diff --git a/devel/rubygem-listen2/pkg-descr b/devel/rubygem-listen2/pkg-descr
new file mode 100644
index 000000000000..ef651a5fd9b6
--- /dev/null
+++ b/devel/rubygem-listen2/pkg-descr
@@ -0,0 +1,15 @@
+The Listen gem listens to file modifications and notifies you about the changes.
+
+Features:
+- Works everywhere!
+- Supports watching multiple directories from a single listener.
+- OS-specific adapters for Mac OS X 10.6+, Linux and Windows.
+- Automatic fallback to polling if OS-specific adapter doesn't work.
+- Detects files modification, addidation and removal.
+- Checksum comparaison for modifications made under the same second.
+- Allows supplying regexp-patterns to ignore and filter paths for better
+ results.
+- Tested on all Ruby environments via travis-ci.
+
+WWW: https://github.com/guard/listen
+RG: https://rubygems.org/gems/listen
diff --git a/sysutils/vagrant/Makefile b/sysutils/vagrant/Makefile
index 66106281f67e..2e942dadf09b 100644
--- a/sysutils/vagrant/Makefile
+++ b/sysutils/vagrant/Makefile
@@ -3,6 +3,7 @@
PORTNAME= vagrant
PORTVERSION= 1.7.2
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= sysutils rubygems devel
@@ -19,7 +20,7 @@ RUN_DEPENDS= rubygem-bundler17>=1.5.3:${PORTSDIR}/sysutils/rubygem-bundler17 \
rubygem-erubis>=2.7.0:${PORTSDIR}/www/rubygem-erubis \
rubygem-hashicorp-checkpoint>=0.1.4:${PORTSDIR}/www/rubygem-hashicorp-checkpoint \
rubygem-i18n>=0.6.9:${PORTSDIR}/devel/rubygem-i18n \
- rubygem-listen>=2.8.0:${PORTSDIR}/devel/rubygem-listen \
+ rubygem-listen2>=2.8.0:${PORTSDIR}/devel/rubygem-listen2 \
rubygem-log4r>=1.1.10:${PORTSDIR}/sysutils/rubygem-log4r \
rubygem-net-scp>=1.1.0:${PORTSDIR}/security/rubygem-net-scp \
rubygem-net-sftp>=2.1:${PORTSDIR}/security/rubygem-net-sftp \
diff --git a/www/rubygem-jekyll-watch/Makefile b/www/rubygem-jekyll-watch/Makefile
index dbc4c988382d..5e54cbbf9184 100644
--- a/www/rubygem-jekyll-watch/Makefile
+++ b/www/rubygem-jekyll-watch/Makefile
@@ -3,6 +3,7 @@
PORTNAME= jekyll-watch
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= www rubygems
MASTER_SITES= RG
@@ -11,7 +12,7 @@ COMMENT= Handles rebuilding of Jekyll sites when a file changes
LICENSE= MIT
-RUN_DEPENDS= rubygem-listen>=2.7:${PORTSDIR}/devel/rubygem-listen
+RUN_DEPENDS= rubygem-listen2>=2.7:${PORTSDIR}/devel/rubygem-listen2
NO_ARCH= yes