aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/Makefile1
-rw-r--r--lang/py-textX/Makefile22
-rw-r--r--lang/py-textX/distinfo3
-rw-r--r--lang/py-textX/pkg-descr16
4 files changed, 42 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 6b7a7b3115cb..fbfd78a95a88 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -294,6 +294,7 @@
SUBDIR += py-mx-base
SUBDIR += py-prolog
SUBDIR += py-qt5-qml
+ SUBDIR += py-textX
SUBDIR += pypy
SUBDIR += pypy3
SUBDIR += python
diff --git a/lang/py-textX/Makefile b/lang/py-textX/Makefile
new file mode 100644
index 000000000000..6ee6b4e9306a
--- /dev/null
+++ b/lang/py-textX/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= textX
+PORTVERSION= 2.1.0
+CATEGORIES= lang python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Meta-language for DSL implementation inspired by Xtext
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}arpeggio>=1.9.0:devel/py-arpeggio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=7.0:devel/py-click@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/lang/py-textX/distinfo b/lang/py-textX/distinfo
new file mode 100644
index 000000000000..e08a0a337bf2
--- /dev/null
+++ b/lang/py-textX/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1572135888
+SHA256 (textX-2.1.0.tar.gz) = 159c710f98401f090eb39fa44cd20bc48d697cb96684d1f457428c7ab37bb61c
+SIZE (textX-2.1.0.tar.gz) = 52951
diff --git a/lang/py-textX/pkg-descr b/lang/py-textX/pkg-descr
new file mode 100644
index 000000000000..fbfc98267edc
--- /dev/null
+++ b/lang/py-textX/pkg-descr
@@ -0,0 +1,16 @@
+textX is a meta-language for building Domain-Specific Languages (DSLs) in
+Python. It is inspired by Xtext.
+
+In a nutshell, textX will help you build your textual language in an easy way.
+You can invent your own language or build a support for already existing textual
+language or file format.
+
+From a single language description (grammar), textX will build a parser and a
+meta-model (a.k.a. abstract syntax) for the language. See the docs for the
+details.
+
+textX follows the syntax and semantics of Xtext but differs in some places and
+is implemented 100% in Python using Arpeggio PEG parser - no grammar
+ambiguities, unlimited lookahead, interpreter style of work.
+
+WWW: http://textx.github.io/textX/stable/