aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING8
-rw-r--r--security/tor-devel/Makefile8
-rw-r--r--security/tor-devel/files/pkg-message.in13
-rw-r--r--security/tor-devel/pkg-plist2
-rw-r--r--security/tor/Makefile8
-rw-r--r--security/tor/files/pkg-message.in13
-rw-r--r--security/tor/pkg-plist2
7 files changed, 34 insertions, 20 deletions
diff --git a/UPDATING b/UPDATING
index 35abf1940b25..69d6b47ef482 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20160119:
+ AFFECTS: users of security/tor, security/tor-devel
+ AUTHOR: amdmi3@FreeBSD.org
+
+ The tor ports now create /var/log/tor subdirectory for tor logs. If
+ you've used /var/log/tor as a log _file_, you'll need to update your
+ torrc and move the file before updating the port.
+
20160118:
AFFECTS: users of mail/rspamd and mail/rmilter
AUTHOR: vsevolod@FreeBSD.org
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index 4233dfd5e317..e8cba5fcd951 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tor
PORTVERSION= 0.2.7.6
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= TOR
PKGNAMESUFFIX= -devel
@@ -109,6 +110,10 @@ CONFIGURE_ARGS+= --disable-transparent
post-patch:
@${REINPLACE_CMD} -E -e "s@(-z) (relro|now)@-Wl,\1,\2@g" \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|lib/tor|db/tor|' \
+ ${WRKSRC}/src/config/torrc.*.in \
+ ${WRKSRC}/doc/tor.1.* \
+ ${WRKSRC}/doc/tor.html.in
post-patch-STATIC_TOR-off:
@${REINPLACE_CMD} -e "s@-ltcmalloc@${LOCALBASE}/lib/libtcmalloc.so@" \
@@ -122,6 +127,9 @@ post-configure:
@${REINPLACE_CMD} -e '\|^nodist_man1_MANS =|s|$$|$$(install_mans:=.1)|' \
${WRKSRC}/Makefile
+post-install:
+ @${MKDIR} ${STAGEDIR}/var/log/tor ${STAGEDIR}/var/run/tor
+
.if ! ${PORT_OPTIONS:MTOR2WEB}
check regression-test test: build
@cd ${BUILD_WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
diff --git a/security/tor-devel/files/pkg-message.in b/security/tor-devel/files/pkg-message.in
index cf0accc2329e..a3155b04a889 100644
--- a/security/tor-devel/files/pkg-message.in
+++ b/security/tor-devel/files/pkg-message.in
@@ -3,17 +3,10 @@ To enable the tor server, set tor_enable="YES" in your /etc/rc.conf
and edit %%PREFIX%%/etc/tor/torrc as desired. (However, note that the
%%PREFIX%%/etc/rc.d/tor rc.subr script can override some torrc
options: see that script for details.) To use the torify script, install
-the net/torsocks port. After installing tor for the first time, or after
-a major update of tor, you should:
+the net/torsocks port.
-rm -r /var/db/tor /var/run/tor
-mkdir -p /var/db/tor/data /var/run/tor
-touch /var/log/tor
-chown -R _tor:_tor /var/db/tor /var/log/tor /var/run/tor
-chmod -R 700 /var/db/tor
-
-before starting the tor server. Tor users are strongly advised to prevent traffic
-analysis that exploits sequential IP IDs by setting:
+Tor users are strongly advised to prevent traffic analysis that
+exploits sequential IP IDs by setting:
sysctl net.inet.ip.random_id=1
diff --git a/security/tor-devel/pkg-plist b/security/tor-devel/pkg-plist
index 1d8a482892cc..157ef514dd66 100644
--- a/security/tor-devel/pkg-plist
+++ b/security/tor-devel/pkg-plist
@@ -9,3 +9,5 @@ man/man1/tor.1.gz
man/man1/torify.1.gz
%%DATADIR%%/geoip
%%DATADIR%%/geoip6
+@dir(_tor,_tor,750) /var/run/tor
+@dir(_tor,_tor,750) /var/log/tor
diff --git a/security/tor/Makefile b/security/tor/Makefile
index da3af82250c8..146c04a300d5 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tor
PORTVERSION= 0.2.7.6
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= TOR
@@ -106,6 +107,10 @@ CONFIGURE_ARGS+= --disable-transparent
post-patch:
@${REINPLACE_CMD} -E -e "s@(-z) (relro|now)@-Wl,\1,\2@g" \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|lib/tor|db/tor|' \
+ ${WRKSRC}/src/config/torrc.*.in \
+ ${WRKSRC}/doc/tor.1.* \
+ ${WRKSRC}/doc/tor.html.in
post-patch-STATIC_TOR-off:
@${REINPLACE_CMD} -e "s@-ltcmalloc@${LOCALBASE}/lib/libtcmalloc.so@" \
@@ -119,6 +124,9 @@ post-configure:
@${REINPLACE_CMD} -e '\|^nodist_man1_MANS =|s|$$|$$(install_mans:=.1)|' \
${WRKSRC}/Makefile
+post-install:
+ @${MKDIR} ${STAGEDIR}/var/log/tor ${STAGEDIR}/var/run/tor
+
.if ! ${PORT_OPTIONS:MTOR2WEB}
check regression-test test: build
@cd ${BUILD_WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
diff --git a/security/tor/files/pkg-message.in b/security/tor/files/pkg-message.in
index cf0accc2329e..a3155b04a889 100644
--- a/security/tor/files/pkg-message.in
+++ b/security/tor/files/pkg-message.in
@@ -3,17 +3,10 @@ To enable the tor server, set tor_enable="YES" in your /etc/rc.conf
and edit %%PREFIX%%/etc/tor/torrc as desired. (However, note that the
%%PREFIX%%/etc/rc.d/tor rc.subr script can override some torrc
options: see that script for details.) To use the torify script, install
-the net/torsocks port. After installing tor for the first time, or after
-a major update of tor, you should:
+the net/torsocks port.
-rm -r /var/db/tor /var/run/tor
-mkdir -p /var/db/tor/data /var/run/tor
-touch /var/log/tor
-chown -R _tor:_tor /var/db/tor /var/log/tor /var/run/tor
-chmod -R 700 /var/db/tor
-
-before starting the tor server. Tor users are strongly advised to prevent traffic
-analysis that exploits sequential IP IDs by setting:
+Tor users are strongly advised to prevent traffic analysis that
+exploits sequential IP IDs by setting:
sysctl net.inet.ip.random_id=1
diff --git a/security/tor/pkg-plist b/security/tor/pkg-plist
index 1d8a482892cc..157ef514dd66 100644
--- a/security/tor/pkg-plist
+++ b/security/tor/pkg-plist
@@ -9,3 +9,5 @@ man/man1/tor.1.gz
man/man1/torify.1.gz
%%DATADIR%%/geoip
%%DATADIR%%/geoip6
+@dir(_tor,_tor,750) /var/run/tor
+@dir(_tor,_tor,750) /var/log/tor