aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/dvdauthor/Makefile4
-rw-r--r--multimedia/dvdauthor/files/patch-src__subgen-image.c26
2 files changed, 13 insertions, 17 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index e3aa0fb26e87..934c694436af 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -8,11 +8,10 @@
PORTNAME= dvdauthor
PORTVERSION= 0.6.18
PORTREVISION= 2
-WRKSRC= ${WRKDIR}/dvdauthor
CATEGORIES= multimedia
MASTER_SITES= SF
-MAINTAINER= pb@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Makes a DVD file structure from one or more MPEG2 streams
LIB_DEPENDS= dvdread.4:${PORTSDIR}/multimedia/libdvdread \
@@ -23,6 +22,7 @@ USE_BISON= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+WRKSRC= ${WRKDIR}/dvdauthor
MAN1= dvdauthor.1 dvddirdel.1 dvdunauthor.1 mpeg2desc.1 spumux.1 spuunmux.1
.include <bsd.port.pre.mk>
diff --git a/multimedia/dvdauthor/files/patch-src__subgen-image.c b/multimedia/dvdauthor/files/patch-src__subgen-image.c
index 9bba393c7ee2..3108b2be0a6b 100644
--- a/multimedia/dvdauthor/files/patch-src__subgen-image.c
+++ b/multimedia/dvdauthor/files/patch-src__subgen-image.c
@@ -1,15 +1,11 @@
-diff -ruN --exclude=CVS /usr/ports/multimedia/dvdauthor.orig/files/patch-src__subgen-image.c /usr/ports/multimedia/dvdauthor/files/patch-src__subgen-image.c
---- /usr/ports/multimedia/dvdauthor.orig/files/patch-src__subgen-image.c 1969-12-31 18:00:00.000000000 -0600
-+++ /usr/ports/multimedia/dvdauthor/files/patch-src__subgen-image.c 2010-07-15 19:58:36.000000000 -0500
-@@ -0,0 +1,11 @@
-+--- src/subgen-image.c.orig 2007-01-12 19:40:42.000000000 -0600
-++++ src/subgen-image.c 2010-07-15 19:56:30.000000000 -0600
-+@@ -203,7 +203,7 @@
-+ png_struct *ps;
-+ png_info *pi;
-+ png_byte **rowp;
-+- unsigned long width,height;
-++ png_uint_32 width,height;
-+ int bit_depth,color_type,channels,x,y;
-+
-+ fp=fopen(s->fname,"rb");
+--- src/subgen-image.c.orig 2007-01-12 19:40:42.000000000 -0600
++++ src/subgen-image.c 2010-07-15 19:56:30.000000000 -0600
+@@ -203,7 +203,7 @@
+ png_struct *ps;
+ png_info *pi;
+ png_byte **rowp;
+- unsigned long width,height;
++ png_uint_32 width,height;
+ int bit_depth,color_type,channels,x,y;
+
+ fp=fopen(s->fname,"rb");