aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/libebur128/Makefile3
-rw-r--r--audio/pulseaudio/Makefile4
-rw-r--r--comms/gnuradio/Makefile2
-rw-r--r--deskutils/conduit/Makefile4
-rw-r--r--deskutils/gnome-documents/Makefile2
-rw-r--r--deskutils/xfce4-tumbler/Makefile3
-rw-r--r--devel/py-roxlib/Makefile4
-rw-r--r--devel/ruby-build/Makefile2
-rw-r--r--games/balazarbrothers/Makefile2
-rw-r--r--net-im/centerim-devel/Makefile4
-rw-r--r--net-im/centerim/Makefile4
-rw-r--r--net/gq/Makefile4
-rw-r--r--net/vnc/Makefile2
-rw-r--r--print/hpijs/Makefile3
-rw-r--r--science/afni/Makefile2
-rw-r--r--security/gnome-gpg/Makefile4
-rw-r--r--security/gnome-keyring-sharp/Makefile4
-rw-r--r--security/gpass/Makefile4
-rw-r--r--security/w3af/Makefile3
-rw-r--r--textproc/docproj/Makefile2
-rw-r--r--textproc/sdom/Makefile2
-rw-r--r--x11-toolkits/py-kivy/Makefile6
-rw-r--r--x11-wm/wmakerconf/Makefile2
-rw-r--r--x11/hotwire-shell/Makefile2
24 files changed, 37 insertions, 37 deletions
diff --git a/audio/libebur128/Makefile b/audio/libebur128/Makefile
index e32c17a0e3f9..fe8f338f792a 100644
--- a/audio/libebur128/Makefile
+++ b/audio/libebur128/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libebur128
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= audio
MAINTAINER= ports@FreeBSD.org
@@ -10,7 +11,7 @@ COMMENT= Implementation of the EBU R128 loudness standard
LICENSE= MIT
-LIB_DEPENDS= libspeexdsp.so:${PORTSDIR}/audio/speex
+LIB_DEPENDS= libspeexdsp.so:${PORTSDIR}/audio/speexdsp
USES= cmake:outsource pkgconfig
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index aff73db949a0..6572459c2422 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pulseaudio
PORTVERSION= 5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://freedesktop.org/software/pulseaudio/releases/
@@ -16,7 +16,7 @@ COMMENT= Sound server for UNIX
LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libsndfile.so:${PORTSDIR}/audio/libsndfile \
- libspeexdsp.so:${PORTSDIR}/audio/speex \
+ libspeexdsp.so:${PORTSDIR}/audio/speexdsp \
libfftw3.so:${PORTSDIR}/math/fftw3 \
libfftw3f.so:${PORTSDIR}/math/fftw3-float \
liborc-0.4.so:${PORTSDIR}/devel/orc \
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 30e45636ee32..b08bed15e92f 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= sdl-config:${PORTSDIR}/devel/sdl12 \
swig2.0:${PORTSDIR}/devel/swig20 \
cheetah:${PORTSDIR}/devel/py-cheetah \
- ${PYTHON_SITELIBDIR}/lxml:${PORTSDIR}/devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
${PYTHON_SITELIBDIR}/pygtk.py:${PORTSDIR}/x11-toolkits/py-gtk2 \
${PYTHON_SITELIBDIR}/PyQt4/Qt.py:${PORTSDIR}/devel/py-qt4 \
xdg-open:${PORTSDIR}/devel/xdg-utils \
diff --git a/deskutils/conduit/Makefile b/deskutils/conduit/Makefile
index e8eab24bd091..efff4bbdfb52 100644
--- a/deskutils/conduit/Makefile
+++ b/deskutils/conduit/Makefile
@@ -15,13 +15,13 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/goocanvasmodule.so:${PORTSDIR}/graphics/py-g
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
xmlproc_parse:${PORTSDIR}/textproc/py-xml \
${PYTHON_PKGNAMEPREFIX}vobject>=0.4.8:${PORTSDIR}/deskutils/py-vobject \
- ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus
+ ${PYTHON_PKGNAMEPREFIX}dbus>0:${PORTSDIR}/devel/py-dbus
LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/goocanvasmodule.so:${PORTSDIR}/graphics/py-goocanvas \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
xmlproc_parse:${PORTSDIR}/textproc/py-xml \
${PYTHON_PKGNAMEPREFIX}vobject>=0.4.8:${PORTSDIR}/deskutils/py-vobject \
- ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
+ ${PYTHON_PKGNAMEPREFIX}dbus>0:${PORTSDIR}/devel/py-dbus \
xdg-open:${PORTSDIR}/devel/xdg-utils
GNU_CONFIGURE= yes
diff --git a/deskutils/gnome-documents/Makefile b/deskutils/gnome-documents/Makefile
index 7a98c323fdff..6a36a9907fa5 100644
--- a/deskutils/gnome-documents/Makefile
+++ b/deskutils/gnome-documents/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libgjs.so:${PORTSDIR}/lang/gjs \
libtracker-sparql-1.0.so:${PORTSDIR}/sysutils/tracker \
libzapojit-0.0.so:${PORTSDIR}/net/libzapojit
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
+RUN_DEPENDS= py2?-dbus>0:${PORTSDIR}/devel/py-dbus \
${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss \
unoconv:${PORTSDIR}/textproc/unoconv
diff --git a/deskutils/xfce4-tumbler/Makefile b/deskutils/xfce4-tumbler/Makefile
index 4d48af867feb..ea37248634f5 100644
--- a/deskutils/xfce4-tumbler/Makefile
+++ b/deskutils/xfce4-tumbler/Makefile
@@ -86,8 +86,7 @@ USE_GNOME+= gdkpixbuf2
CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
PLIST_SUB+= PIXBUF=""
.endif
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libexif.so:${PORTSDIR}/graphics/exif
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
CONFIGURE_ARGS+=--enable-jpeg-thumbnailer
PLIST_SUB+= JPEG=""
.else
diff --git a/devel/py-roxlib/Makefile b/devel/py-roxlib/Makefile
index dfbbd9a4bdc5..c93c372462bc 100644
--- a/devel/py-roxlib/Makefile
+++ b/devel/py-roxlib/Makefile
@@ -12,9 +12,9 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= Python libraries for ROX
USES= python tar:bzip2
+USE_GNOME= pygtk2:run
-RUN_DEPENDS= ${LOCALBASE}/bin/rox:${PORTSDIR}/x11-fm/rox-filer \
- ${PYTHON_SITELIBDIR}/pygtk.py:${PORTSDIR}/x11-toolkits/py-gtk2
+RUN_DEPENDS= ${LOCALBASE}/bin/rox:${PORTSDIR}/x11-fm/rox-filer
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}
diff --git a/devel/ruby-build/Makefile b/devel/ruby-build/Makefile
index 990fdcb33ab8..25323547f95f 100644
--- a/devel/ruby-build/Makefile
+++ b/devel/ruby-build/Makefile
@@ -9,7 +9,7 @@ COMMENT= Compile and install different ruby versions
LICENSE= MIT
-RUN_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
+RUN_DEPENDS= autoconf>0:${PORTSDIR}/devel/autoconf \
curl:${PORTSDIR}/ftp/curl \
gmake:${PORTSDIR}/devel/gmake
diff --git a/games/balazarbrothers/Makefile b/games/balazarbrothers/Makefile
index c637b55cab4c..0fb14f33e722 100644
--- a/games/balazarbrothers/Makefile
+++ b/games/balazarbrothers/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcal3d.so:${PORTSDIR}/graphics/cal3d \
libfreetype.so:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ogg>0:${PORTSDIR}/audio/py-vorbis \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}vorbis>0:${PORTSDIR}/audio/py-vorbis \
${PYTHON_PKGNAMEPREFIX}soya3d>0:${PORTSDIR}/graphics/py-soya3d \
${PYTHON_PKGNAMEPREFIX}tofu>0:${PORTSDIR}/net/py-tofu \
${PYTHON_PKGNAMEPREFIX}cerealizer>0:${PORTSDIR}/security/py-cerealizer
diff --git a/net-im/centerim-devel/Makefile b/net-im/centerim-devel/Makefile
index b5bfb331886d..2a8a77a6aaf1 100644
--- a/net-im/centerim-devel/Makefile
+++ b/net-im/centerim-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= centerim
PORTVERSION= 4.22.10.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-im
MASTER_SITES= http://www.centerim.org/download/mobshots/ \
ftp://ftp.centerim.org/mobshots/
@@ -58,7 +58,7 @@ IRC_CONFIGURE_ENABLE= irc
JABBER_CONFIGURE_ENABLE=jabber
RSS_CONFIGURE_ENABLE= rss
LJ_CONFIGURE_ENABLE= lj
-GG_LIB_DEPENDS= libgadu.so:${PORTSDIR}/polish/ekg
+GG_LIB_DEPENDS= libgadu.so:${PORTSDIR}/polish/libgadu
GG_CONFIGURE_ENABLE= gg
GPGME_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
GPGME_CONFIGURE_OFF= --with-gpgme-prefix=/nonexistent
diff --git a/net-im/centerim/Makefile b/net-im/centerim/Makefile
index 717aaab1b910..3dac188a5710 100644
--- a/net-im/centerim/Makefile
+++ b/net-im/centerim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= centerim
PORTVERSION= 4.22.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-im
MASTER_SITES= http://www.centerim.org/download/releases/ \
ftp://ftp.centerim.org/releases/
@@ -57,7 +57,7 @@ IRC_CONFIGURE_ENABLE= irc
JABBER_CONFIGURE_ENABLE=jabber
RSS_CONFIGURE_ENABLE= rss
LJ_CONFIGURE_ENABLE= lj
-GG_LIB_DEPENDS= libgadu.so:${PORTSDIR}/polish/ekg
+GG_LIB_DEPENDS= libgadu.so:${PORTSDIR}/polish/libgadu
GG_CONFIGURE_ENABLE= gg
GPGME_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
GPGME_CONFIGURE_OFF= --with-gpgme-prefix=/nonexistent
diff --git a/net/gq/Makefile b/net/gq/Makefile
index 7244c5ce2e92..28ff735e7911 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gq
PORTVERSION= 1.3.4
-PORTREVISION= 12
+PORTREVISION= 13
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}client/GQ%20Unstable/${PORTVERSION}
@@ -11,7 +11,7 @@ MASTER_SITES= SF/${PORTNAME}client/GQ%20Unstable/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK-based LDAP client
-LIB_DEPENDS= libgnome-keyring.so:${PORTSDIR}/security/gnome-keyring
+LIB_DEPENDS= libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
OPTIONS_DEFINE= DND CACHE
OPTIONS_DEFAULT= DND CACHE
diff --git a/net/vnc/Makefile b/net/vnc/Makefile
index eb1cb0f4e685..be4f7f5f3172 100644
--- a/net/vnc/Makefile
+++ b/net/vnc/Makefile
@@ -55,7 +55,7 @@ MAKE_ARGS= AR='ar rc'
.endif
RUN_DEPENDS+= xauth:${PORTSDIR}/x11/xauth \
- ${PREFIX}/lib/X11/fonts/misc/6x13-ISO8859-1.pcf.gz:${PORTSDIR}/x11-fonts/xorg-fonts-miscbitmaps \
+ xorg-fonts-miscbitmaps>0:${PORTSDIR}/x11-fonts/xorg-fonts-miscbitmaps \
${LOCALBASE}/lib/X11/fonts/misc/fonts.alias:${PORTSDIR}/x11-fonts/font-alias
EXTRA_PATCHES+= ${WRKSRC}/xc.patch \
diff --git a/print/hpijs/Makefile b/print/hpijs/Makefile
index 7f49ac0a8b51..f5f0ad4df9ff 100644
--- a/print/hpijs/Makefile
+++ b/print/hpijs/Makefile
@@ -39,7 +39,8 @@ PLIST_SUB+= FOOMATIC="@comment "
.endif
.if ${PORT_OPTIONS:MCUPS}
-LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-base
+BUILD_DEPENDS+= cups-base>0:${PORTSDIR}/print/cups-base
+RUN_DEPENDS+= cups-base>0:${PORTSDIR}/print/cups-base
CONFIGURE_ARGS+= --enable-cups-install
PLIST_SUB+= CUPS=""
.else
diff --git a/science/afni/Makefile b/science/afni/Makefile
index a69dd07082d5..8816b4e26f5a 100644
--- a/science/afni/Makefile
+++ b/science/afni/Makefile
@@ -28,7 +28,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libXm.so:${PORTSDIR}/x11-toolkits/open-motif \
libR.so:${PORTSDIR}/math/R \
libgsl.so:${PORTSDIR}/math/gsl \
- libnetcdf.so:${PORTSDIR}/science/netcdf-fortran
+ libnetcdff.so:${PORTSDIR}/science/netcdf-fortran
RUN_DEPENDS= cjpeg:${PORTSDIR}/graphics/jpeg \
mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
whirlgif:${PORTSDIR}/graphics/whirlgif \
diff --git a/security/gnome-gpg/Makefile b/security/gnome-gpg/Makefile
index 1474d4f8f7bb..d1baa96b392b 100644
--- a/security/gnome-gpg/Makefile
+++ b/security/gnome-gpg/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gnome-gpg
PORTVERSION= 0.5.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= security
MASTER_SITES= GNOME
@@ -12,7 +12,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Simple commandline wrapper around gpg for gnome-keyring
BUILD_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
-LIB_DEPENDS= libgnome-keyring.so:${PORTSDIR}/security/gnome-keyring
+LIB_DEPENDS= libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
RUN_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
USES= pkgconfig tar:bzip2
diff --git a/security/gnome-keyring-sharp/Makefile b/security/gnome-keyring-sharp/Makefile
index fdffe8594a9b..b1339978bc2a 100644
--- a/security/gnome-keyring-sharp/Makefile
+++ b/security/gnome-keyring-sharp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnome-keyring-sharp
PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://www.go-mono.com/archive/${PORTNAME}/
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Fully managed implementation of gnome-keyring
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-1.0.pc:${PORTSDIR}/devel/ndesk-dbus \
- ${LOCALBASE}/libdata/pkgconfig/gnome-keyring-1.pc:${PORTSDIR}/security/gnome-keyring
+ ${LOCALBASE}/libdata/pkgconfig/gnome-keyring-1.pc:${PORTSDIR}/security/libgnome-keyring
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
diff --git a/security/gpass/Makefile b/security/gpass/Makefile
index b9ebbb39839c..9ac264213c94 100644
--- a/security/gpass/Makefile
+++ b/security/gpass/Makefile
@@ -3,14 +3,14 @@
PORTNAME= gpass
PORTVERSION= 0.5.1
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= security gnome
MASTER_SITES= http://projects.netlab.jp/gpass/release/
MAINTAINER= ports@FreeBSD.org
COMMENT= Password manager for GNOME2
-LIB_DEPENDS= libmcrypt.so:${PORTSDIR}/security/mcrypt \
+LIB_DEPENDS= libmcrypt.so:${PORTSDIR}/security/libmcrypt \
libmhash.so:${PORTSDIR}/security/mhash
GNU_CONFIGURE= yes
diff --git a/security/w3af/Makefile b/security/w3af/Makefile
index cf3d33cd91de..8c1dc1983c9c 100644
--- a/security/w3af/Makefile
+++ b/security/w3af/Makefile
@@ -3,7 +3,7 @@
PORTNAME= w3af
DISTVERSION= 1.0-rc4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security python www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${DISTVERSION}
@@ -12,7 +12,6 @@ COMMENT= Web Application Attack and Audit Framework
LICENSE= GPLv2
-LIB_DEPENDS= libtidy.so:${PORTSDIR}/www/py-utidy
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=2.1:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:${PORTSDIR}/devel/py-simplejson \
${PYTHON_PKGNAMEPREFIX}openssl>=0:${PORTSDIR}/security/py-openssl \
diff --git a/textproc/docproj/Makefile b/textproc/docproj/Makefile
index 1e2580c4f2d1..272edad5aaf2 100644
--- a/textproc/docproj/Makefile
+++ b/textproc/docproj/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= links:${PORTSDIR}/www/links1 \
${LOCALBASE}/share/xml/dtd/xhtml/xhtml.soc:${PORTSDIR}/textproc/xhtml \
docbook-xsl-ns>=1.78.1_4:${PORTSDIR}/textproc/docbook-xsl-ns \
${LOCALBASE}/share/xsl/iso-schematron/xslt1/iso_schematron_skeleton_for_xslt1.xsl:${PORTSDIR}/textproc/iso-schematron-xslt \
- ${LOCALBASE}/share/xml/docbook/catalog:${PORTSDIR}/textproc/docbook \
+ docbook>0:${PORTSDIR}/textproc/docbook \
${LOCALBASE}/share/xml/xmlcharent/catalog:${PORTSDIR}/textproc/xmlcharent \
p5-XML-Parser>=2.41:${PORTSDIR}/textproc/p5-XML-Parser \
zip:${PORTSDIR}/archivers/zip
diff --git a/textproc/sdom/Makefile b/textproc/sdom/Makefile
index 854465376055..438d1625bf13 100644
--- a/textproc/sdom/Makefile
+++ b/textproc/sdom/Makefile
@@ -12,7 +12,7 @@ COMMENT= Implementation of the W3C DOM recommendation in Scheme
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= guile>=0:${PORTSDIR}/devel/guile-lib
+RUN_DEPENDS= guile-lib>=0:${PORTSDIR}/devel/guile-lib
NO_BUILD= yes
diff --git a/x11-toolkits/py-kivy/Makefile b/x11-toolkits/py-kivy/Makefile
index 878f1426a30c..6dfea94e22d7 100644
--- a/x11-toolkits/py-kivy/Makefile
+++ b/x11-toolkits/py-kivy/Makefile
@@ -60,10 +60,10 @@ PDF_BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
PDF_USE= TEX=texlive,pdftex:build,dvipsk:build
PDF_USES= gmake
PIL_DESC= Text and window rendering support via PIL
-PIL_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PIL:${PORTSDIR}/graphics/py-imaging
+PIL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}imaging>0:${PORTSDIR}/graphics/py-imaging
PYGAME_DESC= Window, text and image rendering support via PyGame
-PYGAME_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame:${PORTSDIR}/devel/py-game
-PYGLET_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyglet:${PORTSDIR}/graphics/py-pyglet
+PYGAME_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>0:${PORTSDIR}/devel/py-game
+PYGLET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyglet>0:${PORTSDIR}/graphics/py-pyglet
SDL2_DESC= Simple Direct Media Layer v2.0 support
SDL2_MAKE_ENV= USE_SDL=1
SDL2_USE= SDL=sdl2,ttf2,mixer2
diff --git a/x11-wm/wmakerconf/Makefile b/x11-wm/wmakerconf/Makefile
index 977495849310..3e6025f3c9b0 100644
--- a/x11-wm/wmakerconf/Makefile
+++ b/x11-wm/wmakerconf/Makefile
@@ -14,7 +14,7 @@ COMMENT= Configuration tool for Window Maker
LICENSE= GPLv2
-LIB_DEPENDS= libwraster.so:${PORTSDIR}/x11-wm/windowmaker
+LIB_DEPENDS= libWINGs.so:${PORTSDIR}/x11-wm/windowmaker
RUN_DEPENDS= rpm:${PORTSDIR}/archivers/rpm4
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/x11/hotwire-shell/Makefile b/x11/hotwire-shell/Makefile
index c8922853de29..fdad391bf976 100644
--- a/x11/hotwire-shell/Makefile
+++ b/x11/hotwire-shell/Makefile
@@ -12,7 +12,7 @@ DISTNAME= hotwire-${DISTVERSION}
MAINTAINER= ashish@FreeBSD.org
COMMENT= Hotwire is an object-oriented hypershell
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:${PORTSDIR}/devel/py-dbus \
${LOCALBASE}/libdata/pkgconfig/pycairo.pc:${PORTSDIR}/graphics/py-cairo \
${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \