aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/musepack/Makefile4
-rw-r--r--emulators/ia64sim/Makefile4
-rw-r--r--emulators/mips64emul/Makefile8
-rw-r--r--lang/gcc295/Makefile1
-rw-r--r--net-im/libmsn/Makefile8
-rw-r--r--net/libmsn/Makefile8
-rw-r--r--net/mDNSResponder/Makefile8
-rw-r--r--www/mod_jk2/Makefile4
-rw-r--r--www/roxen/Makefile4
9 files changed, 45 insertions, 4 deletions
diff --git a/audio/musepack/Makefile b/audio/musepack/Makefile
index 7f12ed3b5cd5..f1c6e7007214 100644
--- a/audio/musepack/Makefile
+++ b/audio/musepack/Makefile
@@ -26,6 +26,10 @@ WRKSRC= ${WRKDIR}/sv7
.include <bsd.port.pre.mk>
+.if ${ARCH} == alpha
+BROKEN= "Does not compile on alpha"
+.endif
+
.if ${ARCH} == i386
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
diff --git a/emulators/ia64sim/Makefile b/emulators/ia64sim/Makefile
index 7352a9a70945..53a267a9faf0 100644
--- a/emulators/ia64sim/Makefile
+++ b/emulators/ia64sim/Makefile
@@ -21,6 +21,10 @@ USE_ZIP= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
EXTRACT_BEFORE_ARGS= -qLa
WRKSRC= ${WRKDIR}/home/chuck/ia64simcc
USE_GMAKE= yes
diff --git a/emulators/mips64emul/Makefile b/emulators/mips64emul/Makefile
index b4577d958b3d..3dcaa5bfc38e 100644
--- a/emulators/mips64emul/Makefile
+++ b/emulators/mips64emul/Makefile
@@ -19,7 +19,13 @@ CONFIGURE_ARGS= --nox11
PLIST_FILES= bin/mips64emul
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mips64emul ${PREFIX}/bin/mips64emul
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/gcc295/Makefile b/lang/gcc295/Makefile
index 8021e038f168..7a52ce60f280 100644
--- a/lang/gcc295/Makefile
+++ b/lang/gcc295/Makefile
@@ -30,6 +30,7 @@ LATEST_LINK= gcc295
.include <bsd.port.pre.mk>
.if (${ARCH} == alpha)
+BROKEN= "Does not compile on alpha"
WITHOUT_CPU_CFLAGS= yes
.endif
diff --git a/net-im/libmsn/Makefile b/net-im/libmsn/Makefile
index b48b8f854f04..5c0fef7d9c15 100644
--- a/net-im/libmsn/Makefile
+++ b/net-im/libmsn/Makefile
@@ -22,4 +22,10 @@ USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/libmsn/Makefile b/net/libmsn/Makefile
index b48b8f854f04..5c0fef7d9c15 100644
--- a/net/libmsn/Makefile
+++ b/net/libmsn/Makefile
@@ -22,4 +22,10 @@ USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/mDNSResponder/Makefile b/net/mDNSResponder/Makefile
index 085c679b3c51..eed5b3c2e7e7 100644
--- a/net/mDNSResponder/Makefile
+++ b/net/mDNSResponder/Makefile
@@ -35,6 +35,12 @@ EXTRAMAN8= dnsextd.8 mDNSResponder.8
MAN8= mdnsd.8 ${EXTRAMAN8}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
pre-build:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/mDNSPosix/Makefile
@@ -49,4 +55,4 @@ post-install:
. endfor
. endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mod_jk2/Makefile b/www/mod_jk2/Makefile
index aa7d087b935d..44e7a9174e80 100644
--- a/www/mod_jk2/Makefile
+++ b/www/mod_jk2/Makefile
@@ -33,6 +33,10 @@ WRKSRC= ${WRKDIR}/jakarta-tomcat-connectors-jk2-${PORTVERSION}-src/jk/native2
WITH_APACHE2= yes
.endif
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
.if ${ARCH} == "sparc64" && !defined(WITH_APACHE2)
BROKEN= "Fails to link on sparc64"
.endif
diff --git a/www/roxen/Makefile b/www/roxen/Makefile
index 712746628bca..f4c314444243 100644
--- a/www/roxen/Makefile
+++ b/www/roxen/Makefile
@@ -37,6 +37,10 @@ post-install:
.include <bsd.port.pre.mk>
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
.if defined(PARALLEL_PACKAGE_BUILD) && ${OSVERSION} >= 500000
IGNORE= hang
.endif