aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/tcllib/Makefile12
-rw-r--r--devel/tcllib/distinfo2
-rw-r--r--devel/tcllib/pkg-descr23
-rw-r--r--devel/tcllib/pkg-message14
-rw-r--r--devel/tcllib/pkg-plist90
5 files changed, 91 insertions, 50 deletions
diff --git a/devel/tcllib/Makefile b/devel/tcllib/Makefile
index 280a09f53350..0a16af5e0d4b 100644
--- a/devel/tcllib/Makefile
+++ b/devel/tcllib/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tcllib
-PORTVERSION= 0.4
+PORTVERSION= 0.8
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= tcllib
@@ -19,14 +19,20 @@ NO_BUILD= YES
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-MANN= graph.n queue.n stack.n tree.n math.n ncgi.n pop3.n profiler.n html.n
+MANN= counter.n ftpd.n graph.n html.n javascript.n math.n \
+ ncgi.n nntp.n pop3.n profiler.n queue.n stack.n textutil.n \
+ tree.n uri.n
MANCOMPRESSED= no
do-install:
- ${TAR} -xz --exclude "${PORTNAME}${PORTVERSION}/[RI]*" \
+ ${TAR} -xpz --exclude "${PORTNAME}${PORTVERSION}/[RI]*" \
+ --exclude install.sh \
-C ${LOCALBASE}/lib -f ${DISTDIR}/${DISTFILES}
${MV} `find ${LOCALBASE}/lib/${PORTNAME}${PORTVERSION} \
-type f -name '*.n'` \
${LOCALBASE}/man/mann/
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/devel/tcllib/distinfo b/devel/tcllib/distinfo
index c38dff7f72f2..d7b04cd101ea 100644
--- a/devel/tcllib/distinfo
+++ b/devel/tcllib/distinfo
@@ -1 +1 @@
-MD5 (tcllib0.4.tar.gz) = efee3008c58bf481913a133fbee4ede0
+MD5 (tcllib0.8.tar.gz) = 0c198c010090b52043034a7a20179ef7
diff --git a/devel/tcllib/pkg-descr b/devel/tcllib/pkg-descr
index 51a45cec5417..74ffb6a37bc6 100644
--- a/devel/tcllib/pkg-descr
+++ b/devel/tcllib/pkg-descr
@@ -1,21 +1,24 @@
-Tcllib is a collection of utility modules for Tcl. These modules provide
-a wide variety of functionality, from implementations of standard data
-structures to implementations of common networking protocols. The intent
-is to collect commonly used function into a single library, which users
-can rely on to be available and stable.
+Tcllib is a collection of utility modules for Tcl. The intent is to
+collect commonly used function into a single library, which users can
+rely on to be available and stable.
-The latest version of tcllib, 0.4, includes the following modules:
+The latest version of tcllib, 0.8, includes the following modules:
base64 base64 encoder and decoder
cmdline command line argument processor similar to opt
- fileutil
- Tcl implementations of some standard Unix utilities
+ counter Event counters, interval timers, and histogram display
+ fileutil Tcl implementations of some standard Unix utilities
+ ftp FTP client library
+ ftpd FTP server
html HTML generation procedures. This uses ncgi.
+ javascript Javascript generation procedures.
math common math functions like min, max, and others
mime MIME encoder and decoder
ncgi new CGI processing module
+ nntp NNTP (news) client
pop3 POP3 protocol implementation
- profiler
- function level Tcl source code profiler
+ profiler function level Tcl source code profiler
struct Tcl implementations of common data structures
+ textutil Text processing utilities
+ uri URI parsing module
WWW: http://dev.scriptics.com/software/tcllib/
diff --git a/devel/tcllib/pkg-message b/devel/tcllib/pkg-message
index 06a5dc766238..6798dfdac6c6 100644
--- a/devel/tcllib/pkg-message
+++ b/devel/tcllib/pkg-message
@@ -1,11 +1,7 @@
-===========================================================================
- If you want users to be able to create their own web
- subdirectories off of the main web directory, you need to:
+ Some of the parts of tcllib already come with man pages,
+ which are properly installed. Some others -- with
+ plain-text/HTML pages which are installed next to the
+ corresponding TCL code. This is how the Scriptics/Ajuba
+ developers intended it to happen, apparently...
- a) add a group for www admins
- b) chgrp yourgroup ${PREFIX}/bin/makeweb ${PREFIX}/www
- c) chmod 2755 ${PREFIX}/bin/makeweb
- d) tell them about makeweb(1)
-
-===========================================================================
diff --git a/devel/tcllib/pkg-plist b/devel/tcllib/pkg-plist
index 4df506f411f8..f819b4768d72 100644
--- a/devel/tcllib/pkg-plist
+++ b/devel/tcllib/pkg-plist
@@ -1,45 +1,61 @@
lib/tcllib%%PORTVERSION%%/base64/base64.tcl
-lib/tcllib%%PORTVERSION%%/base64/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/base64/base64.test
+lib/tcllib%%PORTVERSION%%/base64/compare.tcl
+lib/tcllib%%PORTVERSION%%/base64/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/base64
lib/tcllib%%PORTVERSION%%/cmdline/cmdline.tcl
+lib/tcllib%%PORTVERSION%%/cmdline/cmdline.test
lib/tcllib%%PORTVERSION%%/cmdline/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/cmdline/typedCmdline.tcl
-lib/tcllib%%PORTVERSION%%/cmdline/cmdline.test
lib/tcllib%%PORTVERSION%%/cmdline/typedCmdline.test
@dirrm lib/tcllib%%PORTVERSION%%/cmdline
-lib/tcllib%%PORTVERSION%%/struct/graph.tcl
-lib/tcllib%%PORTVERSION%%/struct/pkgIndex.tcl
-lib/tcllib%%PORTVERSION%%/struct/queue.tcl
-lib/tcllib%%PORTVERSION%%/struct/stack.tcl
-lib/tcllib%%PORTVERSION%%/struct/struct.tcl
-lib/tcllib%%PORTVERSION%%/struct/tree.tcl
-lib/tcllib%%PORTVERSION%%/struct/graph.test
-lib/tcllib%%PORTVERSION%%/struct/queue.test
-lib/tcllib%%PORTVERSION%%/struct/stack.test
-lib/tcllib%%PORTVERSION%%/struct/tree.test
-@dirrm lib/tcllib%%PORTVERSION%%/struct
+lib/tcllib%%PORTVERSION%%/counter/counter.tcl
+lib/tcllib%%PORTVERSION%%/counter/counter.test
+lib/tcllib%%PORTVERSION%%/counter/pkgIndex.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/counter
lib/tcllib%%PORTVERSION%%/fileutil/fileutil.tcl
-lib/tcllib%%PORTVERSION%%/fileutil/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/fileutil/fileutil.test
+lib/tcllib%%PORTVERSION%%/fileutil/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/fileutil
+lib/tcllib%%PORTVERSION%%/ftp/ftp.tcl
+lib/tcllib%%PORTVERSION%%/ftp/ftpdemo.tcl
+lib/tcllib%%PORTVERSION%%/ftp/pkgIndex.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/ftp
+lib/tcllib%%PORTVERSION%%/ftpd/ftpd.tcl
+lib/tcllib%%PORTVERSION%%/ftpd/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/ftpd/rfc959.txt
+lib/tcllib%%PORTVERSION%%/ftpd/std9.txt
+@dirrm lib/tcllib%%PORTVERSION%%/ftpd
+lib/tcllib%%PORTVERSION%%/html/html.tcl
+lib/tcllib%%PORTVERSION%%/html/html.test
+lib/tcllib%%PORTVERSION%%/html/pkgIndex.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/html
+lib/tcllib%%PORTVERSION%%/javascript/javascript.tcl
+lib/tcllib%%PORTVERSION%%/javascript/pkgIndex.tcl
+@dirrm lib/tcllib%%PORTVERSION%%/javascript
+lib/tcllib%%PORTVERSION%%/license.terms
lib/tcllib%%PORTVERSION%%/math/math.tcl
-lib/tcllib%%PORTVERSION%%/math/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/math/math.test
+lib/tcllib%%PORTVERSION%%/math/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/math
-lib/tcllib%%PORTVERSION%%/mime/mime.tcl
-lib/tcllib%%PORTVERSION%%/mime/pkgIndex.tcl
-lib/tcllib%%PORTVERSION%%/mime/smtp.tcl
-lib/tcllib%%PORTVERSION%%/mime/mime.test
lib/tcllib%%PORTVERSION%%/mime/README.html
lib/tcllib%%PORTVERSION%%/mime/README.txt
lib/tcllib%%PORTVERSION%%/mime/README.xml
+lib/tcllib%%PORTVERSION%%/mime/mime.tcl
+lib/tcllib%%PORTVERSION%%/mime/mime.test
+lib/tcllib%%PORTVERSION%%/mime/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/mime/smtp.tcl
@dirrm lib/tcllib%%PORTVERSION%%/mime
lib/tcllib%%PORTVERSION%%/ncgi/formdata.txt
lib/tcllib%%PORTVERSION%%/ncgi/ncgi.tcl
-lib/tcllib%%PORTVERSION%%/ncgi/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/ncgi/ncgi.test
+lib/tcllib%%PORTVERSION%%/ncgi/pkgIndex.tcl
@dirrm lib/tcllib%%PORTVERSION%%/ncgi
+lib/tcllib%%PORTVERSION%%/nntp/nntp.tcl
+lib/tcllib%%PORTVERSION%%/nntp/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/nntp/rfc977.txt
+@dirrm lib/tcllib%%PORTVERSION%%/nntp
+lib/tcllib%%PORTVERSION%%/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/pop3/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/pop3/pop3.tcl
@dirrm lib/tcllib%%PORTVERSION%%/pop3
@@ -47,11 +63,31 @@ lib/tcllib%%PORTVERSION%%/profiler/pkgIndex.tcl
lib/tcllib%%PORTVERSION%%/profiler/profiler.tcl
lib/tcllib%%PORTVERSION%%/profiler/profiler.test
@dirrm lib/tcllib%%PORTVERSION%%/profiler
-lib/tcllib%%PORTVERSION%%/html/html.tcl
-lib/tcllib%%PORTVERSION%%/html/pkgIndex.tcl
-lib/tcllib%%PORTVERSION%%/html/html.test
-@dirrm lib/tcllib%%PORTVERSION%%/html
-lib/tcllib%%PORTVERSION%%/pkgIndex.tcl
-lib/tcllib%%PORTVERSION%%/install.sh
-lib/tcllib%%PORTVERSION%%/license.terms
+lib/tcllib%%PORTVERSION%%/struct/graph.tcl
+lib/tcllib%%PORTVERSION%%/struct/graph.test
+lib/tcllib%%PORTVERSION%%/struct/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/struct/queue.tcl
+lib/tcllib%%PORTVERSION%%/struct/queue.test
+lib/tcllib%%PORTVERSION%%/struct/stack.tcl
+lib/tcllib%%PORTVERSION%%/struct/stack.test
+lib/tcllib%%PORTVERSION%%/struct/struct.tcl
+lib/tcllib%%PORTVERSION%%/struct/tree.tcl
+lib/tcllib%%PORTVERSION%%/struct/tree.test
+@dirrm lib/tcllib%%PORTVERSION%%/struct
+lib/tcllib%%PORTVERSION%%/textutil/adjust.tcl
+lib/tcllib%%PORTVERSION%%/textutil/adjust.test
+lib/tcllib%%PORTVERSION%%/textutil/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/textutil/split.tcl
+lib/tcllib%%PORTVERSION%%/textutil/split.test
+lib/tcllib%%PORTVERSION%%/textutil/tabify.tcl
+lib/tcllib%%PORTVERSION%%/textutil/tabify.test
+lib/tcllib%%PORTVERSION%%/textutil/textutil.tcl
+lib/tcllib%%PORTVERSION%%/textutil/textutil.test
+lib/tcllib%%PORTVERSION%%/textutil/trim.tcl
+lib/tcllib%%PORTVERSION%%/textutil/trim.test
+@dirrm lib/tcllib%%PORTVERSION%%/textutil
+lib/tcllib%%PORTVERSION%%/uri/pkgIndex.tcl
+lib/tcllib%%PORTVERSION%%/uri/uri.tcl
+lib/tcllib%%PORTVERSION%%/uri/uri.test
+@dirrm lib/tcllib%%PORTVERSION%%/uri
@dirrm lib/tcllib%%PORTVERSION%%