aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/ncbi-toolkit/Makefile5
-rw-r--r--x11-toolkits/p5-Prima/Makefile4
2 files changed, 9 insertions, 0 deletions
diff --git a/biology/ncbi-toolkit/Makefile b/biology/ncbi-toolkit/Makefile
index c512edf7c9d8..643c83de3c40 100644
--- a/biology/ncbi-toolkit/Makefile
+++ b/biology/ncbi-toolkit/Makefile
@@ -51,6 +51,11 @@ MLINKS= blast.1 bl2seq.1 blast.1 blastall.1 blast.1 blastcl3.1 \
blast.1 blastpgp.1 blast.1 impala.1 blast.1 megablast.1 \
blast.1 seedtop.1
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' \
+ ${WRKSRC}/make/makedis.csh \
+ ${WRKSRC}/platform/freebsd.ncbi.mk
+
# the ncbi-toolkit provides a shell script to drive the build
# and we use it
diff --git a/x11-toolkits/p5-Prima/Makefile b/x11-toolkits/p5-Prima/Makefile
index 9ea0e028843b..9cbaad696c67 100644
--- a/x11-toolkits/p5-Prima/Makefile
+++ b/x11-toolkits/p5-Prima/Makefile
@@ -28,6 +28,10 @@ USE_XPM= 1
USE_XLIB= 1
USE_PERL5= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' \
+ ${WRKSRC}/Makefile.PL
+
post-configure:
@cd ${CONFIGURE_WRKSRC} && ${PERL5} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}