aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DMOZ-ParseRDF/Makefile20
-rw-r--r--databases/p5-DMOZ-ParseRDF/distinfo3
-rw-r--r--databases/p5-DMOZ-ParseRDF/pkg-descr7
-rw-r--r--databases/p5-DMOZ-ParseRDF/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 0946073645c3..9f45b48dbda0 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -250,6 +250,7 @@
SUBDIR += p5-DBIx-XML_RDB
SUBDIR += p5-DBM-Deep
SUBDIR += p5-DBZ_File
+ SUBDIR += p5-DMOZ-ParseRDF
SUBDIR += p5-DWH_File
SUBDIR += p5-Data-Page
SUBDIR += p5-Data-Pageset
diff --git a/databases/p5-DMOZ-ParseRDF/Makefile b/databases/p5-DMOZ-ParseRDF/Makefile
new file mode 100644
index 000000000000..402fd00bf769
--- /dev/null
+++ b/databases/p5-DMOZ-ParseRDF/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: databases/p5-DMOZ-ParseRDF
+# Date created: 04 August 2006
+# Whom: Hans Fredrik Nordhaug <hans@nordhaug.priv.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DMOZ-ParseRDF
+PORTVERSION= 0.14
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DMOZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hans@nordhaug.priv.no
+COMMENT= Parse the gigantic dmoz.org content file into smaller parts
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DMOZ-ParseRDF/distinfo b/databases/p5-DMOZ-ParseRDF/distinfo
new file mode 100644
index 000000000000..ba8d9e4ca3b2
--- /dev/null
+++ b/databases/p5-DMOZ-ParseRDF/distinfo
@@ -0,0 +1,3 @@
+MD5 (DMOZ-ParseRDF-0.14.tar.gz) = 46f6a39626e01a7514e50f26e5f09f17
+SHA256 (DMOZ-ParseRDF-0.14.tar.gz) = ba25829f8262fb1b406a3eaccc2ee6993b1d07e4b58c99c1aedace169fbc2397
+SIZE (DMOZ-ParseRDF-0.14.tar.gz) = 4715
diff --git a/databases/p5-DMOZ-ParseRDF/pkg-descr b/databases/p5-DMOZ-ParseRDF/pkg-descr
new file mode 100644
index 000000000000..ed41c88c9cae
--- /dev/null
+++ b/databases/p5-DMOZ-ParseRDF/pkg-descr
@@ -0,0 +1,7 @@
+DMOZ::ParseRDF is an object-oriented module for parsing DMOZ data into
+manageable sub-sections. As of January 8th 2004 the DMOZ content file is
+around 1.3GB in size. The data is free to download and can be used in your
+custom database but please make sure you read the license agreement at
+http://dmoz.org/license.html first.
+
+WWW: http://search.cpan.org/dist/DMOZ-ParseRDF
diff --git a/databases/p5-DMOZ-ParseRDF/pkg-plist b/databases/p5-DMOZ-ParseRDF/pkg-plist
new file mode 100644
index 000000000000..b90123fdcd4d
--- /dev/null
+++ b/databases/p5-DMOZ-ParseRDF/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/DMOZ/ParseRDF.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DMOZ/ParseRDF/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DMOZ/ParseRDF
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DMOZ
+@dirrmtry %%SITE_PERL%%/DMOZ