aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/kc/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/security/kc/Makefile b/security/kc/Makefile
index 385a2abee643..ca03346ff738 100644
--- a/security/kc/Makefile
+++ b/security/kc/Makefile
@@ -11,11 +11,12 @@ COMMENT= Console based password storing application
LICENSE= BSD
-USES= pkgconfig
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
- pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2 \
+ libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
+USES= pkgconfig
+
MAN1= kc.1
MANCOMPRESSED= yes
@@ -25,6 +26,9 @@ PLIST_FILES= bin/kc \
MAKE_ENV+= HAVE_PCRE=yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|pkg-config|${LOCALBASE}/bin/pkgconf|' ${WRKSRC}/Makefile
+
post-install:
${INSTALL} -d ${PREFIX}/share/kc
${INSTALL} ${WRKSRC}/pwsafe_to_kc.pl ${PREFIX}/share/kc/