aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/amide/Makefile70
-rw-r--r--graphics/amide/distinfo2
-rw-r--r--graphics/amide/files/patch-configure53
-rw-r--r--graphics/amide/files/patch-src-dcmtk_interface.cc115
-rw-r--r--graphics/amide/files/patch-src-mpeg_encode.c11
-rw-r--r--graphics/amide/files/patch-src-ui_common.c11
-rw-r--r--graphics/amide/pkg-descr5
-rw-r--r--graphics/amide/pkg-plist60
9 files changed, 328 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 1a923da9e06a..33ae92b65dc8 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -28,6 +28,7 @@
SUBDIR += allegrogl
SUBDIR += alpng
SUBDIR += amanith
+ SUBDIR += amide
SUBDIR += ampasCTL
SUBDIR += animorph
SUBDIR += aoi
diff --git a/graphics/amide/Makefile b/graphics/amide/Makefile
new file mode 100644
index 000000000000..eda9ee284c36
--- /dev/null
+++ b/graphics/amide/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: amide
+# Date created: 8 Feb 2011
+# Whom: Guido Falsi <mad@madpilot.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= amide
+PORTVERSION= 0.9.2
+CATEGORIES= graphics
+MASTER_SITES= SF
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mad@madpilot.net
+COMMENT= Medical Imaging Data Examiner
+
+LICENSE= GPLv2
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
+USE_GETTEXT= yes
+USE_GNOME= gtk20 libgnomecanvas libgnomeui libxml2
+INSTALLS_OMF= yes
+
+MAN1= amide.1
+
+OPTIONS= XMEDCON "Use xmedcon" on \
+ DCMTK "Use dcmtk" on \
+ FFMPEG "Use ffmpeg" on \
+ GSL "Use gsl" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_XMEDCON)
+LIB_DEPENDS+= mdc.2:${PORTSDIR}/graphics/xmedcon
+CONFIGUE_ARGS+= --enable-libmdc
+.else
+CONFIGUE_ARGS+= --disable-libmdc
+.endif
+
+.if !defined(WITHOUT_DCMTK)
+LIB_DEPENDS+= dcmdata.3:${PORTSDIR}/devel/dcmtk
+CONFIGUE_ARGS+= --enable-libdcmdata
+.else
+CONFIGUE_ARGS+= --disable-libdcmdata
+.endif
+
+.if !defined(WITHOUT_FFMPEG)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+CONFIGUE_ARGS+= --enable-ffmpeg
+.else
+CONFIGUE_ARGS+= --disable-ffmpeg
+.endif
+
+.if !defined(WITHOUT_GSL)
+LIB_DEPENDS+= gsl.15:${PORTSDIR}/math/gsl
+CONFIGUE_ARGS+= --enable-libgsl
+.else
+CONFIGUE_ARGS+= --disable-libgsl
+.endif
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS='@comment '
+.else
+PLIST_SUB+= NLS=''
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/amide/distinfo b/graphics/amide/distinfo
new file mode 100644
index 000000000000..ceb26aa09f7c
--- /dev/null
+++ b/graphics/amide/distinfo
@@ -0,0 +1,2 @@
+SHA256 (amide-0.9.2.tgz) = bbe230b7aef3c65ef2014d561a09d97b96e50ec4f1a09c16b4de751974ff01be
+SIZE (amide-0.9.2.tgz) = 1476952
diff --git a/graphics/amide/files/patch-configure b/graphics/amide/files/patch-configure
new file mode 100644
index 000000000000..cdf7955e304e
--- /dev/null
+++ b/graphics/amide/files/patch-configure
@@ -0,0 +1,53 @@
+--- configure.orig 2009-12-09 07:35:12.000000000 +0100
++++ configure 2011-02-10 18:25:18.165872253 +0100
+@@ -17889,13 +17889,13 @@
+ DATADIRNAME=share
+ else
+ CATOBJEXT=.mo
+- DATADIRNAME=lib
++ DATADIRNAME=share
+ fi
+
+ ;;
+ *)
+ CATOBJEXT=.mo
+- DATADIRNAME=lib
++ DATADIRNAME=share
+ ;;
+ esac
+ fi
+@@ -18684,12 +18684,12 @@
+ if test "x$ac_cv_func_bind_textdomain_codeset" = x""yes; then
+ DATADIRNAME=share
+ else
+- DATADIRNAME=lib
++ DATADIRNAME=share
+ fi
+
+ ;;
+ *)
+- DATADIRNAME=lib
++ DATADIRNAME=share
+ ;;
+ esac
+ fi
+@@ -19625,7 +19625,7 @@
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-ldcmdata -lofstd -lz -L/usr/local/dicom/lib -L/sw/lib $THREAD_LIBS $LIBS"
++LIBS="-ldcmdata -lofstd -loflog -lz -L/usr/local/lib $THREAD_LIBS $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -20391,8 +20391,8 @@
+
+ if (test $enable_libdcmdata = yes) && (test $FOUND_DCMDATA = yes); then
+ echo "Compiling with DCMTK support for DICOM files"
+- AMIDE_LIBDCMDATA_LIBS="-L/usr/local/dicom/lib -ldcmdata -lofstd -lz $THREAD_LIBS"
+- AMIDE_LIBDCMDATA_CFLAGS="-I/usr/local/dicom/include/dcmtk/dcmdata -I/usr/local/dicom/include/dcmtk/ofstd -I/usr/local/dicom/include -I/usr/include/dcmtk/dcmdata -I/usr/local/include/dcmtk/ofstd -I/sw/include/dcmtk/dcmdata -I/sw/include/dcmtk/ofstd -I/sw/include/dcmtk"
++ AMIDE_LIBDCMDATA_LIBS="-L/usr/local/lib -ldcmdata -lofstd -loflog -lz $THREAD_LIBS"
++ AMIDE_LIBDCMDATA_CFLAGS="-I/usr/local/include"
+
+
+
diff --git a/graphics/amide/files/patch-src-dcmtk_interface.cc b/graphics/amide/files/patch-src-dcmtk_interface.cc
new file mode 100644
index 000000000000..0d87608c69bc
--- /dev/null
+++ b/graphics/amide/files/patch-src-dcmtk_interface.cc
@@ -0,0 +1,115 @@
+--- src/dcmtk_interface.cc.orig 2009-12-14 05:53:11.000000000 +0100
++++ src/dcmtk_interface.cc 2011-02-11 10:59:18.612565854 +0100
+@@ -32,7 +32,7 @@
+ #include <unistd.h>
+ #endif
+ #include "dcmtk_interface.h"
+-#include "dcddirif.h" /* for class DicomDirInterface */
++#include "dcmtk/dcmdata/dcddirif.h" /* for class DicomDirInterface */
+ #include <dirent.h>
+ #include <sys/stat.h>
+ #include "amitk_data_set_DOUBLE_0D_SCALING.h"
+@@ -44,7 +44,8 @@
+ #undef PACKAGE_STRING
+ #undef PACKAGE_TARNAME
+ #undef PACKAGE_VERSION
+-#include <dctk.h>
++#include "amide_config.h"
++#include <dcmtk/dcmdata/dctk.h>
+ //#include <dcostrmb.h>
+ const gchar * dcmtk_version = OFFIS_DCMTK_VERSION;
+
+@@ -188,7 +189,7 @@
+ }
+ dim.y = return_uint16;
+
+- if (dcm_dataset->findAndGetUint16(DCM_Planes, return_uint16).bad())
++ if (dcm_dataset->findAndGetUint16(DCM_RETIRED_Planes, return_uint16).bad())
+ dim.z = 1;
+ else
+ dim.z = return_uint16;
+@@ -352,7 +353,7 @@
+ if (dcm_dataset->findAndGetString(DCM_PatientID, return_str, OFTrue).good())
+ amitk_data_set_set_subject_id(ds, return_str);
+
+- if (dcm_dataset->findAndGetFloat64(DCM_PatientsWeight, return_float64).good()) {
++ if (dcm_dataset->findAndGetFloat64(DCM_PatientWeight, return_float64).good()) {
+ amitk_data_set_set_subject_weight(ds, return_float64);
+ amitk_data_set_set_displayed_weight_unit(ds, AMITK_WEIGHT_UNIT_KILOGRAM);
+ }
+@@ -429,7 +430,7 @@
+ }
+ }
+
+- if (dcm_dataset->findAndGetString(DCM_PatientsName, return_str, OFTrue).good()) {
++ if (dcm_dataset->findAndGetString(DCM_PatientName, return_str, OFTrue).good()) {
+ if (AMITK_OBJECT_NAME(ds) == NULL)
+ amitk_object_set_name(AMITK_OBJECT(ds), return_str);
+ amitk_data_set_set_subject_name(ds, return_str);
+@@ -495,7 +496,7 @@
+ }
+ }
+
+- if (dcm_dataset->findAndGetString(DCM_PatientsBirthDate, return_str, OFTrue).good())
++ if (dcm_dataset->findAndGetString(DCM_PatientBirthDate, return_str, OFTrue).good())
+ amitk_data_set_set_subject_dob(ds, return_str);
+
+ /* because of how the dicom coordinates are setup, after reading in the patient slices,
+@@ -1257,7 +1258,7 @@
+ if (return_str != NULL)
+ info->patient_id = g_strdup(return_str);
+
+- dcm_dataset->findAndGetString(DCM_PatientsName, return_str, OFTrue);
++ dcm_dataset->findAndGetString(DCM_PatientName, return_str, OFTrue);
+ if (return_str != NULL)
+ info->patient_name = g_strdup(return_str);
+
+@@ -1537,7 +1538,7 @@
+
+ /* go through the whole directory */
+ while ((patient_record = dcm_root_record->nextSub(patient_record)) != NULL) {
+- patient_record->findAndGetString(DCM_PatientsName, record_name[0]);
++ patient_record->findAndGetString(DCM_PatientName, record_name[0]);
+ patient_record->findAndGetString(DCM_PatientID, patient_id, OFTrue);
+
+
+@@ -1802,8 +1803,9 @@
+ }
+
+ #ifdef AMIDE_DEBUG
+- dcm_dir.enableVerboseMode(TRUE);
+- dcm_dir.setLogStream(&ofConsole);
++// These are not defined in the latest dcmtk and could not find substitutes.
++// dcm_dir.enableVerboseMode(TRUE);
++// dcm_dir.setLogStream(&ofConsole);
+ #endif
+
+ /* create the DICOMDIR, unless already made in which case we'll append to it */
+@@ -1905,15 +1907,15 @@
+
+ /* other stuff */
+ if (AMITK_DATA_SET_SUBJECT_NAME(ds) != NULL)
+- insert_str(dcm_ds,DCM_PatientsName, AMITK_DATA_SET_SUBJECT_NAME(ds));
++ insert_str(dcm_ds,DCM_PatientName, AMITK_DATA_SET_SUBJECT_NAME(ds));
+ if (AMITK_DATA_SET_SUBJECT_ID(ds) != NULL)
+ insert_str(dcm_ds,DCM_PatientID, AMITK_DATA_SET_SUBJECT_ID(ds));
+ if (AMITK_DATA_SET_SUBJECT_DOB(ds) != NULL)
+- insert_str(dcm_ds,DCM_PatientsBirthDate, AMITK_DATA_SET_SUBJECT_DOB(ds));
++ insert_str(dcm_ds,DCM_PatientBirthDate, AMITK_DATA_SET_SUBJECT_DOB(ds));
+ if (AMITK_OBJECT_NAME(ds) != NULL)
+ insert_str(dcm_ds,DCM_StudyDescription, AMITK_OBJECT_NAME(ds));
+ insert_double(dcm_ds,DCM_RadionuclideTotalDose, AMITK_DATA_SET_INJECTED_DOSE(ds));
+- insert_double(dcm_ds,DCM_PatientsWeight, AMITK_DATA_SET_SUBJECT_WEIGHT(ds));
++ insert_double(dcm_ds,DCM_PatientWeight, AMITK_DATA_SET_SUBJECT_WEIGHT(ds));
+
+ switch(AMITK_DATA_SET_SUBJECT_ORIENTATION(ds)) {
+ case AMITK_SUBJECT_ORIENTATION_SUPINE_HEADFIRST:
+@@ -1949,7 +1951,7 @@
+ case AMITK_MODALITY_PET:
+ insert_str(dcm_ds,DCM_Modality, "PT");
+ dcm_metainfo->putAndInsertString(DCM_MediaStorageSOPClassUID,
+- UID_PETImageStorage);
++ UID_EnhancedPETImageStorage);
+ break;
+ case AMITK_MODALITY_SPECT:
+ insert_str(dcm_ds,DCM_Modality, "ST");
diff --git a/graphics/amide/files/patch-src-mpeg_encode.c b/graphics/amide/files/patch-src-mpeg_encode.c
new file mode 100644
index 000000000000..459bc2b90310
--- /dev/null
+++ b/graphics/amide/files/patch-src-mpeg_encode.c
@@ -0,0 +1,11 @@
+--- src/mpeg_encode.c.orig 2009-11-16 07:55:52.000000000 +0100
++++ src/mpeg_encode.c 2011-02-08 16:18:47.640994869 +0100
+@@ -141,7 +141,7 @@
+ /* -------------------------------------------------------- */
+ #ifdef AMIDE_FFMPEG_SUPPORT
+
+-#include <ffmpeg/libavcodec/avcodec.h>
++#include <libavcodec/avcodec.h>
+
+
+ typedef struct {
diff --git a/graphics/amide/files/patch-src-ui_common.c b/graphics/amide/files/patch-src-ui_common.c
new file mode 100644
index 000000000000..af9ac8ccae24
--- /dev/null
+++ b/graphics/amide/files/patch-src-ui_common.c
@@ -0,0 +1,11 @@
+--- src/ui_common.c.orig 2009-11-16 06:00:11.000000000 +0100
++++ src/ui_common.c 2011-02-08 16:21:18.283127798 +0100
+@@ -46,7 +46,7 @@
+ #include <medcon.h>
+ #endif
+ #ifdef AMIDE_FFMPEG_SUPPORT
+-#include <ffmpeg/libavcodec/avcodec.h>
++#include <libavcodec/avcodec.h>
+ #endif
+ #ifdef AMIDE_LIBFAME_SUPPORT
+ #include <fame_version.h>
diff --git a/graphics/amide/pkg-descr b/graphics/amide/pkg-descr
new file mode 100644
index 000000000000..e93cdd546fb6
--- /dev/null
+++ b/graphics/amide/pkg-descr
@@ -0,0 +1,5 @@
+AMIDE is a competely free tool for viewing, analyzing, and registering
+volumetric medical imaging data sets. It's been written on top of GTK+, and runs
+on any system that supports this toolkit.
+
+WWW: http://amide.sourceforge.net
diff --git a/graphics/amide/pkg-plist b/graphics/amide/pkg-plist
new file mode 100644
index 000000000000..e967f4b89096
--- /dev/null
+++ b/graphics/amide/pkg-plist
@@ -0,0 +1,60 @@
+bin/amide
+share/applications/amide.desktop
+share/gnome/help/amide/C/amide.xml
+share/gnome/help/amide/C/figures/amide_main_window.png
+share/gnome/help/amide/C/figures/study_tree.png
+share/gnome/help/amide/C/legal.xml
+share/gnome/help/amide/es/amide.xml
+share/gnome/help/amide/es/figures/amide_main_window.png
+share/gnome/help/amide/es/figures/study_tree.png
+share/gnome/help/amide/es/legal.xml
+share/gtk-doc/html/amitk/AmitkWidgets.html
+share/gtk-doc/html/amitk/SpaceObjects.html
+share/gtk-doc/html/amitk/amitk-AmitkCanvas.html
+share/gtk-doc/html/amitk/amitk-AmitkColorTableMenu.html
+share/gtk-doc/html/amitk/amitk-AmitkDataSet.html
+share/gtk-doc/html/amitk/amitk-AmitkFiducialMark.html
+share/gtk-doc/html/amitk/amitk-AmitkLineProfile.html
+share/gtk-doc/html/amitk/amitk-AmitkObject.html
+share/gtk-doc/html/amitk/amitk-AmitkObjectDialog.html
+share/gtk-doc/html/amitk/amitk-AmitkProgressDialog.html
+share/gtk-doc/html/amitk/amitk-AmitkRawData.html
+share/gtk-doc/html/amitk/amitk-AmitkRoi.html
+share/gtk-doc/html/amitk/amitk-AmitkSpace.html
+share/gtk-doc/html/amitk/amitk-AmitkSpaceEdit.html
+share/gtk-doc/html/amitk/amitk-AmitkStudy.html
+share/gtk-doc/html/amitk/amitk-AmitkThresholdsDialog.html
+share/gtk-doc/html/amitk/amitk-AmitkTreeView.html
+share/gtk-doc/html/amitk/amitk-AmitkVolume.html
+share/gtk-doc/html/amitk/amitk-amitk-canvas-object.html
+share/gtk-doc/html/amitk/amitk-amitk-color-table.html
+share/gtk-doc/html/amitk/amitk-amitk-common.html
+share/gtk-doc/html/amitk/amitk-amitk-filter.html
+share/gtk-doc/html/amitk/amitk-amitk-point.html
+share/gtk-doc/html/amitk/amitk-amitk-type.html
+share/gtk-doc/html/amitk/amitk-theory.html
+share/gtk-doc/html/amitk/amitk.devhelp
+share/gtk-doc/html/amitk/amitk.devhelp2
+share/gtk-doc/html/amitk/amitk_base.html
+share/gtk-doc/html/amitk/amitk_intro.html
+share/gtk-doc/html/amitk/amitk_objects.html
+share/gtk-doc/html/amitk/ch01.html
+share/gtk-doc/html/amitk/home.png
+share/gtk-doc/html/amitk/index.html
+share/gtk-doc/html/amitk/index.sgml
+share/gtk-doc/html/amitk/left.png
+share/gtk-doc/html/amitk/right.png
+share/gtk-doc/html/amitk/style.css
+share/gtk-doc/html/amitk/up.png
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/amide.mo
+share/omf/amide/amide-C.omf
+share/omf/amide/amide-es.omf
+share/pixmaps/amide_logo.png
+share/pixmaps/amide_file_logo.png
+@dirrm share/gtk-doc/html/amitk
+@dirrm share/gnome/help/amide/es/figures
+@dirrm share/gnome/help/amide/es
+@dirrm share/gnome/help/amide/C/figures
+@dirrm share/gnome/help/amide/C
+@dirrm share/gnome/help/amide
+@dirrm share/omf/amide