aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/git/Makefile2
-rw-r--r--devel/obby/Makefile15
-rw-r--r--editors/gobby/Makefile1
-rw-r--r--games/nethack34/Makefile2
-rw-r--r--math/libtommath/Makefile1
-rw-r--r--math/tomsfastmath/Makefile1
-rw-r--r--net-im/pork/Makefile1
-rw-r--r--net-mgmt/isic/Makefile1
-rw-r--r--net/bittwist/Makefile1
-rw-r--r--net/daemonlogger/Makefile1
-rw-r--r--net/honeyd/Makefile1
-rw-r--r--net/httpry/Makefile1
-rw-r--r--net/libpcap/Makefile1
-rw-r--r--net/net6/Makefile1
-rw-r--r--net/ntop/Makefile1
-rw-r--r--net/pktanon/Makefile1
-rw-r--r--net/silc-client/Makefile1
-rw-r--r--net/silc-server/Makefile1
-rw-r--r--net/sobby/Makefile1
-rw-r--r--net/tcpdump/Makefile1
-rw-r--r--net/tftpgrab/Makefile1
-rw-r--r--security/libtomcrypt/Makefile1
-rw-r--r--sysutils/cdargs/Makefile1
-rw-r--r--www/tinyproxy/Makefile1
-rw-r--r--x11-clocks/xdaliclock/Makefile1
-rw-r--r--x11-wm/selectwm/Makefile1
-rw-r--r--x11/keynav/Makefile1
-rw-r--r--x11/xdotool/Makefile1
28 files changed, 37 insertions, 7 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index d5a94cd7b610..ee64a756d555 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -25,6 +25,8 @@ RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
${SITE_PERL}/Net/SMTP/SSL.pm:${PORTSDIR}/mail/p5-Net-SMTP-SSL
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+MAKE_JOBS_SAFE= yes
+
MAN1= git.1 \
git-add.1 \
git-am.1 \
diff --git a/devel/obby/Makefile b/devel/obby/Makefile
index 41dc1edec22a..f99c2cea5677 100644
--- a/devel/obby/Makefile
+++ b/devel/obby/Makefile
@@ -17,17 +17,18 @@ COMMENT= A library for synced document buffers
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
net6:${PORTSDIR}/net/net6
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-howl
-USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-howl
+USE_LDCONFIG= yes
.if !defined(WITHOUT_NLS)
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
diff --git a/editors/gobby/Makefile b/editors/gobby/Makefile
index 41a8c289f93a..c5ff25aa4104 100644
--- a/editors/gobby/Makefile
+++ b/editors/gobby/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= xml\\+\\+-2.6.2:${PORTSDIR}/textproc/libxml++26 \
net6-1.3:${PORTSDIR}/net/net6 \
obby-0.4:${PORTSDIR}/devel/obby
+MAKE_JOBS_SAFE= yes
USE_XORG= x11
GNU_CONFIGURE= yes
USE_GNOME= gnomehack pkgconfig gtksourceview2
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index 5e897e80b88b..338f696345e9 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -19,6 +19,7 @@ COMMENT= A dungeon explorin', slashin', hackin' game
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKE_JOBS_SAFE= yes
USE_GMAKE= yes
MAKE_ENV= GRAPHICS="${GRAPHICS}"
PLIST_SUB= HACKNAME="${HACKNAME}" \
@@ -37,6 +38,7 @@ USE_XORG= xaw xpm
GRAPHICS= X11_GRAPHICS
.else
.if ${PKGNAMESUFFIX} == "-gnome"
+MAKE_JOBS_UNSAFE= yes
CATEGORIES= games gnome
USE_GNOME= gnomelibs
MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
index fbf83bc57a2c..fbfd43c66e00 100644
--- a/math/libtommath/Makefile
+++ b/math/libtommath/Makefile
@@ -20,6 +20,7 @@ MAKEFILE= makefile
USE_BZIP2= yes
USE_GMAKE= yes
ALL_TARGET= default
+MAKE_JOBS_SAFE= yes
PLIST_FILES= include/tommath.h include/tommath_class.h \
include/tommath_superclass.h lib/libtommath.a
diff --git a/math/tomsfastmath/Makefile b/math/tomsfastmath/Makefile
index 811d3a6a8db3..f560b0ec447d 100644
--- a/math/tomsfastmath/Makefile
+++ b/math/tomsfastmath/Makefile
@@ -22,6 +22,7 @@ MAKEFILE= makefile
USE_BZIP2= yes
USE_GMAKE= yes
ALL_TARGET= default
+MAKE_JOBS_SAFE= yes
PLIST_FILES= include/tfm.h lib/libtfm.a
diff --git a/net-im/pork/Makefile b/net-im/pork/Makefile
index e5cf6a1f3b72..f02069941113 100644
--- a/net-im/pork/Makefile
+++ b/net-im/pork/Makefile
@@ -18,6 +18,7 @@ USE_PERL5= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
post-patch:
@${REINPLACE_CMD} -e 's/^inline //' ${WRKSRC}/src/*.h
diff --git a/net-mgmt/isic/Makefile b/net-mgmt/isic/Makefile
index 5a78da825d25..7fbf61733cc6 100644
--- a/net-mgmt/isic/Makefile
+++ b/net-mgmt/isic/Makefile
@@ -19,6 +19,7 @@ COMMENT= IP Stack Integrity Checker
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN1= isic.1
diff --git a/net/bittwist/Makefile b/net/bittwist/Makefile
index e7c805745f68..e2d4ab093136 100644
--- a/net/bittwist/Makefile
+++ b/net/bittwist/Makefile
@@ -16,6 +16,7 @@ COMMENT= Libpcap-based Ethernet packet generator, with PCAP editor
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}"
+MAKE_JOBS_SAFE= yes
MAN1= bittwist.1 bittwistb.1 bittwiste.1
PLIST_FILES= bin/bittwist bin/bittwistb bin/bittwiste
diff --git a/net/daemonlogger/Makefile b/net/daemonlogger/Makefile
index deb916e2cbe7..46a262d328a0 100644
--- a/net/daemonlogger/Makefile
+++ b/net/daemonlogger/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
GNU_CONFIGURE= yes
USE_RC_SUBR= daemonlogger.sh
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/daemonlogger
diff --git a/net/honeyd/Makefile b/net/honeyd/Makefile
index 5ff1760a1cf6..997185498bca 100644
--- a/net/honeyd/Makefile
+++ b/net/honeyd/Makefile
@@ -23,6 +23,7 @@ USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-libdnet=${LOCALBASE} \
--with-libevent=${LOCALBASE}
+MAKE_JOBS_SAFE= yes
.if defined(WITH_PYTHON)
USE_PYTHON= 2.4
diff --git a/net/httpry/Makefile b/net/httpry/Makefile
index 32f50c310c15..745bfe066aab 100644
--- a/net/httpry/Makefile
+++ b/net/httpry/Makefile
@@ -16,6 +16,7 @@ COMMENT= Packet sniffer designed for displaying and logging HTTP traffic
MAN1= httpry.1
USE_RC_SUBR= httpry
+MAKE_JOBS_SAFE= yes
OPTIONS= EXTRASCRIPTS "Install additional scripts" Off
diff --git a/net/libpcap/Makefile b/net/libpcap/Makefile
index 55595ee0952f..dbc4e62fd473 100644
--- a/net/libpcap/Makefile
+++ b/net/libpcap/Makefile
@@ -16,6 +16,7 @@ COMMENT= Ubiquitous network traffic capture library
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BISON= build
diff --git a/net/net6/Makefile b/net/net6/Makefile
index d51f42754b6b..c11ef6c634fc 100644
--- a/net/net6/Makefile
+++ b/net/net6/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack
+MAKE_JOBS_SAFE= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index eb01c00a2fa6..6d1a21991294 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -23,6 +23,7 @@ RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
DBDIR?= /var/db
+MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= libtool:15 automake:19 autoconf:262
USE_GNOME= libxml2
USE_GMAKE= yes
diff --git a/net/pktanon/Makefile b/net/pktanon/Makefile
index 098030fa8744..61446032d148 100644
--- a/net/pktanon/Makefile
+++ b/net/pktanon/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost \
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+MAKE_JOBS_SAFE= yes
post-install:
${MKDIR} ${DATADIR}/profiles
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index 1b165c69d1de..3753c1f377ee 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -30,6 +30,7 @@ COMMENT= Secure Internet Live Conferencing (SILC) network client
CONFLICTS= silc-toolkit-1.1.* silc-irssi-plugin-1.1.*
+MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= glib12
diff --git a/net/silc-server/Makefile b/net/silc-server/Makefile
index 943c76920018..b637d3285d73 100644
--- a/net/silc-server/Makefile
+++ b/net/silc-server/Makefile
@@ -30,6 +30,7 @@ COMMENT= Secure Internet Live Conferencing (SILC) network server
LIB_DEPENDS= silc-1.1:${PORTSDIR}/devel/silc-toolkit
+MAKE_JOBS_SAFE= yes
SUB_FILES= pkg-message pkg-deinstall
USE_RC_SUBR= silcd
USE_BZIP2= yes
diff --git a/net/sobby/Makefile b/net/sobby/Makefile
index 3db2f9d448ad..665e697fe443 100644
--- a/net/sobby/Makefile
+++ b/net/sobby/Makefile
@@ -25,6 +25,7 @@ MANCOMPRESSED= no
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/sobby
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index f995d31b465d..f45f40a8ff2e 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= pcap.3:${PORTSDIR}/net/libpcap \
GNU_CONFIGURE= yes
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
# Compilation Options
#
diff --git a/net/tftpgrab/Makefile b/net/tftpgrab/Makefile
index 6e1038918aa1..f8092a1d30b6 100644
--- a/net/tftpgrab/Makefile
+++ b/net/tftpgrab/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= wxs@FreeBSD.org
COMMENT= TFTP stream extractor
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/tftpgrab
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index 9dfad9b8f6e5..4c7da56b64d6 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -22,6 +22,7 @@ MAKE_ARGS= DESTDIR="${PREFIX}" LIBPATH="/lib" INCPATH="/include" \
USE_BZIP2= yes
USE_GMAKE= yes
ALL_TARGET= library
+MAKE_JOBS_SAFE= yes
CFLAGS+= -I${PREFIX}/include
diff --git a/sysutils/cdargs/Makefile b/sysutils/cdargs/Makefile
index ab59e9581096..498cdcf1876a 100644
--- a/sysutils/cdargs/Makefile
+++ b/sysutils/cdargs/Makefile
@@ -16,6 +16,7 @@ COMMENT= Navigate the filesystem using a menu interface or a bookmark system
GNU_CONFIGURE= yes
CFLAGS+= -DHAVE_DECL_GETOPT
+MAKE_JOBS_SAFE= yes
MAN1= cdargs.1
diff --git a/www/tinyproxy/Makefile b/www/tinyproxy/Makefile
index 238990a5fa02..935a14602160 100644
--- a/www/tinyproxy/Makefile
+++ b/www/tinyproxy/Makefile
@@ -21,6 +21,7 @@ USE_GMAKE= yes
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin \
--with-config=${PREFIX}/etc/tinyproxy.conf \
--program-transform-name=""
+MAKE_JOBS_SAFE= yes
MAN8= tinyproxy.8
diff --git a/x11-clocks/xdaliclock/Makefile b/x11-clocks/xdaliclock/Makefile
index eb9f68d26907..487e90225502 100644
--- a/x11-clocks/xdaliclock/Makefile
+++ b/x11-clocks/xdaliclock/Makefile
@@ -21,5 +21,6 @@ GNU_CONFIGURE= yes
USE_XORG= xt sm ice xext x11
MAN1= xdaliclock.1
PLIST_FILES= bin/xdaliclock
+MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/x11-wm/selectwm/Makefile b/x11-wm/selectwm/Makefile
index d2c8c1f4b444..d58670f2c506 100644
--- a/x11-wm/selectwm/Makefile
+++ b/x11-wm/selectwm/Makefile
@@ -19,6 +19,7 @@ MAN1= selectwm.1
USE_BZIP2= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/selectwm share/locale/fr/LC_MESSAGES/selectwm.mo
diff --git a/x11/keynav/Makefile b/x11/keynav/Makefile
index 09c2a50f99e1..b99c13cda5f4 100644
--- a/x11/keynav/Makefile
+++ b/x11/keynav/Makefile
@@ -19,6 +19,7 @@ ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/keynav
PORTEXAMPLES= keynavrc
+MAKE_JOBS_SAFE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/keynav ${PREFIX}/bin
diff --git a/x11/xdotool/Makefile b/x11/xdotool/Makefile
index 14466d639d9e..c79ea94fbcc7 100644
--- a/x11/xdotool/Makefile
+++ b/x11/xdotool/Makefile
@@ -18,6 +18,7 @@ USE_XORG= x11 xtst
ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/xdotool
+MAKE_JOBS_SAFE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xdotool ${PREFIX}/bin