aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/ocsinventory-agent/Makefile8
-rw-r--r--net-mgmt/ocsinventory-agent/distinfo1
-rw-r--r--net-mgmt/ocsinventory-agent/files/patch-Makefile.PL12
-rw-r--r--net-mgmt/ocsinventory-agent/files/pkg-message.in12
-rw-r--r--net-mgmt/ocsinventory-agent/pkg-plist79
5 files changed, 93 insertions, 19 deletions
diff --git a/net-mgmt/ocsinventory-agent/Makefile b/net-mgmt/ocsinventory-agent/Makefile
index 30ce63042f63..55245eed09eb 100644
--- a/net-mgmt/ocsinventory-agent/Makefile
+++ b/net-mgmt/ocsinventory-agent/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Ocsinventory
PORTVERSION= 1.1.2.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://launchpad.net/ocsinventory-unix-agent/stable-1.1.2/ocsinventory-unix-agent-${PORTVERSION}/+download/
@@ -27,8 +28,13 @@ FETCH_ARGS=
LICENSE= GPLv2
USE_PERL5= yes
PERL_CONFIGURE= yes
-IS_INTERACTIVE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAN1= ocsinventory-agent.1
+MAN3= Ocsinventory::Agent::XML::Inventory.3
+SUB_FILES= pkg-message
+SUB_LIST= SITE_PERL=${SITE_PERL}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net-mgmt/ocsinventory-agent/distinfo b/net-mgmt/ocsinventory-agent/distinfo
index e815a35f0847..693eacfb89a5 100644
--- a/net-mgmt/ocsinventory-agent/distinfo
+++ b/net-mgmt/ocsinventory-agent/distinfo
@@ -1,3 +1,2 @@
-MD5 (Ocsinventory-Agent-1.1.2.1.tar.gz) = 79485838881e69d1e4a7e986b52b4d16
SHA256 (Ocsinventory-Agent-1.1.2.1.tar.gz) = db1237a93334f3d6039d9e49a1cb6a03d0b90cf6f58efeacd418d1afd3ff5b97
SIZE (Ocsinventory-Agent-1.1.2.1.tar.gz) = 1401670
diff --git a/net-mgmt/ocsinventory-agent/files/patch-Makefile.PL b/net-mgmt/ocsinventory-agent/files/patch-Makefile.PL
new file mode 100644
index 000000000000..3fc062685216
--- /dev/null
+++ b/net-mgmt/ocsinventory-agent/files/patch-Makefile.PL
@@ -0,0 +1,12 @@
+--- Makefile.PL.orig 2011-01-04 17:59:37.000000000 +0000
++++ Makefile.PL 2011-01-04 18:00:04.000000000 +0000
+@@ -11,7 +11,8 @@
+ install :: all pure_install doc_install
+ $(NOECHO) $(NOOP)';
+
+- $re .= "\n\t[ ! -f run-postinst ] || $^X postinst.pl\n";
++# Disable the post install script
++# $re .= "\n\t[ ! -f run-postinst ] || $^X postinst.pl\n";
+
+ return $re;
+ }
diff --git a/net-mgmt/ocsinventory-agent/files/pkg-message.in b/net-mgmt/ocsinventory-agent/files/pkg-message.in
new file mode 100644
index 000000000000..c8ccbc967e19
--- /dev/null
+++ b/net-mgmt/ocsinventory-agent/files/pkg-message.in
@@ -0,0 +1,12 @@
+*****************************************************************
+
+This port disabled the post installtion script during the build
+process to allow the package to be built without interaction.
+
+If you wish to run this script it is located here:
+ %%SITE_PERL%%/Ocsinventory/postinst.pl
+
+Note: It may not be required to run this script depending on
+your environment.
+
+*****************************************************************
diff --git a/net-mgmt/ocsinventory-agent/pkg-plist b/net-mgmt/ocsinventory-agent/pkg-plist
index c6a1fd1590fb..42b8b8d4ab17 100644
--- a/net-mgmt/ocsinventory-agent/pkg-plist
+++ b/net-mgmt/ocsinventory-agent/pkg-plist
@@ -1,4 +1,5 @@
bin/ocsinventory-agent
+%%SITE_PERL%%/Ocsinventory/Agent.pm
%%SITE_PERL%%/Ocsinventory/Agent/AccountConfig.pm
%%SITE_PERL%%/Ocsinventory/Agent/AccountInfo.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend.pm
@@ -44,6 +45,7 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Memory.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Ports.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Slots.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/UUID.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Hostname.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Ipmi.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Lspci.pm
@@ -53,15 +55,46 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Lspci/Videos.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/BSDpkg.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/ByHand.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/Deb.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/Gentoo.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/Pacman.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/RPM.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Printers/Cups.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Processes.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Screen.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Users.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/ARM.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/ARM/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/Alpha.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/Alpha/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/MIPS.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/MIPS/CPU.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/PowerPC.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/CPU.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Controllers.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/PowerPC/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/PowerPC/Various.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/SPARC.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/SPARC/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/i386.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/i386/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/m68k.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/m68k/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/LSB.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/ArchLinux.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Debian.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Fedora.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Gentoo.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Knoppix.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Mandrake.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Mandriva.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Redhat.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Slackware.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/SuSE.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Trustix.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Ubuntu.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/VmWare.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Domains.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Drives.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Mem.pm
@@ -69,36 +102,25 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Network/Networks.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Sounds.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Sys.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Uptime.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/3ware.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/Adaptec.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/HP.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/Lsilogic.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/ServeRaid.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Debian.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Fedora.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Gentoo.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Knoppix.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Mandrake.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Mandriva.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Redhat.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Slackware.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/SuSE.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Trustix.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/Ubuntu.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/LSB.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Sys.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Uptime.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Bios.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/CPU.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Domains.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Drives.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Hostname.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/IPv4.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Mem.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Networks.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Packages.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Printers.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Sound.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Storages.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Uptime.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Video.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS.pm
@@ -116,12 +138,23 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Slots.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Storages.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Users.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Xen/XM.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/VmWareESX.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Vmsystem.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/VmWareDesktop.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/VirtualBox.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Parallels.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/SolarisZones.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Qemu.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Xen.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Libvirt.pm
%%SITE_PERL%%/Ocsinventory/Agent/Common.pm
%%SITE_PERL%%/Ocsinventory/Agent/CompatibilityLayer.pm
%%SITE_PERL%%/Ocsinventory/Agent/Config.pm
%%SITE_PERL%%/Ocsinventory/Agent/Network.pm
%%SITE_PERL%%/Ocsinventory/Agent/Option/Download.pm
%%SITE_PERL%%/Ocsinventory/Agent/XML/Inventory.pm
+%%SITE_PERL%%/Ocsinventory/Agent/XML/SimpleMessage.pm
%%SITE_PERL%%/Ocsinventory/Agent/XML/Prolog.pm
%%SITE_PERL%%/Ocsinventory/Agent/XML/Response.pm
%%SITE_PERL%%/Ocsinventory/Agent/XML/Response/Inventory.pm
@@ -137,14 +170,24 @@ bin/ocsinventory-agent
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/XML/Response
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/XML
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Option
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Xen
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Network
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/m68k
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/i386
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/SPARC
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/PowerPC
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/MIPS
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/Alpha
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/ARM
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Printers
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Lspci
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode
@@ -157,3 +200,5 @@ bin/ocsinventory-agent
@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend
@dirrm %%SITE_PERL%%/Ocsinventory/Agent
@dirrm %%SITE_PERL%%/Ocsinventory
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Ocsinventory/Agent
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Ocsinventory