aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/mediastreamer/Makefile2
-rw-r--r--net/mediastreamer/pkg-plist2
-rw-r--r--net/ortp/Makefile5
-rw-r--r--net/ortp/pkg-descr40
4 files changed, 27 insertions, 22 deletions
diff --git a/net/mediastreamer/Makefile b/net/mediastreamer/Makefile
index 39ed2a256e00..20f7eccc0c88 100644
--- a/net/mediastreamer/Makefile
+++ b/net/mediastreamer/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mediastreamer
PORTVERSION= 2.10.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SAVANNAH/linphone/mediastreamer
@@ -32,6 +33,7 @@ OPTIONS_GROUP_VIDEOOPT= FFMPEG THEORA V4L VPX XVIDEO
OPTIONS_DEFAULT= UPNP VIDEO \
GSM OPUS SPANDSP SPEEX \
FFMPEG THEORA V4L VPX XVIDEO
+OPTIONS_SUB= yes
AUDIOOPT_DESC= Audio options
diff --git a/net/mediastreamer/pkg-plist b/net/mediastreamer/pkg-plist
index c986eb008c70..85b095ee953a 100644
--- a/net/mediastreamer/pkg-plist
+++ b/net/mediastreamer/pkg-plist
@@ -55,4 +55,4 @@ share/images/nowebcamCIF.jpg
%%NLS%%share/locale/ru/LC_MESSAGES/mediastreamer.mo
%%NLS%%share/locale/sv/LC_MESSAGES/mediastreamer.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/mediastreamer.mo
-@dirrmtry include/mediastreamer2
+@dirrm include/mediastreamer2
diff --git a/net/ortp/Makefile b/net/ortp/Makefile
index a897373eed26..602de917eff2 100644
--- a/net/ortp/Makefile
+++ b/net/ortp/Makefile
@@ -7,7 +7,10 @@ CATEGORIES= net
MASTER_SITES= SAVANNAH/linphone/ortp
MAINTAINER= sobomax@FreeBSD.org
-COMMENT= Real-time Transport Protocol (RTP) stack
+COMMENT= Real-time Transport Protocol (RTP) library
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules --disable-strict
diff --git a/net/ortp/pkg-descr b/net/ortp/pkg-descr
index afed6991eeed..f846e25ef8d5 100644
--- a/net/ortp/pkg-descr
+++ b/net/ortp/pkg-descr
@@ -1,24 +1,24 @@
-oRTP - a Real-time Transport Protocol stack under LGPL.
+oRTP - Real-time Transport Protocol library
Features:
- * Written in C
- * Implement the RFC3550 (RTP) with a easy to use API with high and low level
- access.
- * Includes support for multiples profiles, AV profile (RFC1890) being the one
- by default.
- * Includes a packet scheduler for synchronizing rtp recv and send. Scheduling
- is optionnal, rtp sessions can remain not scheduled.
- * Implements blocking and non blocking IO for RTP sessions.
- * Supports mutiplexing IO, so that hundreds of RTP sessions can be managed by
- a single thread.
- * Features an adaptive jitter algorithm for a receiver to adapt to the
- clockrate of the sender.
- * Supports part of RFC2833 for telephone events over RTP.
- * The API is well documented using gtk-doc.
- * Licensed under the Lesser Gnu Public License.
- * RTCP messages sent periodically since 0.7.0 (compound packet including
- sender report or receiver report + SDES)
- * Includes an API to parse incoming RTCP packets.
+* Written in C, works under Linux (and probably any Unix) and Windows
+* Implement the RFC3550 (RTP) with a easy to use API with high and low level
+ access
+* Includes support for multiples profiles, AV profile (RFC3551) being the
+ one by default
+* Includes a packet scheduler for to send and recv packet "on time",
+ according to their timestamp. Scheduling is optionnal, rtp sessions can
+ remain not scheduled
+* Supports mutiplexing IO, so that hundreds of RTP sessions can be scheduled
+ by a single thread
+* Features an adaptive jitter algorithm for a receiver to adapt to the
+ clockrate of the sender
+* Supports part of RFC2833 for telephone events over RTP
+* The API is well documented using doxygen
+* Licensed under the Lesser Gnu Public License
+* RTCP messages sent periodically since 0.7.0 (compound packet including
+ sender report or receiver report + SDES)
+* Includes an API to parse incoming RTCP packets
-WWW: http://www.linphone.org/index.php/v2/code_review/ortp
+WWW: http://www.linphone.org/eng/documentation/dev/ortp.html