aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/gnuboy/Makefile18
-rw-r--r--emulators/gnuboy/pkg-descr2
2 files changed, 9 insertions, 11 deletions
diff --git a/emulators/gnuboy/Makefile b/emulators/gnuboy/Makefile
index 6837eaeb1e5e..6e2f9e0bf6ee 100644
--- a/emulators/gnuboy/Makefile
+++ b/emulators/gnuboy/Makefile
@@ -10,30 +10,28 @@ PORTNAME= gnuboy
PORTVERSION= 1.0.3
PORTREVISION= 8
CATEGORIES= emulators games
-MASTER_SITES= http://gnuboy.unix-fu.org/src/ \
- http://brightrain.aerifal.cx/~laguna/src/
+MASTER_SITES= http://www.sourcefiles.org/Emulators/Videogames/
MAINTAINER= ports@FreeBSD.org
COMMENT= Nintendo GameBoy emulator
-BROKEN= does not fetch
+LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib
USE_SDL= sdl
USE_XORG= x11
USE_AUTOTOOLS= autoconf
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-sdl
+MAKE_JOBS_SAFE= yes
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-.endif
-
PLIST_FILES= bin/sdlgnuboy bin/sgnuboy bin/xgnuboy
-post-patch:
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
do-install:
.for file in sdlgnuboy sgnuboy xgnuboy
@@ -41,7 +39,7 @@ do-install:
.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/emulators/gnuboy/pkg-descr b/emulators/gnuboy/pkg-descr
index 32001e4c0842..632a18b41d78 100644
--- a/emulators/gnuboy/pkg-descr
+++ b/emulators/gnuboy/pkg-descr
@@ -3,4 +3,4 @@ software platform
You can find public domain ROMs at SubPort.org
-WWW: http://gnuboy.unix-fu.org/
+WWW: http://code.google.com/p/gnuboy/