aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/mysql-connector-java/Makefile8
-rw-r--r--databases/phpmyadmin/Makefile52
-rw-r--r--mail/sa-utils/Makefile7
-rw-r--r--net/phpldapadmin/Makefile17
-rw-r--r--security/apg/Makefile7
-rw-r--r--textproc/sphinxsearch/Makefile49
-rw-r--r--www/p5-RT-Authen-ExternalAuth/Makefile5
-rw-r--r--www/p5-RT-Extension-LDAPImport/Makefile7
-rw-r--r--www/p5-RT-Extension-SLA/Makefile7
-rw-r--r--www/rt40/Makefile116
-rw-r--r--www/rt40/Makefile.cpan2
-rw-r--r--x11-fonts/gentium-basic/Makefile4
-rw-r--r--x11-fonts/gentium/Makefile4
13 files changed, 133 insertions, 152 deletions
diff --git a/databases/mysql-connector-java/Makefile b/databases/mysql-connector-java/Makefile
index 18f2baa6db3a..cdc0fa985aea 100644
--- a/databases/mysql-connector-java/Makefile
+++ b/databases/mysql-connector-java/Makefile
@@ -35,12 +35,14 @@ JDCLASSPATH= ${SRCDIR}:${CLASSPATH}
PLIST_FILES= %%JAVAJARDIR%%/${DESTJARFILE}
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
.endif
do-build:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${JAVADOCDIR} && (cd ${SRCDIR}; \
${JAVADOC} -quiet -breakiterator -encoding utf8 \
-d ${JAVADOCDIR} -package -classpath ${JDCLASSPATH} \
@@ -55,7 +57,7 @@ do-install-jar:
@${ECHO_MSG} " [ DONE ]"
do-install-apidocs:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
@${MKDIR} ${APIDOCSDIR}
@cd ${JAVADOCDIR} && for src in $$( ${FIND} . ) ; do \
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index 3f12b927a54c..546ce31e7574 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -27,25 +27,28 @@ USE_PHP= ctype session filter mbstring json spl
# want this, either turn off GD in the config dialog, or else turn off
# FONTCONFIG in the graphics/gd port options.
-OPTIONS= SUPHP "suPHP support" off \
- BZ2 "bzip2 library support" on \
- GD "GD library support (requires X11)" on \
- MYSQL "MySQL support via mysql client" off \
- MYSQLI "Improved MySQL client support" on \
- OPENSSL "OpenSSL support" on \
- PDF "PDFlib support" on \
- ZLIB "ZLIB support" on \
- MCRYPT "MCrypt library support" on \
- ZIP "Zip compression support" on \
- APC "APC (animated progress bar) support" on
+PHP_MODULE_OPTIONS= APC BZ2 GD MCRYPT OPENSSL PDF ZIP ZLIB
+OPTIONS_DEFINE= SUPHP ${PHP_MODULE_OPTIONS}
+OPTIONS_DEFAULT= APC BZ2 GD MCRYPT MYSQLI OPENSSL PDF ZIP ZLIB
+
+OPTIONS_MULTI= DB_connect
+OPTIONS_MULTI_DB_connect= MYSQL MYSQLI
+
+APC_DESC= PHP APC (animated progress bar) support
+BZ2_DESC= PHP bzip2 library support
+GD_DESC= PHP GD library support (requires X11)
+MCRYPT_DESC= PHP MCrypt library support
+MYSQLI_DESC= PHP Improved MySQL client support
+MYSQL_DESC= PHP MySQL support via mysql client
+OPENSSL_DESC= PHP OpenSSL support
+PDF_DESC= PHP PDFlib support
+SUPHP_DESC= suPHP support
+ZIP_DESC= PHP Zip compression support
+ZLIB_DESC= PHP ZLIB support
.include <bsd.port.options.mk>
-.if !defined(WITH_MYSQL) && !defined(WITH_MYSQLI)
-BROKEN= ${PKGNAME} needs at least one of WITH_MYSQL or WITH_MYSQLI in order to work
-.endif
-
-.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
+.if ${PORT_OPTIONS:MSUPHP}
PKGNAMESUFFIX= -suphp
RUN_DEPENDS+= ${LOCALBASE}/sbin/suphp:${PORTSDIR}/www/suphp
@@ -57,14 +60,14 @@ WANT_PHP_WEB= yes
.endif
-# USERS is only used WITH_SUPHP
+# USERS is only used with the SUPHP option
GROUPS?= ${WWWGRP}
CFGFILE= config.inc.php
PLIST= ${WRKDIR}/plist
PLIST_SUB+= PMA_GRP=${GROUPS}
-.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
+.if ${PORT_OPTIONS:MSUPHP}
USERS?= _pma
@@ -81,19 +84,12 @@ LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
.if !defined(WITHOUT_PHP_DEPENDS)
-# Options that default to on:
-.for opt in BZ2 GD OPENSSL PDF ZLIB MCRYPT MBSTRING ZIP APC
-. if !defined(WITHOUT_${opt}) || defined(WITH_${opt})
+.for opt in ${PHP_MODULE_OPTIONS} ${OPTIONS_MULTI_DB_connect}
+. if ${PORT_OPTIONS:M${opt}}
USE_PHP+= ${opt:L}
. endif
.endfor
-# Options that default to off:
-.for opt in MYSQLI
-. if defined(WITH_${opt}) && !defined(WITHOUT_${opt})
-USE_PHP+= ${opt:L}
-. endif
-.endfor
.endif
.SILENT:
@@ -136,7 +132,7 @@ install-conf: install-app
fi
post-install:
-.if defined(WITH_SUPHP)
+.if ${PORT_OPTIONS:MSUPHP}
${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
${CAT} ${PKGMESSAGE}
diff --git a/mail/sa-utils/Makefile b/mail/sa-utils/Makefile
index ee57bc554398..59aabfeec862 100644
--- a/mail/sa-utils/Makefile
+++ b/mail/sa-utils/Makefile
@@ -18,7 +18,8 @@ COMMENT= SpamAssassin nightly periodic maintenance
RUN_DEPENDS= sa-update:${PORTSDIR}/mail/p5-Mail-SpamAssassin
-OPTIONS= SACOMPILE "Enable sa-compile support" off
+OPTIONS_DEFINE= SACOMPILE
+SACOMPILE_DESC= "Enable sa-compile support"
NO_BUILD= yes
SUB_FILES= sa-utils
@@ -30,8 +31,8 @@ PLIST_DIRS= ${PERIODIC_DAILY} ${PERIODIC_DAILY:H}
.include <bsd.port.options.mk>
-.if defined(WITH_SACOMPILE)
-RUN_DEPENDS+= re2c>=.12.0:${PORTSDIR}/devel/re2c
+.if ${PORT_OPTIONS:MSACOMPILE}
+RUN_DEPENDS+= re2c>=0.12.0:${PORTSDIR}/devel/re2c
SUB_LIST+= SACOMPILE=YES
.else
SUB_LIST+= SACOMPILE=NO
diff --git a/net/phpldapadmin/Makefile b/net/phpldapadmin/Makefile
index 4e06a72ccda8..30b08acec145 100644
--- a/net/phpldapadmin/Makefile
+++ b/net/phpldapadmin/Makefile
@@ -22,11 +22,12 @@ USE_PHP= gettext ldap openssl pcre session xml iconv hash
DEFAULT_PHP_VER= 5
IGNORE_WITH_PHP= 4
-OPTIONS= SUPHP "suPHP support" off
+OPTIONS_DEFINE= SUPHP
+SUPHP_DESCR= suPHP support
.include <bsd.port.options.mk>
-.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
+.if ${PORT_OPTIONS:MSUPHP}
PKGNAMESUFFIX+= -suphp
RUN_DEPENDS+= ${LOCALBASE}/sbin/suphp:${PORTSDIR}/www/suphp
@@ -38,7 +39,7 @@ WANT_PHP_WEB= yes
.endif
-# USERS is only used WITH_SUPHP
+# USERS is only used when SUPHP option selected
GROUPS?= ${WWWGRP}
CFGDIR= config
CFGFILE= config.php
@@ -46,7 +47,7 @@ CFGFILE= config.php
PLIST= ${WRKDIR}/plist
PLIST_SUB+= PLA_GRP=${GROUPS}
-.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
+.if ${PORT_OPTIONS:MSUPHP}
USERS?= _pla
@@ -61,12 +62,6 @@ SUB_FILES+= pkg-message
.SILENT:
-pre-everything::
- ${ECHO_MSG} ""
- ${ECHO_MSG} "This port is PHP5 specific. If you need PHP4 support,"
- ${ECHO_MSG} "please use the net/phpldapadmin098 port instead."
- ${ECHO_MSG} ""
-
post-patch:
cd ${WRKSRC} ; \
${FIND} . ! -type d ! -name ${CFGFILE}.example ! -name .cvsignore \
@@ -101,7 +96,7 @@ install-conf:
fi
post-install:
-.if defined(WITH_SUPHP)
+.if ${PORT_OPTIONS:MSUPHP}
${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
${CAT} ${PKGMESSAGE}
diff --git a/security/apg/Makefile b/security/apg/Makefile
index accfaa4e85a5..b52fef0b1ba9 100644
--- a/security/apg/Makefile
+++ b/security/apg/Makefile
@@ -15,11 +15,12 @@ MASTER_SITE_SUBDIR= UNIX/misc
MAINTAINER= matthew@FreeBSD.org
COMMENT= An automated password generator
-OPTIONS= CRACKLIB "CrackLib support for password quality" off
+OPTIONS_DEFINE= CRACKLIB
+CRACKLIB_DESCR= CrackLib support for password quality
.include <bsd.port.options.mk>
-.if defined(WITH_CRACKLIB)
+.if ${PORT_OPTIONS:MCRACKLIB}
LIB_DEPENDS= crack:${PORTSDIR}/security/cracklib
MAKE_ARGS= -DWITH_CRACKLIB
.endif
@@ -41,7 +42,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/doc/man/apg.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/man/apgbfm.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/man/apgd.8 ${MANPREFIX}/man/man8
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}
.endif
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index 2c0a996138f3..16a8c10cd494 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -25,14 +25,19 @@ LICENSE= GPLv2
# of turning this off. So for consistency, make sure it's always on.
LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
-OPTIONS= MYSQL "MySQL support" on \
- PGSQL "PostgreSQL support" off \
- ICONV "Iconv support" on \
- OPTIMIZED_CFLAGS "Use compiler optimization (-O3)" off \
- ID64 "use 64-bit document and word IDs" off \
- UNIXODBC "unixODBC support" off \
- SYSLOG "enable logging via syslog" on \
- LIBSTEMMER "compile with libstemmer support" off
+OPTIONS_DEFINE= ICONV ID64 LIBSTEMMER MYSQL OPTIMIZED_CFLAGS PGSQL \
+ SYSLOG UNIXODBC
+
+#ICONV_DESC= Iconv support
+ID64_DESC= use 64-bit document and word IDs
+LIBSTEMMER_DESC= compile with libstemmer support
+#MYSQL_DESC= MySQL support
+#OPTIMIZED_CFLAGS_DESC= Use compiler optimization (-O3)
+#PGSQL_DESC= PostgreSQL support
+SYSLOG_DESC= enable logging via syslog
+UNIXODBC_DESC= unixODBC support
+
+OPTIONS_DEFAULT= ICONV MYSQL SYSLOG
CONFLICTS= sphinxsearch-devel-[0-9]*
@@ -41,46 +46,46 @@ CONFLICTS= sphinxsearch-devel-[0-9]*
# The port will successfully compile with both PGSQL and MYSQL support
# simultaneously. Not sure how useful that is in practice though.
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
CONFIGURE_ARGS+= --with-mysql
USE_MYSQL= yes
.else
CONFIGURE_ARGS+= --without-mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
CONFIGURE_ARGS+= --with-pgsql
USE_PGSQL= yes
.else
CONFIGURE_ARGS+= --without-pgsql
.endif
-.if defined(WITH_ICONV)
+.if ${PORT_OPTIONS:MICONV}
CONFIGURE_ARGS+= --with-iconv
USE_ICONV= yes
.else
CONFIGURE_ARGS+= --without-iconv
.endif
-.if defined(WITH_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CXXFLAGS+= -O3 -fomit-frame-pointer
.endif
# Changes document and word IDs to a 64bit type, useful if you have
# more than about 4.2E9 such items to deal with. Means corresponding
# changes in DB schema. Disabled by default.
-.if defined(WITH_ID64)
+.if ${PORT_OPTIONS:MID64}
CONFIGURE_ARGS+= --enable-id64
.endif
-.if defined(WITH_UNIXODBC)
+.if ${PORT_OPTIONS:MUNIXODBC}
CONFIGURE_ARGS+= --with-unixodbc
LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
.else
CONFIGURE_ARGS+= --without-unixodbc
.endif
-.if defined(WITH_SYSLOG)
+.if ${PORT_OPTIONS:MSYSLOG}
CONFIGURE_ARGS+= --with-syslog
.else
CONFIGURE_ARGS+= --without-syslog
@@ -100,14 +105,14 @@ CONFIGURE_ARGS+= --without-syslog
# Portuguese, Italian, Romanian, German, Dutch, Swedish, Norwegian,
# Danish, Finnish, Hungarian. Disabled by default.
-.if defined(WITH_LIBSTEMMER) || make(makesum) || defined(FETCH_ALL)
+.if ${PORT_OPTIONS:MLIBSTEMMER} || make(makesum) || defined(FETCH_ALL)
MASTER_SITES+= http://snowball.tartarus.org/dist/:libstemmer
LIBSTEMMER_TGZ= libstemmer_c.tgz
DISTFILES+= ${LIBSTEMMER_TGZ}:libstemmer
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
.endif
-.if defined(WITH_LIBSTEMMER)
+.if ${PORT_OPTIONS:MLIBSTEMMER}
CONFIGURE_ARGS+= --with-libstemmer
.else
CONFIGURE_ARGS+= --without-libstemmer
@@ -136,17 +141,17 @@ SUB_LIST+= PORTNAME=${PORTNAME} \
SPHINX_LOG=${SPHINX_LOG}
SUB_FILES+= pkg-deinstall
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
EXAMPLES= example.sql api
PORTEXAMPLES= *
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
DOCS= doc/sphinx.css doc/sphinx.html doc/sphinx.txt doc/sphinx.xml
.endif
post-extract:
-.if defined(WITH_LIBSTEMMER)
+.if ${PORT_OPTIONS:MLIBSTEMMER}
@( cd ${WRKSRC} && \
${GZIP_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${LIBSTEMMER_TGZ} \
${EXTRACT_AFTER_ARGS} )
@@ -171,7 +176,7 @@ install-bin:
${INSTALL_DATA} ${WRKSRC}/sphinx.conf.dist ${CFGFILE}.sample
install-docs:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for doc in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
@@ -179,7 +184,7 @@ install-docs:
.endif
install-examples:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
.for example in ${EXAMPLES}
@cd ${WRKSRC} && ${COPYTREE_SHARE} ${example} ${EXAMPLESDIR}
diff --git a/www/p5-RT-Authen-ExternalAuth/Makefile b/www/p5-RT-Authen-ExternalAuth/Makefile
index bcdfea5eee44..b0ebbf092d96 100644
--- a/www/p5-RT-Authen-ExternalAuth/Makefile
+++ b/www/p5-RT-Authen-ExternalAuth/Makefile
@@ -25,11 +25,12 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-OPTIONS= RT38 "Install for rt-3.8.x (default rt-4.0.x)" off
+OPTIONS_DEFINE= RT38
+RT38_DESC= Install for rt-3.8.x (default rt-4.0.x)
.include <bsd.port.options.mk>
-.if defined(WITH_RT38)
+.if ${PORT_OPTIONS:MRT38}
RT_VER= 38
.else
RT_VER= 40
diff --git a/www/p5-RT-Extension-LDAPImport/Makefile b/www/p5-RT-Extension-LDAPImport/Makefile
index 30e64131708b..6880ab877d17 100644
--- a/www/p5-RT-Extension-LDAPImport/Makefile
+++ b/www/p5-RT-Extension-LDAPImport/Makefile
@@ -24,11 +24,12 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-OPTIONS= RT38 "Install for rt-3.8.x (default rt-4.0.x)" off
+OPTIONS_DEFINE= RT38
+RT38_DESC= Install for rt-3.8.x (default rt-4.0.x)
.include <bsd.port.options.mk>
-.if defined(WITH_RT38)
+.if ${PORT_OPTIONS:MRT38}
RT_VER= 38
.else
RT_VER= 40
@@ -43,7 +44,7 @@ MAN3= RT::Extension::LDAPImport.3
PLIST_SUB+= RTHOME=share/rt${RT_VER}
# Note: You can install using an arbitrary $PREFIX but only if it
-# matches the $PREFIX used to install www/rt3{6,8}. Hence ignore
+# matches the $PREFIX used to install www/rt{38,40}. Hence ignore
# $PREFIX in the environment and inherit settings from RT.pm
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
diff --git a/www/p5-RT-Extension-SLA/Makefile b/www/p5-RT-Extension-SLA/Makefile
index 9a1188f7a687..edc749fb1cfb 100644
--- a/www/p5-RT-Extension-SLA/Makefile
+++ b/www/p5-RT-Extension-SLA/Makefile
@@ -24,11 +24,12 @@ LICENSE= GPLv2
PERL_CONFIGURE= yes
-OPTIONS= RT38 "Install for rt-3.8.x (default rt-4.0.x)" off
+OPTIONS_DEFINE= RT38
+RT38_DESC= Install for rt-3.8.x (default rt-4.0.x)
.include <bsd.port.options.mk>
-.if defined(WITH_RT38)
+.if ${PORT_OPTIONS:MRT38}
RT_VER= 38
.else
RT_VER= 40
@@ -57,7 +58,7 @@ SUB_LIST+= INITIALDATA=plugins/RT-Extension-SLA/etc/initialdata
SUB_FILES+= pkg-message
# Note: You can install using an arbitrary $PREFIX but only if it
-# matches the $PREFIX used to install www/rt3{6,8}. Hence ignore
+# matches the $PREFIX used to install www/rt{38,40}. Hence ignore
# $PREFIX in the environment and inherit settings from RT.pm
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
diff --git a/www/rt40/Makefile b/www/rt40/Makefile
index 1ef3d68c8647..3454eac127ec 100644
--- a/www/rt40/Makefile
+++ b/www/rt40/Makefile
@@ -4,12 +4,6 @@
#
# $FreeBSD$
-# TODO:
-# o GRANTS
-# o Schema
-# - Vhost Config
-# o install a sample into etc/apache22/Includes
-
PORTNAME= rt
PORTVERSION= 4.0.6
CATEGORIES= www
@@ -19,10 +13,6 @@ MASTER_SITES= http://download.bestpractical.com/pub/rt/release/ \
MAINTAINER= matthew@FreeBSD.org
COMMENT= RT is an industrial-grade ticketing system written in Perl
-.if defined(NOPORTDOCS)
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-noportdocs-Makefile.in
-.endif
-
CONFLICTS= rt-3.8*
LATEST_LINK= rt40
@@ -38,19 +28,22 @@ LATEST_LINK= rt40
# mentioned in the docs is currently unsupported in the ports, but see
# http://www.infracaninophile.co.uk/articles/sphinxse.html
-OPTIONS= AP_MODPERL "Deploy with apache and mod_perl" on \
- AP_MODFASTCGI "Deploy with apache and mod_fastcgi" off \
- LIGHTTPD "Deploy with lighttpd and mod_fastcgi" off \
- SPAWN_FCGI "Deploy with spawn_fcgi" off \
- MYSQL "Enable MySQL backend" on \
- POSTGRESQL "Enable PosgreSQL backend" off \
- ORACLE "Enable Oracle backend" off \
- SQLITE "Enable SQLite backend (dev only)" off \
- SSL_MAILGATE "Enable HTTPS support for rt-mailgate" off \
- DEV "Configure for Developers" off \
- GPG "Enable GnuPG support" on \
- GRAPHVIZ "Enable GraphViz charts" off \
- GD "Enable GD Graphs and Charts" on
+OPTIONS_DEFINE= DEV GD GPG GRAPHVIZ SSL_MAILGATE
+OPTIONS_SINGLE= DB WEB
+OPTIONS_SINGLE_DB= MYSQL ORACLE PGSQL SQLITE
+OPTIONS_SINGLE_WEB= AP_MODFASTCGI AP_MODPERL LIGHTTPD SPAWN_FCGI BUILTIN
+
+OPTIONS_DEFAULT= AP_MODPERL GD GPG MYSQL
+
+AP_MODFASTCGI_DESC= Deploy with apache and mod_fastcgi
+AP_MODPERL_DESC= Deploy with apache and mod_perl
+BUILTIN_DESC= Deploy with built-in web server (not for production)
+DEV_DESC= Configure for Developers
+GD_DESC= Enable GD Graphs and Charts
+GPG_DESC= Enable GnuPG support
+LIGHTTPD_DESC= Deploy with lighttpd and mod_fastcgi
+SPAWN_FCGI_DESC= Deploy with spawn_fcgi
+SSL_MAILGATE_DESC= Enable HTTPS support for rt-mailgate
GROUPS?= rt
@@ -75,114 +68,95 @@ USE_AUTOTOOLS= autoconf
.include <bsd.port.options.mk>
-.if defined(WITH_AP_MODPERL)
+.if !${PORT_OPTIONS:MDOCS}
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-noportdocs-Makefile.in
+.endif
-.if defined(WITH_AP_MODFASTCGI) || defined(WITH_LIGHTTPD) || \
- defined(WITH_SPAWN_FCGI)
-IGNORE= please select at most one of AP_MODPERL, AP_MODFASTCGI, LIGHTTPD or SPAWN_FCGI
+.if !${PORT_OPTIONS:MAP_MODPERL} && !${PORT_OPTIONS:MAP_MODFASTCGI} && \
+ !${PORT_OPTIONS:MLIGHTTPD} && !${PORT_OPTIONS:MSPAWN_FCGI} && \
+ !${PORT_OPTIONS:MBUILTIN}
+IGNORE= please select one of AP_MODPERL, AP_MODFASTCGI, LIGHTTPD, SPAWN_FCGI or BUILTIN
.endif
+.if ${PORT_OPTIONS:MAP_MODPERL}
BUILD_DEPENDS+= ${MODPERL2_DEPS}
RUN_DEPENDS+= ${MODPERL2_DEPS}
-
-.elif defined(WITH_AP_MODFASTCGI)
-
-.if defined(WITH_LIGHTTPD) || defined(WITH_SPAWN_FCGI)
-IGNORE= please select at most one of AP_MODPERL, AP_MODFASTCGI, LIGHTTPD or SPAWN_FCGI
.endif
+.if ${PORT_OPTIONS:MAP_MODFASTCGI}
USE_APACHE= 20+
BUILD_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
${FASTCGI_DEPS}
-
-.elif defined(WITH_LIGHTTPD)
-
-.if defined(WITH_SPAWN_FCGI)
-IGNORE= please select at most one of AP_MODPERL, AP_MODFASTCGI, LIGHTTPD or SPAWN_FCGI
.endif
+.if ${PORT_OPTIONS:MLIGHTTPD}
BUILD_DEPENDS+= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd
RUN_DEPENDS+= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd
+.endif
-.elif defined(WITH_SPAWN_FCGI)
-
+.if ${PORT_OPTIONS:MSPAWN_FCGI}
BUILD_DEPENDS+= ${LOCALBASE}/bin/spawn-fcgi:${PORTSDIR}/www/spawn-fcgi
RUN_DEPENDS+= ${LOCALBASE}/bin/spawn-fcgi:${PORTSDIR}/www/spawn-fcgi
-
.endif
-.if defined(WITH_MYSQL)
-
-.if defined(WITH_POSTGRESQL) || defined(WITH_ORACLE) || \
- defined(WITH_SQLITE)
-IGNORE= please select only one of MYSQL, POSTGRESQL, ORACLE or SQLITE
+.if !${PORT_OPTIONS:MMYSQL} && !${PORT_OPTIONS:MPGSQL} && \
+ ! ${PORT_OPTIONS:MORACLE} && !${PORT_OPTIONS:MSQLITE}
+IGNORE= please select one of MYSQL, PGSQL, ORACLE or SQLITE
.endif
+.if ${PORT_OPTIONS:MMYSQL}
DB_TYPE= mysql
USE_MYSQL= yes
BUILD_DEPENDS+= ${MYSQL_DEPS}
RUN_DEPENDS+= ${MYSQL_DEPS}
-
-.elif defined(WITH_POSTGRESQL)
-
-.if defined(WITH_ORACLE) || defined(WITH_SQLITE)
-IGNORE= please select only one of MYSQL, POSTGRESQL, ORACLE or SQLITE
.endif
+.if ${PORT_OPTIONS:MPGSQL}
DB_TYPE= Pg
USE_PGSQL= yes
-BUILD_DEPENDS+= ${POSTGRESQL_DEPS}
-RUN_DEPENDS+= ${POSTGRESQL_DEPS}
-
-.elif defined(WITH_ORACLE)
-
-.if defined(WITH_SQLITE)
-IGNORE= please select only one of MYSQL, POSTGRESQL, ORACLE or SQLITE
+BUILD_DEPENDS+= ${PGSQL_DEPS}
+RUN_DEPENDS+= ${PGSQL_DEPS}
.endif
+.if ${PORT_OPTIONS:MORACLE}
DB_TYPE= Oracle
BUILD_DEPENDS+= ${ORACLE_DEPS}
RUN_DEPENDS+= ${ORACLE_DEPS}
+.endif
-.elif defined(WITH_SQLITE)
-
+.if ${PORT_OPTIONS:MSQLITE}
DB_TYPE= SQLite
USE_SQLITE= yes
BUILD_DEPENDS+= ${SQLITE_DEPS}
RUN_DEPENDS+= ${SQLITE_DEPS}
-
-.else
-
-IGNORE= please select one of MYSQL, POSTGRESQL, ORACLE or SQLITE
-
.endif
-.if defined(WITH_DEV)
+.if ${PORT_OPTIONS:MDEV}
BUILD_DEPENDS+= ${DEV_DEPS}
RUN_DEPENDS+= ${DEV_DEPS}
CONFIGURE_ARGS+= --enable-developer-mode
.endif
-.if defined(WITH_SSL_MAILGATE)
+.if ${PORT_OPTIONS:MSSL_MAILGATE}
BUILD_DEPENDS+= ${SSL_MAILGATE_DEPS}
RUN_DEPENDS+= ${SSL_MAILGATE_DEPS}
CONFIGURE_ARGS+= --enable-ssl-mailgate
.endif
-.if defined(WITH_GRAPHVIZ)
+.if ${PORT_OPTIONS:MGRAPHVIZ}
BUILD_DEPENDS+= ${GRAPHVIZ_DEPS}
RUN_DEPENDS+= ${GRAPHVIZ_DEPS}
CONFIGURE_ARGS+= --enable-graphviz
.endif
-.if defined(WITH_GPG)
+.if ${PORT_OPTIONS:MGPG}
BUILD_DEPENDS+= ${GPG_DEPS}
RUN_DEPENDS+= ${GPG_DEPS}
CONFIGURE_ARGS+= --enable-gpg
.endif
-.if defined(WITH_GD)
+.if ${PORT_OPTIONS:MGD}
BUILD_DEPENDS+= ${GD_DEPS}
RUN_DEPENDS+= ${GD_DEPS}
configure_args+= --enable-gd
@@ -235,7 +209,7 @@ pre-fetch:
@${ECHO} " DB_DBA_PASSWORD=password Password of database administrator"
@${ECHO} " DB_USER=username Name of database user for RT (rt_user)"
@${ECHO} " DB_PASSWORD=password Name of database password for RT (rt_pass)"
-.if defined(WITH_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE}
@${ECHO} ""
@${ECHO} "SQLITE is not recommended for production use"
.endif
@@ -252,7 +226,7 @@ pre-install:
@${RM} -f ${WRKSRC}/lib/RT.pm.in
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/upgrade
(cd ${WRKSRC}/etc && \
${COPYTREE_SHARE} upgrade ${DOCSDIR} "! -name *\.in")
diff --git a/www/rt40/Makefile.cpan b/www/rt40/Makefile.cpan
index 725aa252c8fd..11e1b5ef2f74 100644
--- a/www/rt40/Makefile.cpan
+++ b/www/rt40/Makefile.cpan
@@ -113,7 +113,7 @@ MYSQL_DEPS= p5-DBD-mysql>=2.1018:${PORTSDIR}/databases/p5-DBD-mysql
ORACLE_DEPS= p5-DBD-Oracle>0:${PORTSDIR}/databases/p5-DBD-Oracle
-POSTGRESQL_DEPS= p5-DBD-Pg>=1.43:${PORTSDIR}/databases/p5-DBD-Pg
+PGSQL_DEPS= p5-DBD-Pg>=1.43:${PORTSDIR}/databases/p5-DBD-Pg
SQLITE_DEPS= p5-DBD-SQLite>=1.00:${PORTSDIR}/databases/p5-DBD-SQLite
diff --git a/x11-fonts/gentium-basic/Makefile b/x11-fonts/gentium-basic/Makefile
index d2b5e8376243..e71fd8450066 100644
--- a/x11-fonts/gentium-basic/Makefile
+++ b/x11-fonts/gentium-basic/Makefile
@@ -40,6 +40,8 @@ DOCSLIST= FONTLOG.txt GENTIUM-FAQ.txt OFL-FAQ.txt
.SILENT:
+.include <bsd.port.options.mk>
+
#
# Install
#
@@ -53,7 +55,7 @@ install-fonts:
${INSTALL_DATA} ${WRKSRC}/OFL.txt ${FONTSTGT}
install-docs:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
@for doc in ${DOCSLIST} ; do \
${INSTALL_DATA} ${WRKSRC}/$$doc ${DOCSDIR} ; \
diff --git a/x11-fonts/gentium/Makefile b/x11-fonts/gentium/Makefile
index 8be7b83f72b0..353f2be0e2b1 100644
--- a/x11-fonts/gentium/Makefile
+++ b/x11-fonts/gentium/Makefile
@@ -41,6 +41,8 @@ DOCSLIST= FONTLOG GENTIUM-FAQ Gentium-Greek-Specimen.pdf \
Gentium-RU-A3Proofs.pdf Gentium-RU-Specimen.pdf \
OFL-FAQ QUOTES README
+.include <bsd.port.options.mk>
+
.SILENT:
#
@@ -61,7 +63,7 @@ install-conf:
${PREFIX}/etc/fonts/conf.d/${FONTNAME}.conf
install-docs:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
@for doc in ${DOCSLIST} ; do \
${INSTALL_DATA} ${WRKSRC}/$$doc ${DOCSDIR} ; \