aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/mencoder/Makefile136
-rw-r--r--multimedia/mencoder/distinfo6
-rw-r--r--multimedia/mencoder/pkg-descr8
-rw-r--r--multimedia/mencoder/pkg-plist15
5 files changed, 166 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 7313b4dbcf02..10939f3d6903 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -127,6 +127,7 @@
SUBDIR += mandvd
SUBDIR += manencode
SUBDIR += manslide
+ SUBDIR += mencoder
SUBDIR += mjpegtools
SUBDIR += mjpegtools-yuvfilters
SUBDIR += mkvtoolnix
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
new file mode 100644
index 000000000000..975dd92eb33b
--- /dev/null
+++ b/multimedia/mencoder/Makefile
@@ -0,0 +1,136 @@
+# New ports collection makefile for: mencoder
+# Date created: 23 June 2007
+# Whom: Thomas E. Zander
+# $FreeBSD$
+#
+
+PORTNAME= mencoder
+PORTVERSION= ${MPLAYER_PORT_VERSION}
+COMMENT= Convenient video file and movie encoder
+RESTRICTED= Port has restricted dependencies
+
+.include "${.CURDIR}/../mplayer/Makefile.shared"
+
+OPTIONS= DEBUG "Include debug symbols in mencoder's binary files" off
+OPTIONS+= RTCPU "Let mplayer dynamically check for CPU features" on
+OPTIONS+= OCFLAGS "Use optimized compiler flags" on
+OPTIONS+= SIMD "Allow mplayer to use vector engines (MMX...)" on
+OPTIONS+= IPV6 "Include inet6 network support" on
+OPTIONS+= JACK "Enable JackIt audio server support" off
+#OPTIONS+= POLYP "Enable polyp sound server support" off
+OPTIONS+= NAS "Enable NAS sound server support" off
+OPTIONS+= OPENAL "Enable OpenAL sound support" off
+OPTIONS+= LIBUNGIF "Enable gif support" on
+OPTIONS+= LIBDV "Enable libdv support" off
+OPTIONS+= MAD "Enable mad MPEG audio engine support" off
+OPTIONS+= TWOLAME "Enable twolame MPEG audio codec support" off
+OPTIONS+= DTS "Enable DTS audio codec support" on
+OPTIONS+= LIBMPCDEC "Enable libmpcdec support" off
+OPTIONS+= FAAC "Enable FAAC audio codec support" off
+OPTIONS+= LADSPA "Enable LADSPA plugin support" off
+OPTIONS+= SPEEX "Enable speex audio codec support" off
+OPTIONS+= TREMOR "Use built-in tremor instead of libvorbis" off
+OPTIONS+= XMMS "Enable XMMS plugin support" off
+OPTIONS+= WIN32 "Enable win32 codec set on the IA32 arch" on
+OPTIONS+= THEORA "Enable ogg theora video support" off
+OPTIONS+= X264 "Enable x264 (H.264) video codec support" off
+OPTIONS+= XANIM "Enable xanim DLL support" off
+OPTIONS+= XVID "Enable XVID video codec support" on
+OPTIONS+= REALPLAYER "Enable real player plugin" off
+OPTIONS+= LIVEMEDIA "Enable LIVE555 streaming support" off
+OPTIONS+= SMB "Enable Samba input support" off
+OPTIONS+= FRIBIDI "Enable FriBiDi support" off
+OPTIONS+= LIBCDIO "Enable libcdio support" off
+OPTIONS+= CDPARANOIA "Enable cdparanoia support" off
+OPTIONS+= LIBLZO "Enable external liblzo library" off
+
+MLINKS= mplayer.1 mencoder.1
+
+PATCHDIR= ${.CURDIR}/../mplayer/files
+DATADIR= ${PREFIX}/share/mplayer
+
+TOOLFILES= calcbpp.pl countquant.pl dvd2divxscript.pl \
+ menc2pass mencvcd mp.pl subedit.pl subsearch.sh \
+ sws-test w32codec_dl.pl wma2ogg.pl x2mpsub.sh
+
+.include <bsd.port.pre.mk>
+
+LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
+BUILD_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+
+CONFIGURE_ARGS+= --disable-vidix-internal \
+ --disable-freetype \
+ --disable-x11 \
+ --disable-fontconfig \
+ --disable-rtc \
+ --disable-arts \
+ --disable-esd \
+ --disable-caca \
+ --disable-lirc \
+ --disable-sdl \
+ --disable-svga \
+ --disable-aa \
+ --disable-joystick
+
+.include "${.CURDIR}/../mplayer/Makefile.options"
+
+.if defined(WITH_TWOLAME)
+LIB_DEPENDS+= twolame.0:${PORTSDIR}/audio/twolame
+.else
+CONFIGURE_ARGS+= --disable-twolame
+.endif
+
+.if defined(WITH_FAAC)
+LIB_DEPENDS+= faac.0:${PORTSDIR}/audio/faac
+.else
+CONFIGURE_ARGS+= --disable-faac
+.endif
+
+pre-everything::
+ @${ECHO_MSG} "N - O - T - E"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "There are some knobs which *can* *not* be selected via the"
+ @${ECHO_MSG} "OPTIONS framework. As this one is a slave port of multimedia/"
+ @${ECHO_MSG} "mplayer, you might want to check mplayer's Makefile(s) in"
+ @${ECHO_MSG} "order to learn more about them."
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|libxmms.so.1|libxmms.so|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|; \
+ s|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's!/usr/local!${PREFIX}!' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${FIND} -E ${WRKSRC} -type f \
+ -iregex ".*(configure|.sh|Makefile)" -print0 | \
+ ${XARGS} -x -0 -n 10 \
+ ${REINPLACE_CMD} -E \
+ -e 's|[[:space:]]gcc[-[:digit:]\.]+| ${CC}|' \
+ -e 's|[[:space:]]gcc| ${CC}|' \
+ -e 's|\$$\(CC\)|${CC}|' \
+ -e 's|/usr/X11R6|${X11BASE}|'
+ @${FIND} ${WRKSRC}/DOCS/man -name "mplayer.1" | ${XARGS} ${REINPLACE_CMD} -E -e \
+ 's|/usr/\\:local/\\:etc/\\:mplayer|${DATADIR:S/\//\/\\\:/g}|g ; \
+ s|/dev/\\:(dvd[[:alnum:]]*[[:>:]])|${DEFAULT_DVD_DEVICE:S/dev\//dev\/\\\:/}|g ; \
+ s|/dev/\\:(cdrom[[:alnum:]]*[[:>:]])|${DEFAULT_CDROM_DEVICE:S/dev\//dev\/\\\:/}|g'
+
+post-configure:
+ @${REINPLACE_CMD} -e 's#-pthread#${PTHREAD_LIBS}#g' \
+ ${WRKSRC}/config.mak
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/mencoder ${PREFIX}/bin
+
+post-install:
+ @${MKDIR} ${DATADIR}
+ @${CHMOD} 755 ${DATADIR}
+ @${MKDIR} ${DATADIR}/tools
+ @${CHMOD} 755 ${DATADIR}/tools
+.for tool in ${TOOLFILES}
+ @${INSTALL_SCRIPT} ${WRKSRC}/TOOLS/${tool} ${DATADIR}/tools
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/mencoder/distinfo b/multimedia/mencoder/distinfo
new file mode 100644
index 000000000000..ce7f15a5afc1
--- /dev/null
+++ b/multimedia/mencoder/distinfo
@@ -0,0 +1,6 @@
+MD5 (MPlayer-1.0rc1.tar.bz2) = 18c05d88e22c3b815a43ca8d7152ccdc
+SHA256 (MPlayer-1.0rc1.tar.bz2) = 8dd9dd61a0fe56904f5b76ddedb99bd359abaaf486e0b83b45e3357fecc81063
+SIZE (MPlayer-1.0rc1.tar.bz2) = 8414213
+MD5 (asmrules_fix_20061231.diff) = f0b71c38b1207c1d604be091876ac051
+SHA256 (asmrules_fix_20061231.diff) = 3f71e6f4e07940d4d55084d0df12404371bc4e534a3a6b0756ca73e44ddbc3c4
+SIZE (asmrules_fix_20061231.diff) = 1450
diff --git a/multimedia/mencoder/pkg-descr b/multimedia/mencoder/pkg-descr
new file mode 100644
index 000000000000..21cd569f34cc
--- /dev/null
+++ b/multimedia/mencoder/pkg-descr
@@ -0,0 +1,8 @@
+The "mencoder" component of the MPlayer project is a tool which
+allows creation of video streams. It supports almost the same set
+of input sources as the player component and supports encoding from
+these sources through various codecs, including the popular ffmpeg,
+XviD and x264 families. "Transcoding" DVDs into avi files is also
+possible.
+
+WWW: http://www.mplayerhq.hu/
diff --git a/multimedia/mencoder/pkg-plist b/multimedia/mencoder/pkg-plist
new file mode 100644
index 000000000000..516b18d2a14f
--- /dev/null
+++ b/multimedia/mencoder/pkg-plist
@@ -0,0 +1,15 @@
+bin/mencoder
+%%DATADIR%%/tools/calcbpp.pl
+%%DATADIR%%/tools/countquant.pl
+%%DATADIR%%/tools/dvd2divxscript.pl
+%%DATADIR%%/tools/menc2pass
+%%DATADIR%%/tools/mencvcd
+%%DATADIR%%/tools/mp.pl
+%%DATADIR%%/tools/subedit.pl
+%%DATADIR%%/tools/subsearch.sh
+%%DATADIR%%/tools/sws-test
+%%DATADIR%%/tools/w32codec_dl.pl
+%%DATADIR%%/tools/wma2ogg.pl
+%%DATADIR%%/tools/x2mpsub.sh
+@dirrm %%DATADIR%%/tools
+@dirrmtry %%DATADIR%%