aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/xfce4-tumbler/Makefile25
-rw-r--r--deskutils/xfce4-tumbler/distinfo4
-rw-r--r--deskutils/xfce4-tumbler/pkg-plist9
3 files changed, 32 insertions, 6 deletions
diff --git a/deskutils/xfce4-tumbler/Makefile b/deskutils/xfce4-tumbler/Makefile
index 9188b93ce8b7..b1d0518e2beb 100644
--- a/deskutils/xfce4-tumbler/Makefile
+++ b/deskutils/xfce4-tumbler/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tumbler
-PORTVERSION= 0.1.22
-PORTREVISION= 1
+PORTVERSION= 0.1.23
CATEGORIES= deskutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/xfce/${PORTNAME}/${PORTVERSION:R}
@@ -39,7 +38,9 @@ OPTIONS= NLS "Enable Native Language Support" on \
JPEG "Enable JPEG and EXIF plugin thumbnailer" on \
FFMPEG "Enable FFMPEG plugin thumbnailer" off \
POPPLER "Enable PDF/PS plugin thumbnailer" on \
- GSTREAMER "Enable videos plugin thumbnailer" on
+ GSTREAMER "Enable videos plugin thumbnailer" on \
+ ODF "Enable ODF plugin thumbnailer" on \
+ RAW "Enable RAW plugin thumbnailer" off \
.include <bsd.port.pre.mk>
@@ -114,4 +115,22 @@ CONFIGURE_ARGS+=--disable-gstreamer-thumbnailer
PLIST_SUB+= GSTREAMER="@comment "
.endif
+.if !defined(WITHOUT_ODF)
+USE_GNOME+= libgsf
+CONFIGURE_ARGS+=--enable-odf-thumbnailer
+PLIST_SUB+= ODF=""
+.else
+CONFIGURE_ARGS+=--disable-odf-thumbnailer
+PLIST_SUB+= ODF="@comment "
+.endif
+
+.if defined(WITH_RAW)
+LIB_DEPENDS+= openraw.6:${PORTSDIR}/graphics/libopenraw
+CONFIGURE_ARGS+=--enable-raw-thumbnailer
+PLIST_SUB+= RAW=""
+.else
+CONFIGURE_ARGS+=--disable-raw-thumbnailer
+PLIST_SUB+= RAW="@comment "
+.endif
+
.include <bsd.port.post.mk>
diff --git a/deskutils/xfce4-tumbler/distinfo b/deskutils/xfce4-tumbler/distinfo
index 2f457058b14e..678ca9d78224 100644
--- a/deskutils/xfce4-tumbler/distinfo
+++ b/deskutils/xfce4-tumbler/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/tumbler-0.1.22.tar.bz2) = 9e41fe8f76f9422fb4f804e9635f6734552f0d82361f9971c0442a2119d451b6
-SIZE (xfce4/tumbler-0.1.22.tar.bz2) = 481203
+SHA256 (xfce4/tumbler-0.1.23.tar.bz2) = b3066d17b7e1fee5135eb876a7c2c50a1221bd0d447c3dd7c36efe6d7f3874cb
+SIZE (xfce4/tumbler-0.1.23.tar.bz2) = 479320
diff --git a/deskutils/xfce4-tumbler/pkg-plist b/deskutils/xfce4-tumbler/pkg-plist
index 22ec7b159721..82e4a683fb61 100644
--- a/deskutils/xfce4-tumbler/pkg-plist
+++ b/deskutils/xfce4-tumbler/pkg-plist
@@ -35,12 +35,18 @@ lib/tumbler-1/plugins/cache/tumbler-xdg-cache.so
%%GSTREAMER%%lib/tumbler-1/plugins/tumbler-gst-thumbnailer.a
%%GSTREAMER%%lib/tumbler-1/plugins/tumbler-gst-thumbnailer.la
%%GSTREAMER%%lib/tumbler-1/plugins/tumbler-gst-thumbnailer.so
+%%ODF%%lib/tumbler-1/plugins/tumbler-odf-thumbnailer.a
+%%ODF%%lib/tumbler-1/plugins/tumbler-odf-thumbnailer.la
+%%ODF%%lib/tumbler-1/plugins/tumbler-odf-thumbnailer.so
%%PIXBUF%%lib/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.a
%%PIXBUF%%lib/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.la
%%PIXBUF%%lib/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.so
%%POPPLER%%lib/tumbler-1/plugins/tumbler-poppler-thumbnailer.a
%%POPPLER%%lib/tumbler-1/plugins/tumbler-poppler-thumbnailer.la
%%POPPLER%%lib/tumbler-1/plugins/tumbler-poppler-thumbnailer.so
+%%RAW%%lib/tumbler-1/plugins/tumbler-raw-thumbnailer.a
+%%RAW%%lib/tumbler-1/plugins/tumbler-raw-thumbnailer.la
+%%RAW%%lib/tumbler-1/plugins/tumbler-raw-thumbnailer.so
lib/tumbler-1/tumblerd
libdata/pkgconfig/tumbler-1.pc
share/dbus-1/services/org.xfce.Tumbler.Cache1.service
@@ -69,7 +75,6 @@ share/dbus-1/services/org.xfce.Tumbler.Thumbnailer1.service
%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler-tumbler-file-info.html
%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler-tumbler-provider-factory.html
%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler-tumbler-provider-plugin.html
-%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler.devhelp
%%APIDOCS%%share/gtk-doc/html/tumbler/tumbler.devhelp2
%%APIDOCS%%share/gtk-doc/html/tumbler/up.png
%%NLS%%share/locale/ar/LC_MESSAGES/tumbler.mo
@@ -89,11 +94,13 @@ share/dbus-1/services/org.xfce.Tumbler.Thumbnailer1.service
%%NLS%%share/locale/he/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/hu/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/id/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/is/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/it/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/ja/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/kk/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/ko/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/lv/LC_MESSAGES/tumbler.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/nb/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/nl/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/pa/LC_MESSAGES/tumbler.mo