aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/hstr/Makefile20
-rw-r--r--sysutils/hstr/distinfo3
-rw-r--r--sysutils/hstr/files/patch-src-hstr.c11
-rw-r--r--sysutils/hstr/files/patch-src_Makefile.am11
-rw-r--r--sysutils/hstr/files/patch-src_include_hstr__curses.h11
-rw-r--r--sysutils/hstr/pkg-descr5
7 files changed, 62 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ba290c15ea32..222d568f60ca 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -466,6 +466,7 @@
SUBDIR += hs-ekg-core
SUBDIR += hs-ekg-json
SUBDIR += hs-mountpoints
+ SUBDIR += hstr
SUBDIR += htop
SUBDIR += httplog
SUBDIR += hwstat
diff --git a/sysutils/hstr/Makefile b/sysutils/hstr/Makefile
new file mode 100644
index 000000000000..476a8ced9a22
--- /dev/null
+++ b/sysutils/hstr/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= hstr
+DISTVERSION= 1.23
+CATEGORIES= sysutils
+
+MAINTAINER= monsieurp@gentoo.org
+COMMENT= Bash and Zsh shell history suggest box
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= autoreconf ncurses readline
+USE_GITHUB= yes
+GH_ACCOUNT= dvorka
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/hh bin/hstr man/man1/hh.1.gz man/man1/hstr.1.gz
+
+.include <bsd.port.mk>
diff --git a/sysutils/hstr/distinfo b/sysutils/hstr/distinfo
new file mode 100644
index 000000000000..464c4b4453ba
--- /dev/null
+++ b/sysutils/hstr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511211427
+SHA256 (dvorka-hstr-1.23_GH0.tar.gz) = f435b4fce473e966fe52d3c27ca9074df0925a236b01517ece022607b889af33
+SIZE (dvorka-hstr-1.23_GH0.tar.gz) = 47239
diff --git a/sysutils/hstr/files/patch-src-hstr.c b/sysutils/hstr/files/patch-src-hstr.c
new file mode 100644
index 000000000000..979d05a6a53e
--- /dev/null
+++ b/sysutils/hstr/files/patch-src-hstr.c
@@ -0,0 +1,11 @@
+--- src/hstr.c.orig 2017-09-30 10:01:44 UTC
++++ src/hstr.c
+@@ -22,6 +22,8 @@
+ #include <locale.h>
+ #ifdef __APPLE__
+ #include <curses.h>
++#elif defined(__FreeBSD__)
++#include <ncurses.h>
+ #else
+ #include <ncursesw/curses.h>
+ #endif
diff --git a/sysutils/hstr/files/patch-src_Makefile.am b/sysutils/hstr/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..b5043c75a642
--- /dev/null
+++ b/sysutils/hstr/files/patch-src_Makefile.am
@@ -0,0 +1,11 @@
+--- src/Makefile.am.orig 2017-11-23 08:02:07 UTC
++++ src/Makefile.am
+@@ -15,7 +15,7 @@
+ # limitations under the License.
+
+ # http://mij.oltrelinux.com/devel/autoconf-automake/
+-AM_CFLAGS = --pedantic -Wall -std=c99 -O2
++AM_CFLAGS = --pedantic -Wall -std=c99
+ AM_LDFLAGS =
+
+ # bin_ installs to bin; hh_ is the binary name
diff --git a/sysutils/hstr/files/patch-src_include_hstr__curses.h b/sysutils/hstr/files/patch-src_include_hstr__curses.h
new file mode 100644
index 000000000000..6d1e2572d823
--- /dev/null
+++ b/sysutils/hstr/files/patch-src_include_hstr__curses.h
@@ -0,0 +1,11 @@
+--- src/include/hstr_curses.h.orig 2017-09-30 10:01:44 UTC
++++ src/include/hstr_curses.h
+@@ -21,6 +21,8 @@
+
+ #ifdef __APPLE__
+ #include <curses.h>
++#elif defined(__FreeBSD__)
++#include <ncurses.h>
+ #else
+ #include <ncursesw/curses.h>
+ #endif
diff --git a/sysutils/hstr/pkg-descr b/sysutils/hstr/pkg-descr
new file mode 100644
index 000000000000..9d93942f22e8
--- /dev/null
+++ b/sysutils/hstr/pkg-descr
@@ -0,0 +1,5 @@
+HSTR is a command line utility that brings improved shell command completion
+based on command history. It aims to make completion easier and more efficient
+than Ctrl+R.
+
+WWW: https://github.com/dvorka/hstr