aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/kxmleditor/Makefile28
-rw-r--r--editors/kxmleditor/distinfo4
-rw-r--r--editors/kxmleditor/pkg-plist30
3 files changed, 51 insertions, 11 deletions
diff --git a/editors/kxmleditor/Makefile b/editors/kxmleditor/Makefile
index 014873695c21..ed326ef53b2c 100644
--- a/editors/kxmleditor/Makefile
+++ b/editors/kxmleditor/Makefile
@@ -6,20 +6,32 @@
#
PORTNAME= kxmleditor
-PORTVERSION= 0.8.1
-PORTREVISION= 2
-CATEGORIES= editors
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTVERSION= 1.0.0
+CATEGORIES= editors kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= kevlo@FreeBSD.org
COMMENT= XML editor for KDE
-BROKEN= "Does not compile with qt 3.3"
-
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
+USE_GMAKE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+USE_REINPLACE= yes
+
+UIFILES=kxesearchdialogbase kxeprocinstrdialogbase kxespecprocinstrdialogbase \
+ kxeelementdialogbase kxeattributedialogbase kxechardatadialogbase \
+ kxeattachdialogbase kxechoosestringdialogbase kxetreeviewsettingspage \
+ kxenewfilesettingspage kxeprintsettingspage kxearchiveextssettingspage \
+ kxetextviewsettingspage kxetexteditordialogbase
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.for i in ${UIFILES}
+ @${RM} ${WRKSRC}/part/$i.h ${WRKSRC}/part/$i.cpp
+.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11/kde3/Makefile.kde"
+.include <bsd.port.post.mk>
diff --git a/editors/kxmleditor/distinfo b/editors/kxmleditor/distinfo
index e894661369c5..55c34266d542 100644
--- a/editors/kxmleditor/distinfo
+++ b/editors/kxmleditor/distinfo
@@ -1,2 +1,2 @@
-MD5 (kxmleditor-0.8.1.tar.gz) = b3406ad8ce88443e24dc8073c2e0eb5a
-SIZE (kxmleditor-0.8.1.tar.gz) = 1038469
+MD5 (kxmleditor-1.0.0.tar.gz) = 0f34b6b8a5aa5781cb7f48c5fbcae10d
+SIZE (kxmleditor-1.0.0.tar.gz) = 1395834
diff --git a/editors/kxmleditor/pkg-plist b/editors/kxmleditor/pkg-plist
index 985919a80d1d..900211d38201 100644
--- a/editors/kxmleditor/pkg-plist
+++ b/editors/kxmleditor/pkg-plist
@@ -1,12 +1,14 @@
bin/kxmleditor
lib/libkxmleditorpart.la
lib/libkxmleditorpart.so
-lib/libkxmleditorpart.so.1.0
+lib/libkxmleditorpart.so.1
share/applnk/Applications/kxmleditor.desktop
share/apps/kxmleditor/icons/hicolor/16x16/actions/bookmark_next.png
share/apps/kxmleditor/icons/hicolor/16x16/actions/bookmark_prev.png
share/apps/kxmleditor/icons/hicolor/16x16/actions/collapse_node.png
share/apps/kxmleditor/icons/hicolor/16x16/actions/expand_node.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_cdata.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_comment.png
share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_delete_attribute.png
share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_delete_contents.png
share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_delete_element.png
@@ -21,6 +23,7 @@ share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_insert_element.png
share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_insert_procins.png
share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_move_item_down.png
share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_move_item_up.png
+share/apps/kxmleditor/icons/hicolor/16x16/actions/xml_text.png
share/apps/kxmleditor/icons/hicolor/22x22/actions/bookmark_next.png
share/apps/kxmleditor/icons/hicolor/22x22/actions/bookmark_prev.png
share/apps/kxmleditor/icons/hicolor/22x22/actions/collapse_node.png
@@ -77,18 +80,40 @@ share/apps/kxmleditor/pics/xml_procinstr.png
share/apps/kxmleditor/pics/xml_procinstr_b.png
share/apps/kxmleditor/pics/xml_text.png
share/apps/kxmleditor/pics/xml_text_b.png
+share/doc/HTML/en/kxmleditor/common
share/doc/HTML/en/kxmleditor/index.cache.bz2
share/doc/HTML/en/kxmleditor/index.docbook
+share/doc/HTML/en/kxmleditor/kparts.png
share/doc/HTML/en/kxmleditor/screenshot.png
+share/doc/HTML/en/kxmleditor/setupdefaults.png
+share/doc/HTML/en/kxmleditor/setupprintout.png
share/doc/HTML/en/kxmleditor/setupspcchr.png
share/doc/HTML/en/kxmleditor/setuptargz.png
+share/doc/HTML/en/kxmleditor/setuptexteditor.png
+share/doc/HTML/en/kxmleditor/setuptreeview.png
+share/doc/HTML/en/kxmleditor/specprocinstrdlg.png
+share/doc/HTML/en/kxmleditor/texteditor.png
share/doc/HTML/en/kxmleditor/xml.png
share/icons/hicolor/32x32/apps/kxmleditor.png
share/icons/hicolor/48x48/apps/kxmleditor.png
share/icons/locolor/16x16/apps/kxmleditor.png
share/icons/locolor/32x32/apps/kxmleditor.png
share/services/kxmleditorpart.desktop
+@unexec rmdir %D/share/services 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
+@unexec rmdir %D/share/icons 2>/dev/null || true
@dirrm share/doc/HTML/en/kxmleditor
+@unexec rmdir %D/share/doc/HTML/en 2>/dev/null || true
+@unexec rmdir %D/share/doc/HTML 2>/dev/null || true
@dirrm share/apps/kxmleditor/pics
@dirrm share/apps/kxmleditor/icons/locolor/16x16/actions
@dirrm share/apps/kxmleditor/icons/locolor/16x16
@@ -102,3 +127,6 @@ share/services/kxmleditorpart.desktop
@dirrm share/apps/kxmleditor/icons/hicolor
@dirrm share/apps/kxmleditor/icons
@dirrm share/apps/kxmleditor
+@unexec rmdir %D/share/apps 2>/dev/null || true
+@unexec rmdir %D/share/applnk/Applications 2>/dev/null || true
+@unexec rmdir %D/share/applnk 2>/dev/null || true