aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.port.mk6
-rw-r--r--lang/perl5.10/Makefile6
-rw-r--r--lang/perl5.10/files/use.perl2
-rw-r--r--lang/perl5.12/Makefile6
-rw-r--r--lang/perl5.12/files/use.perl2
-rw-r--r--lang/perl5.14/Makefile6
-rw-r--r--lang/perl5.14/files/use.perl2
-rw-r--r--lang/perl5.16/Makefile6
-rw-r--r--lang/perl5.16/files/use.perl2
-rw-r--r--lang/perl5.6/Makefile14
-rw-r--r--lang/perl5.6/files/use.perl10
-rw-r--r--lang/perl5.8/Makefile6
-rw-r--r--lang/perl5.8/files/use.perl2
-rw-r--r--lang/perl5/Makefile14
-rw-r--r--lang/perl5/files/use.perl10
15 files changed, 34 insertions, 60 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 4caa47277876..127d1bc16a7d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1173,9 +1173,9 @@ BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
.endif
-.if ${OSVERSION} >= 502100
-PERL_VERSION?= 5.8.5
-PERL_VER?= 5.8.5
+.if ${OSVERSION} >= 500036
+PERL_VERSION?= 5.8.6
+PERL_VER?= 5.8.6
.else
.if ${OSVERSION} >= 500032
PERL_VERSION?= 5.6.1
diff --git a/lang/perl5.10/Makefile b/lang/perl5.10/Makefile
index feb908223f83..4b23c9f21a6f 100644
--- a/lang/perl5.10/Makefile
+++ b/lang/perl5.10/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -90,8 +91,9 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-.if ${OSVERSION} < 502100
LATEST_LINK= perl5.8
+
+.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
.else
PKGMESSAGE= ${PKGDIR}/.not-here
@@ -151,7 +153,7 @@ post-install:
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if ${OSVERSION} < 502100
+.if ${OSVERSION} < 500036
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
.endif
diff --git a/lang/perl5.10/files/use.perl b/lang/perl5.10/files/use.perl
index c20a441b65da..57e1acde0bc8 100644
--- a/lang/perl5.10/files/use.perl
+++ b/lang/perl5.10/files/use.perl
@@ -42,7 +42,7 @@ if [ "x$this" = "xuse.perl" ]; then
else
if [ "$2" = "POST-INSTALL" ] ; then
need_remove_links=yes
- if [ $osreldate -ge 502100 ] ; then
+ if [ $osreldate -ge 500036 ] ; then
need_create_links=yes
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index feb908223f83..4b23c9f21a6f 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -90,8 +91,9 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-.if ${OSVERSION} < 502100
LATEST_LINK= perl5.8
+
+.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
.else
PKGMESSAGE= ${PKGDIR}/.not-here
@@ -151,7 +153,7 @@ post-install:
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if ${OSVERSION} < 502100
+.if ${OSVERSION} < 500036
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
.endif
diff --git a/lang/perl5.12/files/use.perl b/lang/perl5.12/files/use.perl
index c20a441b65da..57e1acde0bc8 100644
--- a/lang/perl5.12/files/use.perl
+++ b/lang/perl5.12/files/use.perl
@@ -42,7 +42,7 @@ if [ "x$this" = "xuse.perl" ]; then
else
if [ "$2" = "POST-INSTALL" ] ; then
need_remove_links=yes
- if [ $osreldate -ge 502100 ] ; then
+ if [ $osreldate -ge 500036 ] ; then
need_create_links=yes
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index feb908223f83..4b23c9f21a6f 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -90,8 +91,9 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-.if ${OSVERSION} < 502100
LATEST_LINK= perl5.8
+
+.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
.else
PKGMESSAGE= ${PKGDIR}/.not-here
@@ -151,7 +153,7 @@ post-install:
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if ${OSVERSION} < 502100
+.if ${OSVERSION} < 500036
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
.endif
diff --git a/lang/perl5.14/files/use.perl b/lang/perl5.14/files/use.perl
index c20a441b65da..57e1acde0bc8 100644
--- a/lang/perl5.14/files/use.perl
+++ b/lang/perl5.14/files/use.perl
@@ -42,7 +42,7 @@ if [ "x$this" = "xuse.perl" ]; then
else
if [ "$2" = "POST-INSTALL" ] ; then
need_remove_links=yes
- if [ $osreldate -ge 502100 ] ; then
+ if [ $osreldate -ge 500036 ] ; then
need_create_links=yes
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index feb908223f83..4b23c9f21a6f 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -90,8 +91,9 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-.if ${OSVERSION} < 502100
LATEST_LINK= perl5.8
+
+.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
.else
PKGMESSAGE= ${PKGDIR}/.not-here
@@ -151,7 +153,7 @@ post-install:
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if ${OSVERSION} < 502100
+.if ${OSVERSION} < 500036
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
.endif
diff --git a/lang/perl5.16/files/use.perl b/lang/perl5.16/files/use.perl
index c20a441b65da..57e1acde0bc8 100644
--- a/lang/perl5.16/files/use.perl
+++ b/lang/perl5.16/files/use.perl
@@ -42,7 +42,7 @@ if [ "x$this" = "xuse.perl" ]; then
else
if [ "$2" = "POST-INSTALL" ] ; then
need_remove_links=yes
- if [ $osreldate -ge 502100 ] ; then
+ if [ $osreldate -ge 500036 ] ; then
need_create_links=yes
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
diff --git a/lang/perl5.6/Makefile b/lang/perl5.6/Makefile
index 45a1d93c8625..f697736dda8d 100644
--- a/lang/perl5.6/Makefile
+++ b/lang/perl5.6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -79,23 +79,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
.error You have `USE_PERL5' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
-.if ${OSVERSION} >= 502100
-LATEST_LINK= perl5.8
-.endif
-
.if ${OSVERSION} < 500036
PKGMESSAGE= ${PKGDIR}/pkg-message-sysperl
-.elif ${OSVERSION} < 502100
-PKGMESSAGE= ${PKGDIR}/.not-here
.else
PKGMESSAGE= ${PKGDIR}/pkg-message-prefer58
.endif
-.if ${OSVERSION} >= 500036 && ${OSVERSION} < 502100
-PLIST_SUB+= NEED_USE_PERL="@comment "
-.else
PLIST_SUB+= NEED_USE_PERL=""
-.endif
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
@@ -140,9 +130,7 @@ post-install:
${BSDPAN_WRKSRC}/${file} ${BSDPAN_DEST}/${file}
.endfor
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if ${OSVERSION} < 500036 || ${OSVERSION} >= 502100
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
-.endif
.include <bsd.port.post.mk>
diff --git a/lang/perl5.6/files/use.perl b/lang/perl5.6/files/use.perl
index 916f5f288e58..c5c8d71a51c0 100644
--- a/lang/perl5.6/files/use.perl
+++ b/lang/perl5.6/files/use.perl
@@ -41,16 +41,10 @@ if [ "x$this" = "xuse.perl" ]; then
fi
else
if [ "$2" = "POST-INSTALL" ] ; then
- need_remove_links=yes
- if [ $osreldate -ge 500036 -a $osreldate -lt 502100 ] ; then
- need_create_links=yes
- need_cleanup_make_conf=yes
- need_cleanup_manpath=yes
- need_spam_make_conf=yes
- need_spam_manpath=yes
- fi
need_post_install=yes
elif [ "$2" = "POST-DEINSTALL" ] ; then
+ # XXX this needs a more intelligent handling
+ # XXX since we would not want to remove perl5.8's links
need_remove_links=yes
if [ $osreldate -lt 500036 ] ; then
need_base_system_perl=yes
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index feb908223f83..4b23c9f21a6f 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -90,8 +91,9 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-.if ${OSVERSION} < 502100
LATEST_LINK= perl5.8
+
+.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
.else
PKGMESSAGE= ${PKGDIR}/.not-here
@@ -151,7 +153,7 @@ post-install:
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if ${OSVERSION} < 502100
+.if ${OSVERSION} < 500036
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
.endif
diff --git a/lang/perl5.8/files/use.perl b/lang/perl5.8/files/use.perl
index c20a441b65da..57e1acde0bc8 100644
--- a/lang/perl5.8/files/use.perl
+++ b/lang/perl5.8/files/use.perl
@@ -42,7 +42,7 @@ if [ "x$this" = "xuse.perl" ]; then
else
if [ "$2" = "POST-INSTALL" ] ; then
need_remove_links=yes
- if [ $osreldate -ge 502100 ] ; then
+ if [ $osreldate -ge 500036 ] ; then
need_create_links=yes
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
diff --git a/lang/perl5/Makefile b/lang/perl5/Makefile
index 45a1d93c8625..f697736dda8d 100644
--- a/lang/perl5/Makefile
+++ b/lang/perl5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -79,23 +79,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
.error You have `USE_PERL5' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
-.if ${OSVERSION} >= 502100
-LATEST_LINK= perl5.8
-.endif
-
.if ${OSVERSION} < 500036
PKGMESSAGE= ${PKGDIR}/pkg-message-sysperl
-.elif ${OSVERSION} < 502100
-PKGMESSAGE= ${PKGDIR}/.not-here
.else
PKGMESSAGE= ${PKGDIR}/pkg-message-prefer58
.endif
-.if ${OSVERSION} >= 500036 && ${OSVERSION} < 502100
-PLIST_SUB+= NEED_USE_PERL="@comment "
-.else
PLIST_SUB+= NEED_USE_PERL=""
-.endif
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
@@ -140,9 +130,7 @@ post-install:
${BSDPAN_WRKSRC}/${file} ${BSDPAN_DEST}/${file}
.endfor
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if ${OSVERSION} < 500036 || ${OSVERSION} >= 502100
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
-.endif
.include <bsd.port.post.mk>
diff --git a/lang/perl5/files/use.perl b/lang/perl5/files/use.perl
index 916f5f288e58..c5c8d71a51c0 100644
--- a/lang/perl5/files/use.perl
+++ b/lang/perl5/files/use.perl
@@ -41,16 +41,10 @@ if [ "x$this" = "xuse.perl" ]; then
fi
else
if [ "$2" = "POST-INSTALL" ] ; then
- need_remove_links=yes
- if [ $osreldate -ge 500036 -a $osreldate -lt 502100 ] ; then
- need_create_links=yes
- need_cleanup_make_conf=yes
- need_cleanup_manpath=yes
- need_spam_make_conf=yes
- need_spam_manpath=yes
- fi
need_post_install=yes
elif [ "$2" = "POST-DEINSTALL" ] ; then
+ # XXX this needs a more intelligent handling
+ # XXX since we would not want to remove perl5.8's links
need_remove_links=yes
if [ $osreldate -lt 500036 ] ; then
need_base_system_perl=yes